Subject: Re: [Dots] WGLC for draft-ietf-dots-telemetry-13

From: <[email-masked]>
Date: Thu, 12 Nov 2020 14:22:08 +0000

Hi all, 

The version that takes into account the WGLC comments will be submitted next week. FWIW, the changes can be tracked here: https://tinyurl.com/dots-telemetry-latest.

Cheers,
Med

> -----Message d'origine-----
> De : Valery Smyslov [mailto:[email-masked]]
> Envoyé : mardi 27 octobre 2020 08:09
> À : [email-masked]
> Cc : [email-masked]; [email-masked]
> Objet : WGLC for draft-ietf-dots-telemetry-13
> 
> Hi,
> 
> this message starts a two-week working group last call for draft-
> ietf-dots-telemetry-13, which will end on Wednesday, November 11.
> Please, review the draft carefully and send your comments to the
> mailing list.
> 
> Regards,
> Frank & Valery.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Valery Smyslov" <[email-masked]>
Date: Fri, 13 Nov 2020 10:19:46 +0300

Hi,

the WGLC for draft-ietf-dots-telemetry-13 is over.
Some comments were received and no objections to publish this document.

Regards,
Frank & Valery.

> Hi,
> 
> this message starts a two-week working group last call for draft-ietf-dots-telemetry-13,
> which will end on Wednesday, November 11. Please, review the draft carefully and
> send your comments to the mailing list.
> 
> Regards,
> Frank & Valery.

---

From: <[email-masked]>
Date: Fri, 27 Nov 2020 12:22:53 +0000

Hi Valery, all, 

As the document is still in the WG, we suggest to make two last-minute modifications: 

(1) Add "current-" values: We found that it may be useful to share the current values especially when short measurement periods are used during attack time. The changes to support this can be seen at: https://github.com/boucadair/draft-dots-telemetry/commit/b2d62f293b43c64ee1944b2e36e37d39878b4767. 

(2) Add more units: Even if it will take long time till the numbers are hit but the goal is to make sure that compact messages are sent when such numbers are used. The change can be seen at: 
https://github.com/boucadair/draft-dots-telemetry/commit/00f4579da88295392c5be073b476296a3aec792c.

Please let us know if you have objections to include these changes in the next version that will address the yangdoctors review.

Cheers,
Jon, Tiru & Med

> Envoyé : vendredi 13 novembre 2020 08:20
> À : [email-masked]
> Objet : RE: WGLC for draft-ietf-dots-telemetry-13
> 
> Hi,
> 
> > this message starts a two-week working group last call for
> > draft-ietf-dots-telemetry-13, which will end on Wednesday,
> November
> > 11. Please, review the draft carefully and send your comments to
> the mailing list.
> >
> > Regards,
> > Frank & Valery.

---

From: "Valery Smyslov" <[email-masked]>
Date: Fri, 27 Nov 2020 15:45:16 +0300

Hi Med,

> (1) Add "current-" values: We found that it may be useful to share the current values especially when short
> measurement periods are used during attack time. The changes to support this can be seen at:
> https://github.com/boucadair/draft-dots-
> telemetry/commit/b2d62f293b43c64ee1944b2e36e37d39878b4767.
> 
> (2) Add more units: Even if it will take long time till the numbers are hit but the goal is to make sure that
> compact messages are sent when such numbers are used. The change can be seen at:
> https://github.com/boucadair/draft-dots-
> telemetry/commit/00f4579da88295392c5be073b476296a3aec792c.
> 

No objections from my side. Please, do it.

I only suggest to provide more explanations of the changes (and their justifications) to the WG,
so that the reasons for the changes are clear for those who don't follow Yangdoctors review of the draft
(so that they can chime in should they disagree).

Regards,
Valery.

---

From: <[email-masked]>
Date: Fri, 27 Nov 2020 14:21:37 -0000

Hi Valery,

I support these changes as well.

Supporting the current- variants makes good sense to me for telemetry
reporting - especially when early on into an attack the percentile-
information has not had enough time to necessarily give meaningful values
and the attack may have already started to drop away from the peak- values.
Implementations may also find it easier to report on current- and peak- than
spend time on computing percentiles which requires extra CPU time and RAM
storage for the interim holding of samples.

Extending the list of enums as to the scaling of the reported values, while
I trust that we will not see DDoS attacks of this scale, there is that
future potential possibility, so adding in enums for peta, exa and zetta
scaling would be useful to do now.

Regards

Jon

> -----Original Message-----
> From: Dots [mailto: [email-masked]] On Behalf Of Valery
> Smyslov
> Sent: 27 November 2020 12:45
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Dots] WGLC for draft-ietf-dots-telemetry-13
> 
> Hi Med,
> 
> > (1) Add "current-" values: We found that it may be useful to share the
current
> values especially when short
> > measurement periods are used during attack time. The changes to support
this
> can be seen at:
> > (2) Add more units: Even if it will take long time till the numbers are
hit but the
> goal is to make sure that
> > Please let us know if you have objections to include these changes in
the next
> version that will address the
> > yangdoctors review.
> 
> _________________________________________________________________
> ___________________________
> > _____________________________
> >
> > Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne
> > doivent donc
> > pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
recu ce
> message par erreur, veuillez le
> > signaler
> > a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles
> > d'alteration,
> > Orange decline toute responsabilite si ce message a ete altere, deforme
ou
> falsifie. Merci.
> >
> > This message and its attachments may contain confidential or privileged
> information that may be protected
> > by law;
> > If you have received this email in error, please notify the sender and
delete this
> message and its attachments.
> > As emails may be altered, Orange is not liable for messages that have
been
> modified, changed or falsified.
> > Thank you.
> 
> 
> _______________________________________________
> Dots mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dots