Subject: [Dtls-iot] DICE related drafts list

From: Zach Shelby <[email-masked]>
Date: Mon, 8 Jul 2013 10:51:45 +0300

Hi,

I update the list of drafts related to or submitted for DICE. Please let me know if we are missing something:

Profiling Work Item Strawman

http://tools.ietf.org/html/draft-keoh-dtls-profile-iot-00

Existing work

http://www.ietf.org/id/draft-keoh-lwig-dtls-iot-01.txt
http://www.ietf.org/id/draft-hartke-core-codtls-02.txt
http://www.ietf.org/id/draft-tschofenig-lwig-tls-minimal-02.txt
http://www.ietf.org/id/draft-keoh-tls-multicast-security-00.txt
http://www.ietf.org/id/draft-keoh-dtls-multicast-security-00.txt
http://www.ietf.org/id/draft-ietf-tls-oob-pubkey-07.txt
http://www.ietf.org/id/draft-jennings-core-transitive-trust-enrollment-01.txt
http://tools.ietf.org/html/draft-schmitt-two-way-authentication-for-iot-00
http://tools.ietf.org/html/draft-greevenbosch-dice-authent-author-revoc-00

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com @SensinodeIoT
Mobile: +358 40 7796297
Twitter: @zach_shelby
LinkedIn: http://fi.linkedin.com/in/zachshelby
6LoWPAN Book: http://6lowpan.net

---

From: Bert Greevenbosch <[email-masked]>
Date: Mon, 8 Jul 2013 09:36:31 +0000

Hi Zach,

Thanks for updating the list. I see that you replaced the draft-greevenbosch-tls-ocsp-lite by the use cases and requirements document draft-greevenbosch-dice-authent-author-revoc. That is fine; indeed draft-greevenbosch-dice-authent-author-revoc draft is more relevant to DICE at this stage.

As I have mentioned before, I think revocation is an essential part of a sound security system. I think we should provide a good and solid solution in DICE, not just a quick solution that works but has security holes. I hope the use cases in my draft reflect the wide application and associated issues I see for DICE.

So I think we should not defer revocation to a possible re-chartering of DICE in the future, but consider it well from the beginning.

Best regards,
Bert

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Zach Shelby
Sent: 2013年7月8日 15:52
To: [email-masked]
Subject: [Dtls-iot] DICE related drafts list

Hi,

Existing work

_______________________________________________
dtls-iot mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtls-iot

---

From: Zach Shelby <[email-masked]>
Date: Mon, 8 Jul 2013 15:57:30 +0300

> Thanks for updating the list. I see that you replaced the draft-greevenbosch-tls-ocsp-lite by the use cases and requirements document draft-greevenbosch-dice-authent-author-revoc. That is fine; ind…

Oops, did not mean to remove that. Now the link to draft-greevenbosch-tls-ocsp-lite is included in the list again.

> So I think we should not defer revocation to a possible re-chartering of DICE in the future, but consider it well from the beginning.

Right. However it is pretty clear from the discussion that we don't have a common use case or a well-enough scoped solution yet to actual work on a solution in this charter. What would you propose that we work on? The problem statement and requirements? 

Zach

---

From: Bert Greevenbosch <[email-masked]>
Date: Tue, 9 Jul 2013 02:34:20 +0000

Hi Zach, all,

>Oops, did not mean to remove that. Now the link to draft-greevenbosch-tls-ocsp-lite is included in the list again.

OK, thanks. No problem. :-)

> Right. However it is pretty clear from the discussion that we don't have a common use case or a well-enough scoped solution yet to actual work on a solution in this charter. What would you propose…

draft-greevenbosch-dice-authent-author-revoc indeed points at the problem statement and requirements. The draft proposes addition of the following text to the charter:
"The DICE working group will carefully consider the aspects of authentication, authorisation and revocation, and define or re-use related mechanisms where appropriate."

I think this captures it pretty well. When we design the security solution, we need to keep authentication, authorisation and revocation in mind. That may mean referencing existing technology and pointing out where to apply it, or it may require definition of new technology. The main point is, that it should not be neglected, but that it deserves its place in the security design and analysis.

Best regards,
Bert

-----Original Message-----
From: Zach Shelby [mailto:[email-masked]] 
Sent: 2013年7月8日 20:58
To: Bert Greevenbosch
Cc: [email-masked]
Subject: Re: [Dtls-iot] DICE related drafts list

Zach

---

From: Likepeng <[email-masked]>
Date: Wed, 10 Jul 2013 02:01:54 +0000

>The draft proposes addition of the following text to the charter:

+1.

We can add the proposed text in the draft charter for now and discuss it in Berlin F2F.

Thanks,
Kind Regards
Kepeng

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 Bert Greevenbosch
发送时间: 2013年7月9日 10:34
收件人: Zach Shelby
抄送: [email-masked]
主题: Re: [Dtls-iot] DICE related drafts list

Hi Zach, all,

Best regards,
Bert

-----Original Message-----
From: Zach Shelby [mailto:[email-masked]] 
Sent: 2013年7月8日 20:58
To: Bert Greevenbosch
Cc: [email-masked]
Subject: Re: [Dtls-iot] DICE related drafts list

Zach