Subject: [Dtls-iot] Updated BOF information

From: Zach Shelby <[email-masked]>
Date: Mon, 29 Jul 2013 19:47:33 +0200

Hi Everyone,

We're getting prepared for the DICE BOF this Wed at 15.10 in Potsdam 3, everyone is encouraged to not only attend but get involved hands-on. 

I have updated the Google Doc for the group, now including the BOF agenda along with Q&As we should be prepared for in the BOF. If you think of a possible question (and answer), please add that to the document directly. 

https://docs.google.com/document/d/1Gw00WXRgjJJQJMv9seVpuXuLtIDYKhHE-7pX4eDo3g8

We do realise there have been many documents sent to DICE on revocation and authorisation, however as this is a 1 hour BOF we have only been able to include short presentations on Profiling and DTLS record-layer group communications during the BOF as near-term issues. Regarding revocation and authorisation we clearly need to find a home for that work, which was extensively discussed today in the CoRE WG meeting. Whether that is a new WG or a future task for DICE after our first charter is complete, I think we are all open to. For now we are listing it as possible future work for DICE.

Tonight Carsten and I will send around a draft of the BOF slides we plan to present for comments. We will also pass around the Profiling and Group DTLS slides for comments as they are available.

The proposed charter (found in the Google Doc) also needs a final round of editing, especially around scope. We will start a separate thread on this.  

Regards,
Zach

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://www.sensinode.com @SensinodeIoT
Mobile: +358 40 7796297
Twitter: @zach_shelby
LinkedIn: http://fi.linkedin.com/in/zachshelby
6LoWPAN Book: http://6lowpan.net

---

From: Corinna Schmitt <[email-masked]>
Date: Tue, 30 Jul 2013 07:16:32 +0200

Dear Zach,

thanks for the updated agenda.
It sound of having lots of work in one hour.

Just for information concerning our draft 
http://tools.ietf.org/html/draft-schmitt-two-way-authentication-for-iot-00:
We already started to implemented a solution and evaluated a little bit. 
So we would be glad if our draft will be approved and stay in DICE.

If you need help, let me know.
See you on Wednesday,

Corinna

--

---

From: Zach Shelby <[email-masked]>
Date: Tue, 30 Jul 2013 10:08:37 +0200

Hi Corinna,

On Jul 30, 2013, at 7:16 AM, Corinna Schmitt <[email-masked]> wrote:

> Just for information concerning our draft http://tools.ietf.org/html/draft-schmitt-two-way-authentication-for-iot-00:
> We already started to implemented a solution and evaluated a little bit. So we would be glad if our draft will be approved and stay in DICE.

Your draft was actually discussed yesterday in the CoRE WG meeting in the scope of general authentication and authorisation in CoRE. This subject will be out of scope for the first DICE charter as we already have a couple concrete problems to solve. It is not clear where the "AA" work will end up, probably in some other new working group, or maybe in some future re-chartering of DICE. 

Cheers,
Zach

---

From: "QiMinpeng" <[email-masked]>
Date: Tue, 30 Jul 2013 16:12:16 +0800

Dear Zach,

After I reviewed the google doc, I still wonder why authentication for
secure group communication is out of DICE scope. I agree that using
public-key signature could be a good approach. However, we should notice
that IoT device is constrained devices, which does not have strong enough
capabilities. This will cause some problems when public-key signature (esp.
cert) is used. Some other authentication solution should be considered also.
So I think it would be better to involve the authentication for secure group
communication in DICE scope.

BRs，

Minpeng Qi
China Mobile Research Institute
[email-masked]
+86 13910023873 

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表
Zach Shelby
发送时间: 2013年7月30日 1:48
收件人: [email-masked]
主题: [Dtls-iot] Updated BOF information

Hi Everyone,

We're getting prepared for the DICE BOF this Wed at 15.10 in Potsdam 3,
everyone is encouraged to not only attend but get involved hands-on. 

I have updated the Google Doc for the group, now including the BOF agenda
along with Q&As we should be prepared for in the BOF. If you think of a
possible question (and answer), please add that to the document directly. 

https://docs.google.com/document/d/1Gw00WXRgjJJQJMv9seVpuXuLtIDYKhHE-7pX4eDo
3g8

We do realise there have been many documents sent to DICE on revocation and
authorisation, however as this is a 1 hour BOF we have only been able to
include short presentations on Profiling and DTLS record-layer group
communications during the BOF as near-term issues. Regarding revocation and
authorisation we clearly need to find a home for that work, which was
extensively discussed today in the CoRE WG meeting. Whether that is a new WG
or a future task for DICE after our first charter is complete, I think we
are all open to. For now we are listing it as possible future work for DICE.

Tonight Carsten and I will send around a draft of the BOF slides we plan to
present for comments. We will also pass around the Profiling and Group DTLS
slides for comments as they are available.

The proposed charter (found in the Google Doc) also needs a final round of
editing, especially around scope. We will start a separate thread on this.  

Regards,
Zach

_______________________________________________
dtls-iot mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtls-iot

---

From: Olaf Bergmann <[email-masked]>
Date: Tue, 30 Jul 2013 10:20:44 +0200

Zach Shelby <[email-masked]> writes:

>> We already started to implemented a solution and evaluated a little
>> bit. So we would be glad if our draft will be approved and stay in
>> DICE.
>
> Your draft was actually discussed yesterday in the CoRE WG meeting in
> the scope of general authentication and authorisation in CoRE. This
> subject will be out of scope for the first DICE charter as we already
> have a couple concrete problems to solve. It is not clear where the
> "AA" work will end up, probably in some other new working group, or
> maybe in some future re-chartering of DICE.

The discussion yesterday was a bit low on the guidance level how to
proceed. Even if this topic is not the most pressing for DICE, I highly
recommend to work on this space *now*.

Corinna, maybe we could team up with the other authors of the relevant
drafts to find out what the next steps are? We had a quick talk with
Göran yesterday, and he also had the impression that the WG could have
been more active in giving feedback on these drafts.

Gruesse
Olaf

---

From: Zach Shelby <[email-masked]>
Date: Tue, 30 Jul 2013 11:22:45 +0200

(sorry for the cross-mailing list traffic)

Olaf,

This is the first IETF where this cluster of new AA proposals have come out of the woodwork, so be patient finding a home for it. DICE is really about optimising the use of DTLS in IoT, and we're keeping that focus for at least the first charter as we have a couple very focused problems to solve.

Regarding the AA presentations that were given in CoRE yesterday. Yes I do agree that the IETF should work in this area, but it was also clear yesterday in CoRE that we don't all understand the set of requirements that need to be solved. We are still living in the solution looking for a problem phase. In addition to that there are also revocation proposals that have been submitted recently, and a clear need for ACL management. 

The nice thing about the IETF, is that even if you don't have a home for work yet, you can still work on it. I would encourage the authors doing AA and revocation related work to get together, figure out what the actual problems to be solved are (talk to industry too) and then combine solutions. CoRE is still probably a good mailing list to do that on for now. As more people are agreeing about the problem space and are interested to work on the (same) problem, we can find/make a home.

Zach

---

From: Corinna Schmitt <[email-masked]>
Date: Tue, 30 Jul 2013 11:51:11 +0200

Dear Olaf,

thanks for your remark.
I think authentication is a big topic especially for constraint devices.

And yes, I agree for team up.
Due to many travelling I will arrive in Berlin late afternoon and have 
to leave tomorrow evening again.
Perhaps we can find some time to discuss it  as soon as possible. 
Tomorrow morning I am free. So if any one has time we can meet.
I stay at the Pestana Berlin Tiergarten, but will be at the meeting 
location after breakfast.

For the dinner tonight I have no ticket. So I cannot join if no one has 
one for me.

Regards,
Corinna

Reiseplan: Druckvorschau

--

---

From: Göran Selander <[email-masked]>
Date: Tue, 30 Jul 2013 10:32:33 +0000

Hi Corinna, Olaf,

I'm also interested in this discussion.

I didn't intend to complain on lack of feedback. Here are my concerns:

  1.  To find a home for work on authorization and access control in constrained environments. The proposals on the table are really building on DTLS and COAP, so either CORE or DICE seems right to me. In the CORE WG there were a set of people showing hands of interest.
  2.  To be able to work on this now as there is a potential dependence on other ongoing things (e.g. access control in resource directory).
  3.  To make sure that the CORE and "DTLS in constrained environments"-related questions brought up in these drafts are coordinated with CORE and DICE. This includes stuff like DTLS client and server key provisioning schemes alternative to the CoAP security modes and the use of these for DoS mitigation in DTLS.

Regards,
Göran

From: Corinna Schmitt <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 30, 2013 11:51 AM
To: Olaf Bergmann <[email-masked]<mailto:[email-masked]>>
Cc: Zach Shelby <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Dtls-iot] Updated BOF information

Dear Olaf,

thanks for your remark.

And yes, I agree for team up.
Due to many travelling I will arrive in Berlin late afternoon and have to leave tomorrow evening again.
Perhaps we can find some time to discuss it  as soon as possible. Tomorrow morning I am free. So if any one has time we can meet.
I stay at the Pestana Berlin Tiergarten, but will be at the meeting location after breakfast.

For the dinner tonight I have no ticket. So I cannot join if no one has one for me.

Regards,
Corinna

Zach Shelby <[email-masked]><mailto:[email-masked]> writes:

Hi Corinna,

On Jul 30, 2013, at 7:16 AM, Corinna Schmitt <[email-masked]><mailto:[email-masked]> wrote:

Gruesse
Olaf
_______________________________________________
dtls-iot mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/dtls-iot

--

---

From: Olaf Bergmann <[email-masked]>
Date: Tue, 30 Jul 2013 13:08:46 +0200

Göran Selander <[email-masked]> writes:

> I didn't intend to complain on lack of feedback.

Sorry, my mistake. I did not intend to blame anybody.

Gruesse
Olaf

---

From: "QiMinpeng" <[email-masked]>
Date: Tue, 30 Jul 2013 19:43:07 +0800

Hi Corinna, Olaf, and Goran,

I’m interested in this discussion, too.

As I said in another email, I have the same opinion that the authentication should be considered carefully for the IoT devices.

Minpeng

发件人: [email-masked] [mailto:[email-masked]] 代表 G?ran Selander
发送时间: 2013年7月30日 18:33
收件人: Corinna Schmitt; Olaf Bergmann
抄送: Zach Shelby; [email-masked]
主题: Re: [Dtls-iot] Updated BOF information

Hi Corinna, Olaf,

Regards,

Göran

From: Corinna Schmitt <[email-masked]>
Date: Tuesday, July 30, 2013 11:51 AM
To: Olaf Bergmann <[email-masked]>
Cc: Zach Shelby <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Dtls-iot] Updated BOF information

Dear Olaf,

thanks for your remark.

Regards,
Corinna 

Zach Shelby  <mailto:[email-masked]> <[email-masked]> writes:

Hi Corinna,
 
On Jul 30, 2013, at 7:16 AM, Corinna Schmitt  <mailto:[email-masked]> <[email-masked]> wrote:

 
 
Gruesse
Olaf
_______________________________________________
dtls-iot mailing list
[email-masked]://www.ietf.org/mailman/listinfo/dtls-iot

--

---

From: Göran Selander <[email-masked]>
Date: Tue, 30 Jul 2013 12:23:43 +0000

Hi Zach,

Sorry for being out of sync. You answered 1-2 before I sent my mail. And we maintain the coordination with CORE by keeping the discussion on that list.

On point 3, that is also about "optimising the use of DTLS in IoT" so is addressing the high level scope of DICE. I can't say yet if there is any impact on the DTLS profile or group keys with the DTLS record layer but we can take this discussion in the DICE BOF.

Thanks,
Göran

From: Göran Selander <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 30, 2013 12:32 PM
To: Corinna Schmitt <[email-masked]<mailto:[email-masked]>>, Olaf Bergmann <[email-masked]<mailto:[email-masked]>>
Cc: Zach Shelby <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Dtls-iot] Updated BOF information

Hi Corinna, Olaf,

Regards,
Göran

Dear Olaf,

thanks for your remark.

Regards,
Corinna

Hi Corinna,

Gruesse
Olaf

--

---

From: Zach Shelby <[email-masked]>
Date: Tue, 30 Jul 2013 14:29:42 +0200

> On point 3, that is also about "optimising the use of DTLS in IoT" so is addressing the high level scope of DICE. I can't say yet if there is any impact on the DTLS profile or group keys with the D…

Sure, but to successfully start (and execute) a working group in the IETF you need a very focused scope. Right now, working on AA is clearly out-of-scope for DICE. However, it will be up to the WG and the IESG later on if we can or want to recharter to expand/change scope. 

The security management and AA topic is a large one, and although important, I suspect would probably need its own working group in the security area. CoRE is a fine place to start some work though. 

Regards,
Zach

---

From: Michael Richardson <[email-masked]>
Date: Tue, 30 Jul 2013 08:42:36 -0400

I just read schmitt-two-way-authentication-for-iot-00.
Minor comments:

      In the Internet, identities are usually
      established via public key cryptography (PKC) and identifiers are
      provided through X.509 certificates.

this just isn't true, as much as people would like. HTTPS servers are
identified that way, the identifiers poor.  Nothing else, alas, uses this.

I think that I missed a protocol or standard.

I think it's just saying, "use DTLS with a TPM chip"

I didn't see anything about trust, authorization, etc.

What's the point of this document?

--
Michael Richardson <[email-masked]>, Sandelman Software Works

---

From: "Kumar, Sandeep" <[email-masked]>
Date: Tue, 30 Jul 2013 12:59:32 +0000

Hi Göran and all

I share the view that authorization is important for constrained devices, and key provisioning during this process provides advantages. However the final solution should also look at the larger problem of bootstrapping, general key management and revocation which are all inter-related in some way. Reusing DTLS for this would be preferred to reduce the need for yet another security protocol on these devices. We had a draft in LWIG (draft-keoh-lwig-dtls-iot-01) which discusses the use of DTLS for the key management, we assumed authorizations were being done with acls. And as Sye mentioned during CoRe, we had some similar work done with assertions and would be interested to join any discussions you guys plan to have.

Regards
Sandeep

From: [email-masked] [mailto:[email-masked]] On Behalf Of Göran Selander
Sent: Tuesday, July 30, 2013 2:24 PM
To: Zach Shelby; [email-masked]
Subject: Re: [Dtls-iot] Updated BOF information

Hi Zach,

Thanks,
Göran

Hi Corinna, Olaf,

Dear Olaf,

thanks for your remark.

Regards,
Corinna

Hi Corinna,

DICE.

Gruesse

Olaf

dtls-iot mailing list

--

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Göran Selander <[email-masked]>
Date: Tue, 30 Jul 2013 13:24:01 +0000

Hi Zach

On 7/30/13 2:29 PM, "Zach Shelby" <[email-masked]> wrote:

>> On point 3, that is also about "optimising the use of DTLS in IoT" so
>>is addressing the high level scope of DICE. I can't say yet if there is
>>any impact on the DTLS profile or group keys with the DTLS record layer
>>but we can take this discussion in the DICE BOF.
>
>Sure, but to successfully start (and execute) a working group in the IETF
>you need a very focused scope. Right now, working on AA is clearly
>out-of-scope for DICE. However, it will be up to the WG and the IESG
>later on if we can or want to recharter to expand/change scope.
>
>The security management and AA topic is a large one, and although
>important, I suspect would probably need its own working group in the
>security area. CoRE is a fine place to start some work though.

I'm fine with this. Just want to stress that point 3 was the part which
was specifically *not* about authorization and access control, but about
potential consequences/benefits of the key management solution implied by
doing access control in the proposed way.

Regards,
Göran

---

From: Göran Selander <[email-masked]>
Date: Tue, 30 Jul 2013 15:04:13 +0000

Hi Sandeep and all,

I fully agree that there is a bigger picture to be considered and that DTLS must be supported. I am also interested in the areas you list but to keep the discussion focused I may be important to find a initial common denominator where a number of people could contribute  and then build upon that.

Olaf is arranging a lunch meeting tomorrow for the authorization discussions,  anyone interested in that can join. We'll meet  after the morning session (~11:35) in the Wintergarten which is in front of the LA Cafe.

Regards,
Göran

From: <Kumar>, Sandeep <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 30, 2013 2:59 PM
To: Göran Selander <[email-masked]<mailto:[email-masked]>>, Zach Shelby <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Dtls-iot] Updated BOF information

Hi Göran and all

Regards
Sandeep

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Göran Selander
Sent: Tuesday, July 30, 2013 2:24 PM
To: Zach Shelby; [email-masked]<mailto:[email-masked]>
Subject: Re: [Dtls-iot] Updated BOF information

Hi Zach,

Thanks,
Göran

Hi Corinna, Olaf,

Dear Olaf,

thanks for your remark.

Regards,
Corinna

Hi Corinna,

DICE.

Gruesse

Olaf

dtls-iot mailing list

--

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 30 Jul 2013 17:39:58 +0200

<CoRE chair speaking here>

On Jul 30, 2013, at 10:20, Olaf Bergmann <[email-masked]> wrote:

> proceed.

Well, it was cut short.

> Even if this topic is not the most pressing for DICE, I highly

That would be exactly my guidance.
-- try to find out what is the (in my view, sizable) common ground and document this quickly;
-- look at what is different between the approaches (e.g., node requirements/crypto schemes, roles/trust models, ...), and document them for each specific approach;
-- clarify what actually needs to be standardized to make this happen.

We can continue the work that is on top of DTLS in CoRE.  CoRE has this in its charter:

> Security, particularly keying of new Devices, is very challenging for
> these applications. The WG will work to select approaches to security
> bootstrapping which are realistic given the constraints and requirements
> of the network. To ensure that any two nodes can join together, all
> nodes must implement at least one universal bootstrapping method.
> 
> Security can be achieved using either session security or object
> security. For both object and session security, the WG will work with
> the security area to select appropriate security framework and protocol
> as well as selecting a minimal required to implement cipher suite. CoAP
> will initially look at CMS (RFC 5652), TLS/DTLS, and EAP.

After three years, this clearly needs to be updated, but it is still a good basis to look at:
-- object security for setting up security relationships,
-- providing a way that "any two nodes can join together", which does include establishing authorization between (very constrained) nodes in my view.

So let's not try to cram into DICE what already is legitimately a part of CoRE.

(Once we understand what we really want to standardize in this space, we should request a CoRE charter update, and that may be the point when we decide all this may be too much for CoRE and some things need to be outplaced.)

Grüße, Carsten

---

From: Corinna Schmitt <[email-masked]>
Date: Tue, 30 Jul 2013 18:45:35 +0200

Dear Carsten,

we will meet tomorrow for lunch at 11:35 in Wintergarten.
Perhaps it would be helpful for us if you have time to join.
I would look forward if our draft will be integrated in a WG, because it 
is a hot topic.

Regards,
Corinna

--