Subject: [Dtls-iot] Updated charter text - if you can respond today, that'd be nice for dice

From: Stephen Farrell <[email-masked]>
Date: Thu, 12 Sep 2013 15:02:39 +0100

Hi all,

Based on quite a few comments from the IESG [1] and in
particular largely based on Jari's suggested re-write,
I've crafted new charter text. [2]

Note that all the comments are essentially supportive
of the work, but various ADs have problems with the
-00 text.

Please review and comment on the -01 version.

If I got a number of positive comments in the next 3
hours that would be helpful, as we'll be discussing
this around then on today's IESG telechat. If you hate
it, knowing that in the same timeframe would also be
as useful:-) Silence is not useful.

Sorry about the late notice, but don't worry too much,
this is intended to mean exactly the same thing, just
with a lot fewer words, and it'll go out for IETF wide
review in any case, so there's lots of time to fix
anything that I've accidentally broken.

Thanks,
Stephen.

[1] https://datatracker.ietf.org/doc/charter-ietf-dice/ballot/
[2] https://datatracker.ietf.org/doc/charter-ietf-dice/

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 12 Sep 2013 16:14:44 +0200

> Please review and comment on the -01 version.

I like the much more concise approach.
This does lose some background information, but as charters tend to live for a while, that kind of background information also tends to get dated quickly.

(What I didn't notice with 00-00:  One WG-in-formation that DICE probably wants to coordinate with is 6lo, re header compression support for DTLS.)

Grüße, Carsten

---

From: "Kumar, Sandeep" <[email-masked]>
Date: Thu, 12 Sep 2013 14:34:18 +0000

+1 for the concise charter.

Based on one of the blocks of the IESG on "state machine" I suggest to change "The DTLS state machine should not be modified and ..." with "The DTLS Record Payload protection should not be modified and ...". The only state machine reference in DTLS RFC is to the handshake state machine which we are not concerned with anyways.

Regards
Sandeep

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stephen Farrell
Sent: Thursday, September 12, 2013 4:03 PM
To: [email-masked]
Subject: [Dtls-iot] Updated charter text - if you can respond today, that'd be nice for dice

Hi all,

Based on quite a few comments from the IESG [1] and in particular largely based on Jari's suggested re-write, I've crafted new charter text. [2]

Note that all the comments are essentially supportive of the work, but various ADs have problems with the
-00 text.

If I got a number of positive comments in the next 3 hours that would be helpful, as we'll be discussing this around then on today's IESG telechat. If you hate it, knowing that in the same timeframe would also be as useful:-) Silence is not useful.

Sorry about the late notice, but don't worry too much, this is intended to mean exactly the same thing, just with a lot fewer words, and it'll go out for IETF wide review in any case, so there's lots of time to fix anything that I've accidentally broken.

Thanks,
Stephen.

[1] https://datatracker.ietf.org/doc/charter-ietf-dice/ballot/
[2] https://datatracker.ietf.org/doc/charter-ietf-dice/
_______________________________________________
dtls-iot mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtls-iot

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Robert Cragie <[email-masked]>
Date: Thu, 12 Sep 2013 15:59:56 +0100

I also like the concise approach. A couple of points however:

1) "small devices" seems a bit too vague (and could mean just physically
small) so I would include the more descriptive text from the original
charter, e.g. something like "devices which are constrained by power and
have limited amount of code size and memory"

2) I think the concept of group communication should also be a little
clearer than just "multicast among a set of receivers" - again, perhaps
some text from the original charter should be included.

Robert

---

From: Ludwig Seitz <[email-masked]>
Date: Thu, 12 Sep 2013 17:28:26 +0200

> have limited amount of code size and memory"

I suggest to refer to draft-ietf-lwig-terminology, where these are 
defined as "constrained devices".

/Ludwig

-- 
Ludwig Seitz, PhD
SICS Swedish ICT AB
Ideon Science Park
Building Beta 2
Scheelevägen 17
SE-223 70 Lund

Phone +46(0)70-349 92 51
http://www.sics.se

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 12 Sep 2013 16:34:54 +0100

Ack, will add.

S

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 12 Sep 2013 16:35:27 +0100

Thanks,

> Based on one of the blocks of the IESG on "state machine" I suggest to change "The DTLS state machine should not be modified and ..." with "The DTLS Record Payload protection should not be modified…

Might want to change that based on Richard's ballot. Will get back after
the call

S.

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 12 Sep 2013 16:36:07 +0100

Thanks,

> defined as "constrained devices".

Better not to refer to drafts from charters though so I'll add
back a few more words.

S.

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 12 Sep 2013 16:38:28 +0100

Thanks,

> have limited amount of code size and memory"

Sure.

> some text from the original charter should be included.

Which words?

S.

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 12 Sep 2013 18:14:15 +0100

Thanks all for the responses. The IESG approved this
version [1] (00-04) to go out for IETF review.

That means a message will go to the mail IETF list
(and other external bodies, like IEEE for example)
saying we're considering starting this WG with a
1 (or is it 2?) week timer for comments.

After that we'll see what comments we've gotten then
all going well, the charter will come back to an
IESG telechat for approval.

S.

[1] https://datatracker.ietf.org/doc/charter-ietf-dice/