Subject: [Dtls-iot] draft-hartke-dice-practical-issues-00.txt

From: Carsten Bormann <[email-masked]>
Date: Mon, 7 Oct 2013 17:08:36 +0200

Nice draft.

A couple of quick comments:

[DCOSS12] does *not* use GHC, instead they invent a header compression format not unlike the one in the draft (which fits into the RFC 6282 NHC scheme just like GHC does).

GHC happens to outperform the DCOSS12 scheme in many cases, because it looks at the whole packet, so it also compresses the cipher suite specific header.  Any attempt to get good compression should make use of this somewhat surprising result.

Grüße, Carsten

On Oct 7, 2013, at 16:40, [email-masked] wrote:

> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
> 	Title           : Practical Issues with Datagram Transport Layer Security in Constrained Environments
> 	Author(s)       : Klaus Hartke
> 	Filename        : draft-hartke-dice-practical-issues-00.txt
> 	Pages           : 23
> 	Date            : 2013-10-07
> 
> Abstract:
>   This document investigates practical issues around the implementation
>   of Datagram Transport Layer Security (DTLS) in constrained
>   environments, and explores some ideas for an optimized version of
>   DTLS that is more friendly to constrained nodes and networks.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-hartke-dice-practical-issues
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-hartke-dice-practical-issues-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Klaus Hartke <[email-masked]>
Date: Mon, 7 Oct 2013 18:32:55 +0300

> A couple of quick comments:

Feedback before I had the chance to forward the announcement to the
mailing list -- *like*.

The draft is an update of draft-hartke-core-codtls-02 with a few small
additions and a new section that compares alternative strategies for
DTLS handshake reliability.

What I'd be interested in now is if other implementers share the
assessment or if it's just me.

> [DCOSS12] does *not* use GHC, instead they invent a header compression format not unlike the one in the draft (which fits into the RFC 6282 NHC scheme just like GHC does).

Fixed in the next revision, thanks.

> GHC happens to outperform the DCOSS12 scheme in many cases, because it looks at the whole packet, so it also compresses the cipher suite specific header.  Any attempt to get good compression should…

Do you have some numbers that I could add to the draft?

Best regards,
Klaus

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 7 Oct 2013 18:03:28 +0200

> Do you have some numbers that I could add to the draft?

Results for Lithe (the new name of the [DCOSS12] scheme) are in:
http://ieeexplore.ieee.org/xpl/articleDetails.jsp?tp=&arnumber=6576185&queryText%3DLithe%3A+Lightweight+Secure+CoAP+for+the+Internet+of+Things
(which is probably the paper you want to cite).

Some numbers for GHC are in the GHC draft.

These numbers aren't fully comparable yet, somebody has to do that work (hint, hint).

Grüße, Carsten