Subject: [Dtls-iot] FW: New Version Notification for draft-keoh-dice-multicast-security-05.txt

From: "Kumar, Sandeep" <[email-masked]>
Date: Fri, 14 Feb 2014 16:13:30 +0000

Dear all

A new version of the draft has been submitted that takes Mike’s comments into consideration especially the group sizes.

It is good to clarify that the solution described is not a generic solution to solve every multicast security problem in IoT or the Internet. We have a very specific problem domain of some group members being distributed in multiple mesh (with L2 security) which are connected through the backbone. If they were located in a single physical subnet, then L2 security would have sufficed. The intention is to provide the same level of L2  security to this distributed group. Any source authenticity solutions are complementary and can be additionally designed at the application layer.

Kind regards
Sandeep

----
Changes from keoh-04 to keoh-05:

   o  In section 2.1, removed the firmware upgrade use case and clarified
      the commissioning use case.  The lighting use-case expanded with
      shared and multiple subnets issues.

   o  In Section 2.2, (b) reduced the group size to 100; (h) clarified
      data source authenticity

   o  Added new Section 6.1 (Group level security) in security
      considerations to make clear the risks of the single group key.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, February 14, 2014 5:09 PM
To: Kumar, Sandeep; Garcia Morchon, Oscar; Kumar, Sandeep; Sye Loong Keoh; Dijk, Esko; Garcia Morchon, Oscar; Dijk, Esko; Akbar Rahman; Sye Loong Keoh; Akbar Rahman
Subject: New Version Notification for draft-keoh-dice-multicast-security-05.txt

A new version of I-D, draft-keoh-dice-multicast-security-05.txt
has been successfully submitted by Sandeep S. Kumar and posted to the IETF repository.

Name:           draft-keoh-dice-multicast-security
Revision:       05
Title:          DTLS-based Multicast Security for Low-Power and Lossy Networks (LLNs)
Document date:  2014-02-14
Group:          Individual Submission
Pages:          21
URL:            http://www.ietf.org/internet-drafts/draft-keoh-dice-multicast-security-05.txt
Status:         https://datatracker.ietf.org/doc/draft-keoh-dice-multicast-security/
Htmlized:       http://tools.ietf.org/html/draft-keoh-dice-multicast-security-05
Diff:           http://www.ietf.org/rfcdiff?url2=draft-keoh-dice-multicast-security-05

Abstract:
   The CoAP and 6LoWPAN standards are fast emerging as key protocols in
   the area of resource-constrained devices.  Such IP-based systems are
   foreseen to be used for building and lighting control systems where
   wireless devices interconnect with each other, forming low-power and
   lossy networks (LLNs).  Both multicast and its security are key needs
   in these networks.  This draft presents a method for securing IPv6
   multicast communication in LLNs based on the DTLS which is already
   supported for unicast communication for CoAP devices.  This draft
   deals with the adaptation of the DTLS record layer to protect
   multicast group communication, assuming that all group members
   already have the group security association parameters in their
   possession.  The adapted DTLS record layer provides message
   confidentiality, integrity and replay protection to group messages
   using the group keying material before sending the message via IPv6
   multicast to the group.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Zach Shelby <[email-masked]>
Date: Fri, 14 Feb 2014 20:25:30 -0800

Thanks for updating the draft with more of Mike's recommendations. This draft is in line with the security problem that we were chartered to solve, and it purposely excludes key management. The draft focuses on a shared group key approach, and it does seem that people involved actually deploying constrained devices feel comfortable with the limitations pointed out (at least for their use cases). Mike, is there anything else the authors can do to clarify or narrow down the scope within this shared key approach?

Some of what Mike was asking for here is obviously out of scope, for example a key management scheme, or a DTLS multicast solution applicable outside of IoT. If we do want to solve a more general multicast security problem for the Internet as a whole, that should probably done in SAAG, not DICE. However he does make a valid point regarding asymmetric keys that we as a WG need to explore before going forward.

Several people have pointed out that asymmetric crypto with ECC is by no means an issue for most embedded devices today (I happen to agree). The trend is that asymmetric crypto will eventually be universally available, so we really can't ignore it. Some questions I think we need to answer:

- What would a DTLS record layer multicast solution employing asymmetric keys look like for IoT?
- Can this be done using the current DTLS record layer (which we are chartered to use)?
- Does such a solution require an unreasonable key management scheme (that would be bad since we're not charted to define one), or could it be employed with simple device configuration?
- Could an asymmetric key mode be supported in addition to a shared key mode, just like we do in TLS today?

We would appreciate a separate draft, or simply an appendix to draft-keoh-dice-multicast-security, to document what an asymmetric key mode would look like in practice.

Thanks,
Zach

On Feb 14, 2014, at 8:13 AM, "Kumar, Sandeep" <[email-masked]> wrote:

> _______________________________________________
> dtls-iot mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dtls-iot

Zach Shelby
Director of Technology
ARM Internet of Things BU
www.arm.com
mobile: +1 (408) 203-9434
Skype: zdshelby
LinkedIn: fi.linkedin.com/in/zachshelby/

-- IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium.  Thank you.

ARM Limited, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ, Registered in England & Wales, Company No:  2557590
ARM Holdings plc, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ, Registered in England & Wales, Company No:  2548782