Subject: [Dtls-iot] Unicast responses in draft-keoh-dice-multicast-security-05

From: Marco Tiloca <[email-masked]>
Date: Tue, 1 Apr 2014 18:35:14 +0200

Dear all,

As to possible responses to multicast requests, Section 2.1 states that
they are sent back in unicast. Then, no further details are provided about
their protection.

Are such responses supposed to be protected through a "regular" DTLS
session, which must be (or has previously been) established between the
sender and listener?

Cheers,
Marco

---

From: "Kumar, Sandeep" <[email-masked]>
Date: Wed, 2 Apr 2014 07:46:32 +0000

Hi Marco

The draft only addresses the protection of multicast traffic. If unicast responses are expected and if protection is required for such messages, then existing unicast protection mechanisms based on DTLS as suggested in draft-ietf-core-coap-18 should be used. Protection of all unicast messages should be treated as would be done normally.

Hope that answers your question.

Regards
Sandeep

From: dtls-iot [mailto:[email-masked]] On Behalf Of Marco Tiloca
Sent: Tuesday, April 01, 2014 6:35 PM
To: [email-masked]
Subject: [Dtls-iot] Unicast responses in draft-keoh-dice-multicast-security-05

Dear all,

As to possible responses to multicast requests, Section 2.1 states that they are sent back in unicast. Then, no further details are provided about their protection.

Are such responses supposed to be protected through a "regular" DTLS session, which must be (or has previously been) established between the sender and listener?

Cheers,
Marco

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.