Subject: [Dtls-iot] dice wg future work... or time to declare victory?

From: Stephen Farrell <[email-masked]>
Date: Tue, 20 Oct 2015 16:35:47 +0100

Hi all,

Congratulations to all involved in getting the DTLS profile
document done and through the process.

Now that that's done, and given that the originally planned
work on group communication hasn't progressed as planned (due
to us discovering that it was trickier than we initially
thought), I think it's time for the WG to evaluate whether
it's time to declare victory and close the WG, or if there's
some other work to be done.

In chatting with the chairs, we figured that perhaps now is
time to declare victory, but of course that's a topic to talk
about here, so please send your thoughts on the topic to the
list in the next week or two and the chairs and I will see
where we think things are at.

Cheers and well done again,
Stephen, Dorothy ad Zach.

PS: The list can remain open even if we do end up closing
the working group if that's useful.

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 20 Oct 2015 17:48:26 +0200

Let's close the group and cover group communication in the ACE working
group instead. It is my impression that the train for adding multicast
security to DTLS has left the station already a while ago and folks are
in the meanwhile looking at an application layer security solution instead.

On top of that there are far too few (security) people around so that
the overlap between ACE and DICE is almost 100% anyway. Those who are
interested group security are even a small subset of the security folks
in general (let alone those who have domain expertise in, for example,
the lighting domain).

Ciao
Hannes

On 10/20/2015 05:35 PM, Stephen Farrell wrote:
> _______________________________________________
> dtls-iot mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dtls-iot
>

---

From: Zach Shelby <[email-masked]>
Date: Tue, 20 Oct 2015 15:58:05 +0000

Hannes,

I think that makes good sense.

Zach

> On 20 Oct 2015, at 08:48, Hannes Tschofenig <[email-masked]> wrote:
>

Zach Shelby
Vice President, Marketing
ARM Internet of Things BU
www.arm.com
US: +1 (408) 203-9434
Finland: +358 407796297
Skype: zdshelby
LinkedIn: fi.linkedin.com/in/zachshelby/

________________________________

-- IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 20 Oct 2015 18:06:07 +0200

And thanks to the chairs and to Stephen for the support!

---

From: Marco Tiloca <[email-masked]>
Date: Mon, 26 Oct 2015 12:06:01 +0100

Hello everyone,

Does anyone yet support considering our recent contribution [1] as a
future (last) action in DICE?

Best regards,
/Marco

[1] https://datatracker.ietf.org/doc/draft-tiloca-dice-secure-groupcomm/

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 26 Oct 2015 12:30:35 +0100

> group instead.

I'm not sure that ACE is the right WG for this, we don't do comsec there
(we need it, but import it from elsewhere).

(COSE might be the right WG, but that is rather focused on one technology.)

One other DICE thing that is still open is DTLS-over-SMS.  No idea
whether we have the energy to finish this, but I seem to remember it is
mostly done.

Grüße, Carsten

---

From: Shahid Raza <[email-masked]>
Date: Mon, 26 Oct 2015 12:43:55 +0100

I also think we are not done with the DICE charter. To complete the work, I would prefer current chairs but will not mind new chair(s) if the group is closing only because of the unavailability of the current chairs. 

Regards
Shahid

> On 26 Oct 2015, at 12:30, Carsten Bormann <[email-masked]> wrote:
>

---

From: "Kumar, Sandeep" <[email-masked]>
Date: Mon, 26 Oct 2015 12:55:27 +0000

I do have to say that Zach and Dorothy did spend quite some effort trying to get DICE on track even with their growing responsibilities outside IETF. Thanks to both!  However DICE was just taken hostage by a few distractors who even till today haven't provided any alternative practical solutions. It sure is a "victory" for the distractors, not for anyone here who wanted to solve a real world problem in a practical way.

When we started DICE, there were quite some good ideas on further improving IoT security with just DTLS (remember DTLS-relay). Either we need more energy and guidance (also from the chairs) or accept that these kind of stuff will be standardized outside IETF. The latter is a sad conclusion of closing DICE.

Sandeep

> -----Original Message-----
> From: dtls-iot [mailto:[email-masked]] On Behalf Of Shahid Raza
> Sent: Monday, October 26, 2015 12:44 PM
> To: Carsten Bormann <[email-masked]>
> Cc: Hannes Tschofenig <[email-masked]>; [email-masked]
> Subject: Re: [Dtls-iot] dice wg future work... or time to declare victory?
>
> I also think we are not done with the DICE charter. To complete the work, I
> would prefer current chairs but will not mind new chair(s) if the group is
> closing only because of the unavailability of the current chairs.
>
> Regards
> Shahid
>
> >> Let's close the group and cover group communication in the ACE
> >> working group instead.
> >
> > I'm not sure that ACE is the right WG for this, we don't do comsec
> > there (we need it, but import it from elsewhere).
> >
> > whether we have the energy to finish this, but I seem to remember it
> > is mostly done.
> >
> > Grüße, Carsten
> >

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 26 Oct 2015 12:56:27 +0000

Replying to a few things at once...

> [1] https://datatracker.ietf.org/doc/draft-tiloca-dice-secure-groupcomm/

If some work does get traction and has good security properties
we'll find a venue for that, so whether your draft progresses is
much more influenced by it's security properties and whether or
not people want to implement/use it.

> (COSE might be the right WG, but that is rather focused on one
technology.)

Again, I'd focus on defining the right piece(s) of work that have
good security properties and developer interest. If such pieces of
work exist, we'll find a venue or form a new wg if needed.

> whether we have the energy to finish this, but I seem to remember it is

If someone is willing and able right now is the time to say that.

On 26/10/15 11:43, Shahid Raza wrote:
> I also think we are not done with the DICE charter. To complete the
> work, I would prefer current chairs but will not mind new chair(s) if
> the group is closing only because of the unavailability of the
> current chairs.

If there is DICE work to be done, then I'll chat with Zach and Dorothy
about availability, but chair availability or lack thereof is not why
I at least think we're done here. And if there's good work to be done
and people to do it, we'll find new chairs if need be.

In summary, I'm seeing some level of interest in a few things, but
nothing that yet convinces me there's enough to keep DICE around so
far.

Cheers,
S.

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 26 Oct 2015 12:59:18 +0000

On 26/10/15 12:55, Kumar, Sandeep wrote:
> I do have to say that Zach and Dorothy did spend quite some effort
> trying to get DICE on track even with their growing responsibilities
> outside IETF. Thanks to both!  However DICE was just taken hostage by
> a few distractors who even till today haven't provided any
> alternative practical solutions. It sure is a "victory" for the
> distractors, not for anyone here who wanted to solve a real world
> problem in a practical way.

I think the above is inappropriate. There were and are valid technical
criticisms of what was the planned work. Some who initially supported
that planned work were convinced by those criticisms. That does include
me fwiw, but I'm far from alone. Secure group communication as was
envisaged by our charter just doesn't turn out to work. That's a pity,
but a reality.

S.

> 
> When we started DICE, there were quite some good ideas on further
> improving IoT security with just DTLS (remember DTLS-relay). Either
> we need more energy and guidance (also from the chairs) or accept
> that these kind of stuff will be standardized outside IETF. The
> latter is a sad conclusion of closing DICE.
> 
> Sandeep
> 
>> -----Original Message----- From: dtls-iot
>> [mailto:[email-masked]] On Behalf Of Shahid Raza Sent:
>> Monday, October 26, 2015 12:44 PM To: Carsten Bormann
>> <[email-masked]> Cc: Hannes Tschofenig <[email-masked]>;
>> [email-masked] Subject: Re: [Dtls-iot] dice wg future work... or
>> time to declare victory?
>> 
>> work, I would prefer current chairs but will not mind new chair(s)
>> if the group is closing only because of the unavailability of the
>> current chairs.
>> 
>> Regards Shahid
>> 
>>> I'm not sure that ACE is the right WG for this, we don't do
>>> comsec there (we need it, but import it from elsewhere).
>>> 
>>> One other DICE thing that is still open is DTLS-over-SMS.  No
>>> idea whether we have the energy to finish this, but I seem to
>>> remember it is mostly done.
>>> 
>>> Grüße, Carsten
>>> 
>>> _______________________________________________ dtls-iot mailing
>>> list [email-masked] 
>> _______________________________________________ dtls-iot mailing
>> list [email-masked] 
> ________________________________ The information contained in this
> message may be confidential and legally protected under applicable
> law. The message is intended solely for the addressee(s). If you are
> not the intended recipient, you are hereby notified that any use,
> forwarding, dissemination, or reproduction of this message is
> strictly prohibited and may be unlawful. If you are not the intended
> recipient, please contact the sender by return e-mail and destroy all
> copies of the original message. 
> _______________________________________________ dtls-iot mailing
> list [email-masked]

---

From: Shahid Raza <[email-masked]>
Date: Mon, 26 Oct 2015 14:30:39 +0100

Going thoroughly (once again) through all the DICE emails discussing the group communication, I can clearly see that the group communication work had most valid criticism and some fake criticism (unfortunately more loud). There is a new draft (draft-tiloca-dice-secure-groupcomm-00) that carefully addresses the valid criticism and provides detailed solutions. 
I will vote for keeping the DICE active with new energy and finish the charter and declare victory.

/Shahid

> On 26 Oct 2015, at 13:59, Stephen Farrell <[email-masked]> wrote:
> 
> 
>

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 26 Oct 2015 13:34:18 +0000

On 26/10/15 13:30, Shahid Raza wrote:
> some fake criticism (unfortunately more loud)

That is also inappropriate. You may not agree with them, but your
disagreeing does not mean that whoever was criticising was being
disingenuous and it is not appropriate (not productive) to try to
denigrate other IETF participants in that manner.

S.

---

From: Shahid Raza <[email-masked]>
Date: Mon, 26 Oct 2015 15:02:57 +0100

I have no doubt about the sincerity of their thoughts. By fake I meant, "not applicable or suitable" in the context of DTLS-based group communication for the IoT.
Also, as I said before, most of the criticism is very much valid. 

/Shahid

> On 26 Oct 2015, at 14:34, Stephen Farrell <[email-masked]> wrote:
> 
> 
>