Subject: [dtn-interest] Fwd: I-D Action: draft-blanchet-dtnrg-bp-application-framework-00.txt

From: Marc Blanchet <[email-masked]>
Date: Wed, 15 Jun 2011 15:32:26 -0400

Hello,
  please find a contribution about BP applications. Comments appreciated.

Marc.

-------- Message original --------
Sujet: I-D Action: draft-blanchet-dtnrg-bp-application-framework-00.txt
Date : Wed, 15 Jun 2011 12:27:52 -0700
De : [email-masked]
Répondre à : [email-masked]
Pour : [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.

	Title           : Delay-Tolerant Networking (DTN) Bundle Protocol 
Application Framework
	Author(s)       : Marc Blanchet
	Filename        : draft-blanchet-dtnrg-bp-application-framework-00.txt
	Pages           : 6
	Date            : 2011-06-15

    The Bundle Protocol documents specify the syntax of service
    identifiers but do not identify how to make them interoperable.
    Moreover, there are currently no way to map a service identifier to a
    specific Bundle payload format.  This document attempt to address
    these issues.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-blanchet-dtnrg-bp-application-framework-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-blanchet-dtnrg-bp-application-framework-00.txt
_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: <[email-masked]>
Date: Thu, 16 Jun 2011 05:39:52 +0100

I'd expect anything discussing an application framework for the bundle protocol to discuss MIME...

Lloyd Wood
http://sat-net.com/L.Wood/dtn
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Marc Blanchet [[email-masked]]
Sent: 15 June 2011 20:32
To: DTN
Subject: [dtn-interest] Fwd: I-D Action:        draft-blanchet-dtnrg-bp-application-framework-00.txt

Hello,

Marc.

-------- Message original --------
Sujet: I-D Action: draft-blanchet-dtnrg-bp-application-framework-00.txt
Date : Wed, 15 Jun 2011 12:27:52 -0700
De : [email-masked]
Répondre à : [email-masked]
Pour : [email-masked]

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-blanchet-dtnrg-bp-application-framework-00.txt
_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
_______________________________________________
dtn-interest mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/dtn-interest

---

From: "Burleigh, Scott C (313B)" <[email-masked]>
Date: Thu, 16 Jun 2011 01:51:42 -0700

Hi, Marc.  A couple of comments on this draft:

There actually isn't an CBHE extension header (as mentioned in the second paragraph of section 1).  CBHE is just a convention for compressing the primary header.

The "dtn" scheme syntax isn't yet formally defined anywhere, as far as I know, so strictly speaking I don't think it's correct to say that "both schemes syntax carry the service identifier".  Informally this is true, because historically we often construct dtn-schemes with node names and demux tokens (which often act like service identifiers), but I don't think it's quite right to say this in an RFC.

A small thing: I'm pretty sure we omit the trailing ':' when writing the name of a URI scheme.  That seems to be the convention on http://www.iana.org/assignments/uri-schemes.html, for example.

But in general I think the concept of registering DTN service identifiers is a good idea.

Scott
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Marc Blanchet [[email-masked]]
Sent: Wednesday, June 15, 2011 12:32 PM
To: DTN
Subject: [dtn-interest] Fwd: I-D Action:        draft-blanchet-dtnrg-bp-application-framework-00.txt

Hello,

Marc.