Subject: [dtn-interest] Network Simulation Software

From: Tom Sparks <[email-masked]>
Date: Tue, 10 Jan 2012 13:55:57 -0800 (PST)

I am wondering what network simulation software do use test your network ideas in?

---
tom_a_sparks "It's a nerdy thing I like to do"
Please use ISO approved file formats excluding Office Open XML - http://www.gnu.org/philosophy/no-word-attachments.html
Ubuntu wiki page https://wiki.ubuntu.com/tomsparks
3 x (x)Ubuntu 10.04, Amiga A1200 WB 3.1, UAE AF 2006 Premium Edition, AF 2012 Plus Edition, Sam440 AOS 4.1.2, Roland DXY-1300 pen plotter, Cutok DC330 cutter/pen plotter
Wanted: RiscOS system, GEOS system (C64/C128), Atari ST, Apple Macintosh (6502/68k/PPC only)

---

From: Daniel Ellard <[email-masked]>
Date: Tue, 10 Jan 2012 17:11:01 -0500

> I am wondering what network simulation software do use test your

Depends on whether by "ideas" you mean "code" or "algorithms".

For code, CORE (a wrapper for network namespaces on linux) is nice.

http://cs.itd.nrl.navy.mil/work/core/

An important caveat is that some kernels don't have all the hooks
compiled in, and others do.

-Dan

-- 
Daniel Ellard, Ph.D.
Senior Scientist, Network Research
BBN Technologies
10 Moulton Street
Cambridge, MA 02138
[email-masked]

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Tue, 10 Jan 2012 16:15:51 -0600

Tom,

I suggest looking at the dtnbone on the wiki.
http://www.dtnrg.org/wiki/DtnBone

I think both NASA and Ohio University are using netem along with scripts to bring the links up and down.  You can use STK to run scenarios for contacts for various networks such as space-based orbital stuff.

IMHO, The important thing is to induce disconnection and probably limit bandwidth where one my have such limitations.

- Will

On Jan 10, 2012, at 4:55 PM, Tom Sparks wrote:

---
tom_a_sparks "It's a nerdy thing I like to do"
Please use ISO approved file formats excluding Office Open XML - http://www.gnu.org/philosophy/no-word-attachments.html
Ubuntu wiki page https://wiki.ubuntu.com/tomsparks
3 x (x)Ubuntu 10.04, Amiga A1200 WB 3.1, UAE AF 2006 Premium Edition, AF 2012 Plus Edition, Sam440 AOS 4.1.2, Roland DXY-1300 pen plotter, Cutok DC330 cutter/pen plotter
Wanted: RiscOS system, GEOS system (C64/C128), Atari ST, Apple Macintosh (6502/68k/PPC only)
_______________________________________________
dtn-interest mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/dtn-interest

---

From: Gilbert Clark <[email-masked]>
Date: Tue, 10 Jan 2012 17:44:51 -0500

Hi,

On 1/10/2012 5:15 PM, Ivancic, William D. (GRC-RHN0) wrote:
> I think both NASA and Ohio University are using netem along with scripts to
> bring the links up and down.

Ohio University's dtnbone uses tc (including netem) for network 
conditions, iptables for disconnection, and cron to time the application 
of various iptables / tc rules to the system.

I've also used dummynet (http://info.iet.unipi.it/~luigi/dummynet/ 
<http://info.iet.unipi.it/%7Eluigi/dummynet/>) to induce certain network 
conditions.  I found dummynet to be much easier to work with than tc, 
but I haven't used it for any kind of configuration as complex as the 
dtnbone.

Note that we know the schedule for all of our links, so they're really 
not too hard to emulate.  If you're looking to emulate something more 
dynamic, you probably *could* do it with tc / dummynet ... but I'd 
imagine there are other tools out there that might be easier to 
configure and / or would lead to a more accurate simulation :)

--Gilbert

---

From: Tom Sparks <[email-masked]>
Date: Tue, 10 Jan 2012 15:19:43 -0800 (PST)

> From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>

>To: Tom Sparks <[email-masked]> 
>Cc: "[email-masked]" <[email-masked]> 
>Sent: Wednesday, 11 January 2012 9:15 AM
>Subject: Re: [dtn-interest] Network Simulation Software
> 
>
>Tom,
>
>

>IMHO, The important thing is to induce disconnection and probably limit bandwidth where one my have such limitations.

I was think of using ns-2 (www.isi.edu/nsnam/ns/) or ns-3 (http://www.nsnam.org/)

---
tom_a_sparks "It's a nerdy thing I like to do"
Please use ISO approved file formats excluding Office Open XML - http://www.gnu.org/philosophy/no-word-attachments.html
Ubuntu wiki page https://wiki.ubuntu.com/tomsparks
3
x (x)Ubuntu 10.04, Amiga A1200 WB 3.1, UAE AF 2006 Premium Edition, AF 
2012 Plus Edition, Sam440 AOS 4.1.2, Roland DXY-1300 pen plotter, Cutok 
DC330 cutter/pen plotter
Wanted: RiscOS system, GEOS system (C64/C128), Atari ST, Apple Macintosh (6502/68k/PPC only)

>>3 x (x)Ubuntu 10.04, Amiga A1200 WB
3.1, UAE AF 2006 Premium Edition, AF 2012 Plus Edition, Sam440 AOS 4.1.2, Roland DXY-1300 pen plotter, Cutok DC330 cutter/pen plotter
>>Wanted: RiscOS system, GEOS system (C64/C128), Atari ST, Apple Macintosh (6502/68k/PPC only)_______________________________________________
>>[email-masked]

---

From: Dan Brown <[email-masked]>
Date: Wed, 11 Jan 2012 00:30:18 +0000

Has the ONE<http://www.netlab.tkk.fi/tutkimus/dtn/theone/> simulator fallen out of favor?  I didn't see it mentioned.  It doesn't have near the fidelity of ns2/3 or the emulations previously suggested but it's at least good for prototype-y back-of-the-envelope simulations.  It depends what your needs are.

> -----Original Message-----

> From: [email-masked] [mailto:dtn-interest-

> [email-masked]] On Behalf Of Tom Sparks

> Sent: Tuesday, January 10, 2012 6:20 PM

> To: Ivancic, William D. (GRC-RHN0)

> Cc: [email-masked]

> > From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]<mailto:[email-masked]>>

> >To: Tom Sparks <[email-masked]<mailto:[email-masked]>>

> >Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

> >I think both NASA and Ohio University are using netem along with scripts

> to bring the links up and down.  You can use STK to run scenarios for contacts

> for various networks such as space-based orbital stuff.

> >IMHO, The important thing is to induce disconnection and probably limit

> bandwidth where one my have such limitations.

> I was think of using ns-2 (www.isi.edu/nsnam/ns/<http://www.isi.edu/nsnam/ns/>) or ns-3

> (http://www.nsnam.org/)

> Please use ISO approved file formats excluding Office Open XML -

> http://www.gnu.org/philosophy/no-word-attachments.html

> Wanted: RiscOS system, GEOS system (C64/C128), Atari ST, Apple Macintosh

> (6502/68k/PPC only)

> >I am wondering what network simulation software do use test your

> network ideas in?

> >>Please use ISO approved file formats excluding Office Open XML -

> http://www.gnu.org/philosophy/no-word-attachments.html

> 3.1, UAE AF 2006 Premium Edition, AF 2012 Plus Edition, Sam440 AOS 4.1.2,

> Roland DXY-1300 pen plotter, Cutok DC330 cutter/pen plotter

> >>Wanted: RiscOS system, GEOS system (C64/C128), Atari ST, Apple

> Macintosh (6502/68k/PPC

> only)_______________________________________________