Subject: Re: [dtn-interest] Network Simulation Software

From: Tom Sparks <[email-masked]>
Date: Tue, 10 Jan 2012 23:44:58 -0800 (PST)

I had a quick look though the documents and using VMs for 1000 + nodes it a bit unlikely, for my simulation

Sent from Yahoo! Mail on Android

---

From: Sebastian Schildt <[email-masked]>
Date: Wed, 11 Jan 2012 11:05:15 +0100

Hi,

"1000+" nodes seems like you are more interested in simulation "algorithms" instead of implementations, and here really classical network simulators such as ns-2 or OmNet are your tools of choice. Or as other have mentioned TheONE, which is a nice small simulator specifically for DTNs (although most routing modules deployed with TheOne might have some problems to scale reasonable to "thousands" of nodes) setups).

I do want to mention however, that if your aim is testing "real" software , using VMs  is a reasonable approach up to a few hundreds simulated node with moderate use of resources. The key to success is using small VMs. We did have some success with automatically configuring deploying OpenWRT based VMs to a number of virtualisation slaves, glueing everything together with a bit of iptables (i.e. also netem possible) on the network layer. A common host can easily support 20 lightweight OpenWRT VMs, so not all hat much hosts are needed even for bigger setups. 

Sebastian

Am 11.01.2012 um 08:44 schrieb Tom Sparks:

> From: Elwyn Davies <[email-masked]>; 
> To: Tom Sparks <[email-masked]>; 
> Cc: Ivancic, William D. (GRC-RHN0) <[email-masked]>; [email-masked] <[email-masked]>; 
> Subject: Re: [dtn-interest] Network Simulation Software 
> Sent: Tue, Jan 10, 2012 11:57:30 PM 
> 
> Hi, Tom.
> 
> You might also like to have a look at the tool developed by ITTI as part
> of the N4C project last year.
> 
> You can find the code and pointers to various videos of how to use it at
> http://code.n4c.eu/code/simulation-tools/.  This tool is built on top of
> ns3 and allows emulation combined with real boxes (if required) and
> simulation.  Basically ns3 simulates the physical and link layers with
> the protocol and higher layers run in lots of VMs.
> 
> Documentation can be found at http://www.n4c.eu/Deliverables.php
> deliverables D7.3 and D7.4.
> 
> And of course there is the ONE simulator:
> http://www.netlab.tkk.fi/tutkimus/dtn/theone/
> 
> Regards,
> Elwyn
> 
> On Tue, 2012-01-10 at 15:19 -0800, Tom Sparks wrote:
> > > From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
> > 
> > >To: Tom Sparks <[email-masked]> 
> > >Cc: "[email-masked]" <[email-masked]> 
> > >Sent: Wednesday, 11 January 2012 9:15 AM
> > >Subject: Re: [dtn-interest] Network Simulation Software
> > > 
> > >
> > >Tom,
> > >
> > >
> > >I suggest looking at the dtnbone on the wiki.
> > >http://www.dtnrg.org/wiki/DtnBone
> > 
> > >I think both NASA and Ohio University are using netem along with scripts to bring the links up and down.  You can use STK to run scenarios for contacts for various networks such as space-based orbital stuff.  
> > >
> > >
> > >IMHO, The important thing is to induce disconnection and probably limit bandwidth where one my have such limitations.
> > >
> > >
> > >- Will
> > >
> > 
> > I was think of using ns-2 (www.isi.edu/nsnam/ns/) or ns-3 (http://www.nsnam.org/)
> > 
> > 
> > ---
> > tom_a_sparks "It's a nerdy thing I like to do"
> > Please use ISO approved file formats excluding Office Open XML - http://www.gnu.org/philosophy/no-word-attachments.html
> > Ubuntu wiki page https://wiki.ubuntu.com/tomsparks
> > 3
> > x (x)Ubuntu 10.04, Amiga A1200 WB 3.1, UAE AF 2006 Premium Edition, AF 
> > 2012 Plus Edition, Sam440 AOS 4.1.2, Roland DXY-1300 pen plotter, Cutok 
> > DC330 cutter/pen plotter
> > Wanted: RiscOS system, GEOS system (C64/C128), Atari ST, Apple Macintosh (6502/68k/PPC only)
> > 
> > 
> > >
> > >On Jan 10, 2012, at 4:55 PM, Tom Sparks wrote:
> > >
> > >I am wondering what network simulation software do use test your network ideas in?
> > >>
> > >> 
> > >>---
> > >>tom_a_sparks "It's a nerdy thing I like to do"
> > >>Please use ISO approved file formats excluding Office Open XML - http://www.gnu.org/philosophy/no-word-attachments.html
> > >>Ubuntu wiki page https://wiki.ubuntu.com/tomsparks
> > >>3 x (x)Ubuntu 10.04, Amiga A1200 WB
> > 3.1, UAE AF 2006 Premium Edition, AF 2012 Plus Edition, Sam440 AOS 4.1.2, Roland DXY-1300 pen plotter, Cutok DC330 cutter/pen plotter
> > >>Wanted: RiscOS system, GEOS system (C64/C128), Atari ST, Apple Macintosh (6502/68k/PPC only)_______________________________________________
> > >>dtn-interest mailing list
> > >>[email-masked]
> > >>https://www.irtf.org/mailman/listinfo/dtn-interest
> > >>
> > >
> > >
> > >
> > >
> > >
> > _______________________________________________
> > dtn-interest mailing list
> > [email-masked]
> > https://www.irtf.org/mailman/listinfo/dtn-interest
> 
> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest