Subject: [dtn-interest] banking system in a DTN

From: Tom Sparks <[email-masked]>
Date: Sat, 31 Mar 2012 01:58:19 -0700 (PDT)

How would the banking system work in a DTN?

---
tom_a_sparks "It's a nerdy thing I like to do"
Please use ISO approved file formats excluding Office Open XML - http://www.gnu.org/philosophy/no-word-attachments.html
Ubuntu wiki page https://wiki.ubuntu.com/tomsparks
3 x (x)Ubuntu 10.04, Amiga A1200 WB 3.1, UAE AF 2006 Premium Edition, AF 2012 Plus Edition, Sam440 AOS 4.1.2, Roland DXY-1300 pen plotter, Cutok DC330 cutter/pen plotter
Wanted: RiscOS system, GEOS system (C64/C128), Atari ST, Apple Macintosh (6502/68k/PPC only)

---

From: Marshall Eubanks <[email-masked]>
Date: Sat, 31 Mar 2012 05:51:17 -0400

> How would the banking system work in a DTN?

DTN is a transport mode. As long as the packets get there, why should the
banking be different?

After all, there was banking back when it took weeks to cross the Atlantic. Why
should it be a fundamental problem if it takes 30 minutes to send a
message to Mars?

Regards
Marshall

> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest

---

From: Vint Cerf <[email-masked]>
Date: Sat, 31 Mar 2012 05:56:36 -0400

the transaction needs to be idempotent in case duplicate detection of the
convention type fails.

v

On Sat, Mar 31, 2012 at 5:51 AM, Marshall Eubanks <
[email-masked]> wrote:

> > Please use ISO approved file formats excluding Office Open XML -
> http://www.gnu.org/philosophy/no-word-attachments.html
> > 3 x (x)Ubuntu 10.04, Amiga A1200 WB 3.1, UAE AF 2006 Premium Edition, AF
> 2012 Plus Edition, Sam440 AOS 4.1.2, Roland DXY-1300 pen plotter, Cutok
> DC330 cutter/pen plotter

---

From: "Abdulkader Benchi" <[email-masked]>
Date: Sat, 31 Mar 2012 12:14:20 +0200 (CEST)

Hello,
As long as I know, when you use a DTN protocol in your communication level
you will have many other problems in the upper levels.
In fact, it will not be so easy (perhaps impossible) to support or
guarantee security and consensus issues in the application levels when
using a DTN protocol.
As you know, these issues are very important to be supported in any bank
system.
So to answer your question, you can use any type of communication
protocols but you have to think twice how will such protocol helps you to
support other issues.

Sincerely,

Kader

>> > Wanted: RiscOS system, GEOS system (C64/C128), Atari ST, Apple
>> Macintosh
>> (6502/68k/PPC only)

-- 
BENCHI Abdulkader ---------------------------------------------
Doctorant
Laboratoire VALORIA - Université de Bretagne Sud
Rue Yves Mainguy
Campus de Tohannic, BP 573
56017 Vannes cedex, France
Email: [email-masked]
http://www-valoria.univ-ubs.fr/Abdulkader.Benchi/
tel :     +33 (0)2 97 01 72 96
fax :     +33 (0)9 56 89 94 20
----------------------------------------------------------------------------

---

From: Steve Crocker <[email-masked]>
Date: Sat, 31 Mar 2012 11:35:08 -0400

In today's regular banking system, eg check clearing, the delays are bounded and finalization is held up for enough time to make sure duplicate "messages" have reached their destinations.

Steve

Sent from my iPhone

On Mar 31, 2012, at 5:56 AM, Vint Cerf <[email-masked]> wrote:

> the transaction needs to be idempotent in case duplicate detection of the convention type fails. 
> 
> v
> 
> 
> On Sat, Mar 31, 2012 at 5:51 AM, Marshall Eubanks <[email-masked]> wrote: