Subject: [dtn-interest] random thought - websockets?

From: "Fall, Kevin" <[email-masked]>
Date: Fri, 13 Jul 2012 14:57:07 +0000

Anyone have an opinion as to whether bundles over websockets makes any sense (e.g., for hbh xfer as a CL)?
Looks to me a bit like WS is essentially 'let's get back to TCP but make it look like it is the web so it can go through firewalls, etc'.

- K [reading about WS]

---

From: Joerg Ott <[email-masked]>
Date: Fri, 13 Jul 2012 19:37:13 +0300

Might assist traversal when sufficiently well connected.
Not sure about overhead, but there is surely at least one extra
round-trip that could hurt in some cases.  With potential diversity
of apps on an endpoint, (de)multiplexing may become an issue.
Probably needs a closer look.

Jörg

On 13.07.2012 17:57, Fall, Kevin wrote:
> Looks to me a bit like WS is essentially 'let's get back to TCP but make
> it look like it is the web so it can go through firewalls, etc'.
>
> - K [reading about WS]
>
>
> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest
>