Subject: [dtn-interest] Google Meeting "More" Input - Ivancic

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Fri, 27 Jul 2012 11:04:43 -0500

I forgot this one:

10. One should be able to perform reliability checks without having to implement security (small, low-processing, sensors, etc...)

Also, if the goal is to eventually have "Everything over Bundling" (Vint?) than, there probably needs to be a new research group as this one is based on the InterPlanetary Network (IPN).  Handling the realm from fully connected to fully disconnect requires some deep deep thought in architecture.  Most Certainly a very interesting research area.

- Will
============================

If the group wants to move toward some large real-world deployment (sometime in the future), a lot  has to be reconsidered.  The following are just a few.

 1.  There is no addressing right now, only naming, and naming is overloaded.  To scale (millions), you will likely need addressing.
 2.  The security is so complex, it will be difficult if not impossible to interoperated.  From the workshop I was at in July that Kevin Fall also attended, I think zero of three interoperate as is.  Also, I believe APL's analysis of ION shows it does not implement many if not most of the MUST portions of the BSP. But, you probably only need to authenticate sources. (Information Centric Networking applications will likely handle integrity of data and the user will probably handle encryption of data, not the Bundle Layer).
 3.  The current security mechanism does not work with reactive fragmentation.  - See item 8
 4.  There is currently no requirement to have a mechanism that protects against routing loops. It can be done in extensions blocks, but that is not mandatory.
 5.  There is much discussion of absolute vs relative time, but looking at how implementations use time, it may be that prioritized forwarding is sufficient and you can completely eliminate time from the protocol.  (Information Centric Networking applications will likely handle freshness of data).
 6.  Regardless, there probably should be a document that describes the expected default operations of a BP-agent.
 7.  Without fire-walling and filters, real-world deployment is not likely to happen because you are asking to use someone else's resources.
 8.  From much of the work being done, it appears many thing of bundles = store-and-forward packets.  Architecturally, we have to decide if bundles have vastly varying sizes or fixed sizes. Are bundles 64Kbytes or less or are they 8 bytes to 20 Gbytes or more?
 9.  Is custody transfer the default operation? - see 6.  If so, does having an explicate custody transfer buy you anything vs use of perhaps simpler priorities.

Have fun at Google!

- Will

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 28 Jul 2012 05:34:16 +0100

Hi Will,

Thanks for those. We did cover a number of them during the
meeting. If you can try to check your list vs. the tidied
up minutes we'll send about then we can figure out which
ones we didn't get to during the two days and try see if
we can sort 'em on the list if needed.

Cheers,
S.

On 07/27/2012 05:04 PM, Ivancic, William D. (GRC-RHN0) wrote:
> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest
>