Subject: [dtn-interest] Updated agenda/attendees and SOME DEADLINES...

From: Stephen Farrell <[email-masked]>
Date: Mon, 09 Jul 2012 18:45:22 +0100

Hi all,

We've updated the agenda a bit. [1]

The attendee list [1] is now at 53, and we need a
final list by *July 20th*, so if you're not on the
list but planning to come you better let us know
or you won't have a badge and maybe won't get in
to the room. (If you'll be at the NASA event prior
to the DTNRG meeting, we still need to know as you
need a different badge each day.)

Since we're going to be a quite a crowd it seems,
and we want to have a good bit of discussion, we'll
have to behave ourselves in terms of timing of
presentations etc. and the chairs plan to enforce
that strictly.

To help us with that, please send me draft slides
before the end of *July 16th.* (pdf please, since
libreoffice is liable to mangle any fancy pptx stuff)

Sorry for asking for that so early, but it'll help us
finalise the agenda and leave time for discussion if
we can see what you're planning to say a bit earlier
than usual. You will be able to update slide content
later if necessary. A consequence of that is that the
final agenda is likely to change after the 16th.

If you don't get me slides before the 16th, your
slot will be at risk and if you send too many
slides then I'll just randomly delete some of
them:-)

So please be good, and only include slides for a
*15 minute* presentation - the rest of the slot is
for discussion if we have more than 15 minutes
allocated. (You can have as many backup slides as
you like, but please mark them as such and don't
depend on anyone ever seeing them!)

Cheers,
Stephen.

[1] http://down.dsg.cs.tcd.ie/dtnrg-at-google-12/
[2] http://down.dsg.cs.tcd.ie/dtnrg-at-google-12/attendees.txt

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 14 Jul 2012 00:03:15 +0100

Fred Templin wins some kind of prize from someone
for getting in first with slides! [1]

Thanks and looking forward to getting more over
the weekend,
Cheers,
S.

[1] http://down.dsg.cs.tcd.ie/dtnrg-at-google-12/#Presentati

On 07/09/2012 06:45 PM, Stephen Farrell wrote:
> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest
> 
>

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 16 Jul 2012 23:30:07 +0100

> libreoffice is liable to mangle any fancy pptx stuff)

Thanks to all those who've already done so. [1]

This is just to note that the 16th is nearly over:-)

FWIW, if it comes to a lack of presentation time (and
it probably will), I'll be arguing for more time for
those who've gotten slides in on time and less for
those who don't.

S.

---

From: Paulo Mendes <[email-masked]>
Date: Tue, 24 Jul 2012 17:32:47 +0100

Dear all

Since it is not going to be possible for me to present the draft that we submitted this month (draft-moreira-dlife-00) in this DTNRG meeting, I would like to make my statement about routing in the DTNRG. Since Anders is going to provide a presentation to discuss the future of routing in the DTN research group, I hope that my contribution can be considered remotely.

I'll start to provide my opinion to the questions that Anders is raising in his slides:

a) Should DTNRG be doing more routing work?
Yes, definitely. Current routing protocols being worked out at IETF (e.g. all the Manet flavors) are not suitable for DTN scenarios. Routing is an essential part of any DTN architecture. Since only PRoPHET is specified, we aim to support a potential routing framework with a new routing proposal (dLife).

b) What kind of routing protocols should the community be looking at?
IMO, the DTN architecture should include one routing protocol from the two major trends present in the literature: mobility-aware and social-aware. The former (in which PRoPHET is included) is able to exploit encounters between mobile nodes; the latter (in which dLife in included) aims to exploit the social patterns of mobile nodes. The major different is the operation time scale. Mobility aware protocols operate based on any contact caused by mobility patterns; Social aware protocols tend to be less volatile since they operate based on more stable social graphs.

In what concerns the suggestion to create a DTN routing framework, I agree. For this I would like to start by having feedback from the DTNRG community to consider the proposed draft-moreira-dlife-00 as a DTNRG draft.

Second, and starting from PRoPHET and dLIFE (which are off course in difference stages of evolution), we could look at interoperability issues.  How to allow PRoPHET nodes to take advantage of information carried by dLIFE nodes, and vice-versa. This work is supported by the evidence (as pointed out by Anders in his slides) that there are significant similarities between different routing proposals. I fully agree with the idea to work on a basic protocol spec that different protocols can use to implement their specific operations.

So, in summary:
a) I would like to see the dLife draft being accepted as a DTNRG draft
b) I'm willing to contribute to the definition of a generic DTN routing spec, as co-author of  a new draft to which the PRoPHET spec (almost RFC) and dLife (hopefully DTNRG draft) will be plugged in (some changes will most likely need to be included in the description of these two protocols).

Cheers
Paulo

> [1] http://down.dsg.cs.tcd.ie/dtnrg-at-google-12/#Presentati

-------------------------------------------------------------
Paulo Mendes, Ph.D
Scientific Director for Innovation of the Research Unit in Informatics Systems and Technologies (SITI)
Secretary of the ACM SIGCOMM Chapter - Portugal
University Lusofona, Portugal
[email-masked]
http://siti.ulusofona.pt/~pmendes
Tel.: 217 515 500 Fax: 21 757 7006

---

From: Juliano Naves <[email-masked]>
Date: Tue, 24 Jul 2012 23:54:24 -0300

2012/7/24 Paulo Mendes <[email-masked]>

> Dear all
>
> Since it is not going to be possible for me to present the draft that we
> submitted this month (draft-moreira-dlife-00) in this DTNRG meeting, I
> would like to make my statement about routing in the DTNRG. Since Anders is
> going to provide a presentation to discuss the future of routing in the DTN
> research group, I hope that my contribution can be considered remotely.
>
> Yes, definitely. Current routing protocols being worked out at IETF (e.g.
> all the Manet flavors) are not suitable for DTN scenarios. Routing is an
> essential part of any DTN architecture. Since only PRoPHET is specified, we
> aim to support a potential routing framework with a new routing proposal
> (dLife).
>
> IMO, the DTN architecture should include one routing protocol from the two
> major trends present in the literature: mobility-aware and social-aware.
> The former (in which PRoPHET is included) is able to exploit encounters
> between mobile nodes; the latter (in which dLife in included) aims to
> exploit the social patterns of mobile nodes. The major different is the
> operation time scale. Mobility aware protocols operate based on any contact
> caused by mobility patterns; Social aware protocols tend to be less
> volatile since they operate based on more stable social graphs.
>
> In what concerns the suggestion to create a DTN routing framework, I
> agree. For this I would like to start by having feedback from the DTNRG
> community to consider the proposed draft-moreira-dlife-00 as a DTNRG draft.
>
> Second, and starting from PRoPHET and dLIFE (which are off course in
> difference stages of evolution), we could look at interoperability issues.
>  How to allow PRoPHET nodes to take advantage of information carried by
> dLIFE nodes, and vice-versa. This work is supported by the evidence (as
> pointed out by Anders in his slides) that there are significant
> similarities between different routing proposals. I fully agree with the
> idea to work on a basic protocol spec that different protocols can use to
> implement their specific operations.
>

I think the some kind of raw information can be used to several protocols.
Could be this information inserted in the aforementioned "basic protocol"?
Would it not be better if would be specified that DTN nodes collect and
store basic information and specify  how this information may be exchanged?

> b) I'm willing to contribute to the definition of a generic DTN routing
> spec, as co-author of  a new draft to which the PRoPHET spec (almost RFC)
> and dLife (hopefully DTNRG draft) will be plugged in (some changes will
> most likely need to be included in the description of these two protocols).
>
> Cheers
> Paulo
>
>
>
>

Hi,

I would like to express my opinion regarding a particular point:

I think that raw information can be used for several protocols. Could this
information be inserted in the aforementioned "basic protocol"? Wouldn't it
be better to specify that DTN nodes are responsible for collecting and
storing basic information periodically? Could we also specify how this
information can be exchanged?

Best regards,

Juliano Fischer Naves
IC/UFF, Niterói, Rio de Janeiro, Brazil

---

From: Paulo Mendes <[email-masked]>
Date: Wed, 25 Jul 2012 10:23:21 +0100

Hi

IMO the fastest answer to your question is Yes... It is clear that although DTN routing have different methods and maybe different performance, they seem to share a basic set of functionality. The idea that Anders is putting on the table, and that I fully agree, is to draft a generic routing framework that would be used by any routing protocol. After this is done, maybe PRoPHET and dLife need to be adjusted to operated based on that generic framework... But there is still a lot of work to be done.. 

For now at the DTN meeting at Google would be nice to:
- Have an agreement about the creation of a routing framework (a draft to define the generic routing spec)
- Have dLife accepted as DTNRG draft (together with PRoPHET we will then have 2 specs to start with for the identification and testing of the basic generic routing spec)..

Cheers
Paulo

On Jul 25, 2012, at 3:54 AM, Juliano Naves wrote:

> I think the some kind of raw information can be used to several protocols. Could be this information inserted in the aforementioned "basic protocol"? Would it not be better if would be specified that DTN nodes collect and store basic information and specify  how this information may be exchanged?
> 
> 
> So, in summary:
> I think that raw information can be used for several protocols. Could this information be inserted in the aforementioned "basic protocol"? Wouldn't it be better to specify that DTN nodes are responsible for collecting and storing basic information periodically? Could we also specify how this information can be exchanged?
> 
> Best regards,
> 
> Juliano Fischer Naves

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Wed, 25 Jul 2012 07:14:28 -0500

Since DTN per RFC5050 has no addressing scheme, you will probably have a difficult problem creating a generic routing framework and it will be difficult to aggregate routes.  There isn't even a clear naming convention.

That being said, I like the concept of using the social networking grid for the topology.

- Will

---

From: Paulo Mendes <[email-masked]>
Date: Wed, 25 Jul 2012 14:27:10 +0100

Hi Will

IMO the DTN arch needs a solid routing framework, since there are no protocols being worked out at IETF that will fit the picture. But, as you mentioned, this is not going to be an easy task. Nevertheless, for now we already identified two tasks to be pursuit: i) identification of protocolar similarities among existing specs; ii) identify how the generic routing framework will fit the DTN arch.. (maybe some changes will need to be done to the added to the arch - reason for RFC 5050bis?). I think that there is already food for though in mountain view :)

As for the dLife usage of social networking topologies, we also like the approach :). Published results already show some advantages.

Cheers
Paulo

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Wed, 25 Jul 2012 08:41:37 -0500

At NASA Glenn Research Center, I believe Jim McKim has been tasked with reverse engineering DTLSR in DTN2 as it has not been documented regarding message formats and such.  This may also help.  I am not sure of the status of this work.

- Will

---

From: Juliano Naves <[email-masked]>
Date: Wed, 25 Jul 2012 11:16:41 -0300

In this case, I think the first thing to be made is to identify the
information that could be used by the utility of most protocols.

2012/7/25 Ivancic, William D. (GRC-RHN0) <[email-masked]>

> At NASA Glenn Research Center, I believe Jim McKim has been tasked with
> reverse engineering DTLSR in DTN2 as it has not been documented regarding
> message formats and such.  This may also help.  I am not sure of the status
> of this work.
>
> - Will
>
> > IMO the DTN arch needs a solid routing framework, since there are no
> protocols being worked out at IETF that will fit the picture. But, as you
> mentioned, this is not going to be an easy task. Nevertheless, for now we
> already identified two tasks to be pursuit: i) identification of protocolar
> similarities among existing specs; ii) identify how the generic routing
> framework will fit the DTN arch.. (maybe some changes will need to be done
> to the added to the arch - reason for RFC 5050bis?). I think that there is
> already food for though in mountain view :)
> >
> > As for the dLife usage of social networking topologies, we also like the
> approach :). Published results already show some advantages.
> >
> > Cheers
> > Paulo
> >
> >> Since DTN per RFC5050 has no addressing scheme, you will probably have
> a difficult problem creating a generic routing framework and it will be
> difficult to aggregate routes.  There isn't even a clear naming convention.
> >>

-- 
Juliano Fischer Naves
Ph.D. student, IC/UFF, Brazil

---

From: "Mckim, James H. (GRC-RHN0)[Wyle Information Systems, LLC]" <[email-masked]>
Date: Thu, 26 Jul 2012 06:51:28 -0500

________________________________________
From: Ivancic, William D. (GRC-RHN0)
Sent: Wednesday, July 25, 2012 8:41 AM
To: Paulo Mendes
Cc: Juliano Naves; DTN interest; Mckim, James H. (GRC-RHN0)[Wyle Information Systems, LLC]
Subject: Re: [dtn-interest] Routing issues @ DTNRG

- Will

Here's the current version.

--
Jim

---

From: "Fall, Kevin" <[email-masked]>
Date: Mon, 30 Jul 2012 15:33:10 +0000

It would be nice if the document referenced the original paper, which
described the intent of the protocol and some experience with it.
(one copy is here:  http://kfall.net/ucbpage/papers/dtlsr-nsdr07.pdf)

Might also use this as the basis for an abstract:

http://dtn.sourceforge.net/DTN2/doc/manual/ro_dtlsr.html

Regards,
- K

On 7/26/12 4:51 AM PDT, "Mckim, James H. (GRC-RHN0)[Wyle Information
Systems, LLC]" <[email-masked]> wrote:

>message formats and such.  This may also help.  I am not sure of the
>status of this work.
>
>- Will
>