Subject: [dtn-interest] DTNBone page needs updating regarding interoperability

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Wed, 11 Jul 2012 09:02:19 -0500

What is on DTNbone regarding interoperability  is definitely outdated.

Quite a while ago I started putting together a compatibility matrix.  If different implementors can send me their know interoperability with other implementations I will update this and put it on the wiki.

The current outdated compatibility matrix is here in Excel and one page in PDF.

http://roland.grc.nasa.gov/~ivancic/shared/DTN/

Current Outdated Info
-------------------------------

http://www.dtnrg.org/wiki/DtnBone

Interconnection of different implementations:

 *   ION/LTP and LTP-T will interoperate via UDP
 *   ION and DTN2 currently only interoperate via UDP

    *   Some researchers have patched ION to change its s-TCP CL to TCP
    *   Ohio University is implementing TCP as an additional CL into ION, monitor the ion-users and dtnbone lists for announcements
 *   Spindle3 interoperates with compliant UDP and TCP implementations
 *   IBR-DTN is interoperable with compliant TCP CL and UDP CL implementations. DTN2 and ION have been successfully tested

- Will

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 11 Jul 2012 15:04:40 +0100

We've also done DTN2/LTP with ION/LTP

S.

On 07/11/2012 03:02 PM, Ivancic, William D. (GRC-RHN0) wrote:
> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest
>

---

From: "Burleigh, Scott C (313B)" <[email-masked]>
Date: Wed, 11 Jul 2012 14:28:40 +0000

Thanks for taking this on, Will.  The only update I know of is that ION has a TCPCL implementation that's interoperable with that of DTN2.

Scott

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ivancic, William D. (GRC-RHN0)
Sent: Wednesday, July 11, 2012 7:02 AM
To: [email-masked]
Subject: [dtn-interest] DTNBone page needs updating regarding interoperability

Current Outdated Info

- Will