Subject: [dtn-interest] Video adaptation in DTNs?

From: Sergio <[email-masked]>
Date: Fri, 1 Mar 2013 09:40:44 +0100

Hello,

I'm finishing my PhD in the transmission of video in sparse MANETs and
always have in mind emergency and rescue scenarios. One of my later works
[1] is on video adaptation in opportunistic networks / DTNs (always have
doubts with these terms...), which may be interesting in the emergencies
context. One of the main difficulties is that contact times are unknown,
thus, resource estimation is difficult.

I'm wondering wether this research is relevant for others and I should go
on with it. Since you are probably working in different application
domains, do you see this type of work interesting for them? what other
applications can this have?

[1]
http://www.computer.org/csdl/proceedings/wimob/2012/1429/00/p349cabrero-abs.html

Thanks for your help,

Sergio Cabrero
[email-masked]

---

From: Vint Cerf <[email-masked]>
Date: Fri, 1 Mar 2013 10:44:25 -0500

it is worth investigating. I would imagine that video streaming is tough in
networks with flaky connections if the intent is to achieve anything in
real-time. transmission of video that does not have time constraints is a
different matter.

v

On Fri, Mar 1, 2013 at 3:40 AM, Sergio <[email-masked]> wrote:

> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest
>
>

---

From: "Scott, Keith L." <[email-masked]>
Date: Fri, 1 Mar 2013 16:03:04 +0000

The NASA DTN Project has been experimenting with a 'Bundle Streaming Service' that might be of interest to you.  Think a library at the receiver that implements a model of: "Get what you can in real time and pass it to the receiving application; store everything in a database so the receiving application can go back and get the stuff it missed later."  So sort of like providing a DVR capability for video streaming - you might get drop-outs in the 'real-time' playback, but as data is retransmitted you can go back and replay old data, and have more and more of the holes filled in.

                        --keith

From: [email-masked] [mailto:[email-masked]] On Behalf Of Vint Cerf
Sent: Friday, March 01, 2013 10:44 AM
To: Sergio
Cc: dtn-interest
Subject: Re: [dtn-interest] Video adaptation in DTNs?

it is worth investigating. I would imagine that video streaming is tough in networks with flaky connections if the intent is to achieve anything in real-time. transmission of video that does not have time constraints is a different matter.

v

On Fri, Mar 1, 2013 at 3:40 AM, Sergio <[email-masked]<mailto:[email-masked]>> wrote:
Hello,

I'm finishing my PhD in the transmission of video in sparse MANETs and always have in mind emergency and rescue scenarios. One of my later works [1] is on video adaptation in opportunistic networks / DTNs (always have doubts with these terms...), which may be interesting in the emergencies context. One of the main difficulties is that contact times are unknown, thus, resource estimation is difficult.

I'm wondering wether this research is relevant for others and I should go on with it. Since you are probably working in different application domains, do you see this type of work interesting for them? what other applications can this have?

[1] http://www.computer.org/csdl/proceedings/wimob/2012/1429/00/p349cabrero-abs.html

Thanks for your help,

Sergio Cabrero
[email-masked]<mailto:[email-masked]>

_______________________________________________
dtn-interest mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/dtn-interest

---

From: Marc Blanchet <[email-masked]>
Date: Fri, 1 Mar 2013 11:34:48 -0500

may or may not be good for you, but we did some work for handling video over http over dtn. Our implementation support it: you can see youtube over a dtn.  It does not resolve everything, but still is one step and is implemented and you can try it yourself. 
see: http://postellation.viagenie.ca

Regards, Marc.

---

From: Kevin K Gifford <[email-masked]>
Date: Fri, 1 Mar 2013 08:59:41 -0700

Dear Sergio -

Video streaming/transmission in challenged environments is well worth continuing to investigate.  For Public Safety and Emergency networks the observation is that there will be "out-of-network" scenarios where a contemporaneous path from source to destination does not exist and in these cases DTN transmission of historical event information in is valuable – algorithms such as your Dynamic Temporal Scalability (DTS) are an important open area of research in this regard.

Kevin

From: Vint Cerf <[email-masked]<mailto:[email-masked]>>
Date: Friday, March 1, 2013 8:44 AM
To: Sergio <[email-masked]<mailto:[email-masked]>>
Cc: dtn-interest <[email-masked]<mailto:[email-masked]>>
Subject: Re: [dtn-interest] Video adaptation in DTNs?

v

Thanks for your help,

Sergio Cabrero

---

From: Joerg Ott <[email-masked]>
Date: Sat, 02 Mar 2013 14:29:01 +0200

We spent some time looking at adaptive conversational audio.
http://www.netlab.tkk.fi/~jo/papers/2012-03-adaptive-voice.pdf
http://www.netlab.tkk.fi/~jo/papers/2011-comsnets-dttalkie.pdf

We also experimented with video over RTP over DTN a while
back, but mostly looking at processing overhead of DTN2 back
then.

I suppose some similar ideas might apply to video as well.
For streaming cams (as in CCTV) you may get interesting
tradeoff points between reliable (read: storage) and
timely delivery depending on your target scenario.

Jörg

On 01.03.2013 17:44, Vint Cerf wrote:
> it is worth investigating. I would imagine that video streaming is tough
> in networks with flaky connections if the intent is to achieve anything
> in real-time. transmission of video that does not have time constraints
> is a different matter.
>
> v
>
>
>
>     I'm finishing my PhD in the transmission of video in sparse MANETs
>     and always have in mind emergency and rescue scenarios. One of my
>     later works [1] is on video adaptation in opportunistic networks /
>     DTNs (always have doubts with these terms...), which may be
>     interesting in the emergencies context. One of the main difficulties
>     is that contact times are unknown, thus, resource estimation is
>     difficult.
>
>     I'm wondering wether this research is relevant for others and I
>     should go on with it. Since you are probably working in different
>     application domains, do you see this type of work interesting for
>     them? what other applications can this have?
>
>
>     [1]
>     [email-masked] <mailto:[email-masked]>
>
>
>     [email-masked] <mailto:[email-masked]>

---

From: LOCHIN Emmanuel <[email-masked]>
Date: Sun, 03 Mar 2013 08:46:25 +0100

> timely delivery depending on your target scenario.

Following this case, you might be interested in our "Robust streaming 
in delay tolerant networks" coding scheme available here: 
http://oatao.univ-toulouse.fr/4111/

Emmanuel

---

From: Sergio <[email-masked]>
Date: Sun, 3 Mar 2013 14:01:56 +0100

Thank you all for the answers, it supposes good motivation to push my
research. I will take a careful look to the references you provided.

Best regards,
Sergio

On Sun, Mar 3, 2013 at 8:46 AM, LOCHIN Emmanuel <[email-masked]>wrote:

>> http://www.netlab.tkk.fi/~jo/**papers/2012-03-adaptive-voice.**pdf<http://www.netlab.tkk.fi/~jo/papers/2012-03-adaptive-voice.pdf>
>> http://www.netlab.tkk.fi/~jo/**papers/2011-comsnets-dttalkie.**pdf<http://www.netlab.tkk.fi/~jo/papers/2011-comsnets-dttalkie.pdf>
>>
> Following this case, you might be interested in our "Robust streaming in
> delay tolerant networks" coding scheme available here:
> http://oatao.univ-toulouse.fr/**4111/<http://oatao.univ-toulouse.fr/4111/>
>
> Emmanuel
>
>
>
>> Jörg
>>
>>>     http://www.computer.org/csdl/**proceedings/wimob/2012/1429/**
>>> 00/p349cabrero-abs.html<http://www.computer.org/csdl/proceedings/wimob/2012/1429/00/p349cabrero-abs.html>
>>>
>>>     Thanks for your help,
>>>
>>>     Sergio Cabrero
>>>     [email-masked] <mailto:cabrerosergio@uniovi.**es<[email-masked]>
>>> >
>>>
>>>
>>>     ______________________________**_________________
>>>     https://www.irtf.org/mailman/**listinfo/dtn-interest<https://www.irtf.org/mailman/listinfo/dtn-interest>
>>>
>>>
>>>
>>>
>>> ______________________________**_________________
>>> https://www.irtf.org/mailman/**listinfo/dtn-interest<https://www.irtf.org/mailman/listinfo/dtn-interest>
>>>
>>>  ______________________________**_________________
>> https://www.irtf.org/mailman/**listinfo/dtn-interest<https://www.irtf.org/mailman/listinfo/dtn-interest>
>>
>
> ______________________________**_________________
> https://www.irtf.org/mailman/**listinfo/dtn-interest<https://www.irtf.org/mailman/listinfo/dtn-interest>
>