Subject: [dtn-interest] DTN2.9.0 vs IBR-DTN

From: Bruno Tavares <[email-masked]>
Date: Mon, 4 Mar 2013 15:06:19 +0000

Hello!

Is there any compatibility between the dtn2.9.0 and ibr-dtn ? I was trying to use them but when i start the two daemons they do not discover each other.

Thank you all

Best regards,

Bruno Tavares

---

From: Sebastian Schildt <[email-masked]>
Date: Mon, 11 Mar 2013 14:28:20 +0100

Hi  

As a default IBR-DTN uses IPND discovery which seems to be not supported by DTN2, however IBR-DTN can also generate DTN2-compatible Discovery packets. This configuration option might be of interest:

# specify the discovery mechanism to use
# 0 = DTN2 compatible discovery
# 1 = IPND version 0
# 2 = IPND version 1 (default)
#discovery_version = 2

Alternatively, setting up a static route in IBR-DTN (and possible DTN2?) should also work.

MfG

Sebastian

P.S.: Sometimes we miss these kinds of mails here, so if you start playing with IBR-DTN you might want to consider also joining the ibrdtn mailinglist at  https://www.ibr.cs.tu-bs.de/mailman/listinfo/ibr-dtn

Am 04.03.2013 um 16:06 schrieb Bruno Tavares <[email-masked]>:

> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest