Subject: [dtn-interest] Priority QoS implementation in DTN

From: Alex López <[email-masked]>
Date: Mon, 11 Mar 2013 14:28:15 +0100

Hello all,

I've been studying how the priority parameter works with IBRDTN
implementation of DTN in a MANET that I have with 4 openwrt routers. My lab
setup is the following:

Source 1 --\
                 \
                  \
                   Node 3 -------> End 4
                  /
                 /
Source 2---/

I've observed that if I try to send a file with a high priority from source
1 to End 4, and a file with low priority from source 2 to End 4, the file
with low priority is received in End 4 before the file with high priority.
The routing is set to epidemic.

Reading the RFC 4838, it says the following:

Applications specify their requested priority class and data lifetime (see
> below) for each ADU they send. This information, coupled with policy
> applied at DTN nodes that select how messages are forwarded and which
> routing algorithms are in use, affects the overall likelihood and
> timeliness of ADU delivery.
>

> The priority class of a bundle is only required to relate to other bundles
> from the same source. This means that a high priority bundle from one
> source may not be delivered faster (or with some other superior quality of
> service) than a medium priority bundle from a different source. It does
> mean that a high priority bundle from one source will be handled
> preferentially to a lower priority bundle sent from the same source.
>

> Depending on a particular DTN node’s forwarding/scheduling policy,
> priority may or may not be enforced across different sources. That is, in
> some DTN nodes, expedited bundles might always be sent prior to any bulk
> bundles, irrespective of source. Many variations are possible.

If I understand well, the priority marking that is done in the Sources,
it's lost in the intermediate Node 3, right? I cannot imagine why DTN works
like this? It is really an stupid QoS no? Whats the reason behind this
implementation? There is any way that the Node 3 recognizes the priority of
the bundles that it has in custody? And from what source they are from?

Maybe it is because DTN is aiming for a only bidirectional communication
between only 1 source and 1 end and multiple nodes? So a MANET could not be
the best option to set a DTN implementation?

Thanks in advance.

---

From: "Burleigh, Scott C (313B)" <[email-masked]>
Date: Wed, 13 Mar 2013 15:35:18 +0000

Good point, Alex.  I think the answer is that, at the time 4838 was written, it seemed important not to close off any possible good ideas for QoS that might emerge from the development of the specific protocols.  Now that we've got some experience with implementation and operations, maybe we should start thinking about narrowing in on some specific policies.  In the meantime, I think the most important part of the text you quote is the last paragraph: many variations are possible, and I believe different DTN implementations exercise several of those variations.  ION, for example, completely ignores the source endpoint when prioritizing bundle transmission.

Scott

From: [email-masked] [mailto:[email-masked]] On Behalf Of Alex López
Sent: Monday, March 11, 2013 6:28 AM
To: [email-masked]
Subject: [dtn-interest] Priority QoS implementation in DTN

Hello all,

I've been studying how the priority parameter works with IBRDTN implementation of DTN in a MANET that I have with 4 openwrt routers. My lab setup is the following:

Source 1 --\
                 \
                  \
                   Node 3 -------> End 4
                  /
                 /
Source 2---/

I've observed that if I try to send a file with a high priority from source 1 to End 4, and a file with low priority from source 2 to End 4, the file with low priority is received in End 4 before the file with high priority. The routing is set to epidemic.

Applications specify their requested priority class and data lifetime (see below) for each ADU they send. This information, coupled with policy applied at DTN nodes that select how messages are forwarded and which routing algorithms are in use, affects the overall likelihood and timeliness of ADU delivery.

The priority class of a bundle is only required to relate to other bundles from the same source. This means that a high priority bundle from one source may not be delivered faster (or with some other superior quality of service) than a medium priority bundle from a different source. It does mean that a high priority bundle from one source will be handled preferentially to a lower priority bundle sent from the same source.

Depending on a particular DTN node's forwarding/scheduling policy, priority may or may not be enforced across different sources. That is, in some DTN nodes, expedited bundles might always be sent prior to any bulk bundles, irrespective of source. Many variations are possible.

If I understand well, the priority marking that is done in the Sources, it's lost in the intermediate Node 3, right? I cannot imagine why DTN works like this? It is really an stupid QoS no? Whats the reason behind this implementation? There is any way that the Node 3 recognizes the priority of the bundles that it has in custody? And from what source they are from?

Maybe it is because DTN is aiming for a only bidirectional communication between only 1 source and 1 end and multiple nodes? So a MANET could not be the best option to set a DTN implementation?

Thanks in advance.