Subject: [dtn-interest] DTN Final Work for College

From: Rafael Oliveira Carvalho <[email-masked]>
Date: Wed, 14 Aug 2013 06:11:09 -0700 (PDT)

Hi,

I been read a lot about de DTN, i even spoke with Kevin Gifford, and i really interesting in meke the DTN the theme of my Final Work on College.
I'm Brazilian, so sorry my english case it's wrong, in my search about the subject i found this DTNRG, and i think that you can help me with tecnica material and information to create the final work.
I wanna know if is possible to create a simple environment to test the DTN, or some simulation software.
Can anyone help me?

Regards,

Rafael de Oliveira Carvalho
____________________________________________
CPM Braxis - Prestador de serviço do Terra
CORe: +55 (51) 3284-4200 ou ramal 4179
Service Delivery Latam – Terra Brasil

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Wed, 14 Aug 2013 09:14:56 -0500

Rafael,

You can certainly do this with virtual machines.

I suggest looking at

http://www.dtnrg.org/wiki/

http://www.dtnrg.org/wiki/DtnBone/grc-dtnbone

http://grc.nasa.dtnbone.net/

**** Please Please Please put disconnection into your network. *****

As far as code goes, all of my small business subcontractors have “Independently” chosen IBR-DTN.  It really depends on how much you want to manipulate the code.  DTN-IBR was a fresh start. (Note, I am not a coder, but , my understanding is DTN2 is not the easiest piece to manipulate due to it genetics and evolutionary history. Others would have better insight.)

If you want to develop something useful to the community, I have been wanting a DTN Trace Route tool for four or five years.  It is not a simple thing if you consider disconnections and that paths may change and that the return path may be completely different than the forward path.

See slides 13 and 17.  Note, some of these have test applications  been done, but usually without log periods of disconnection or disruption that require some real thought.

http://roland.grc.nasa.gov/~ivancic/DTN/DTN-NEONet-Ivancic-3June2009-Google.ppt

There may be other pieces of information that are of interest here:
http://roland.grc.nasa.gov/~ivancic/DTN/

Feel free to contact me if you want additional input.

Will Ivancic

******************************
http://roland.grc.nasa.gov/~ivancic

________________________________
From: Rafael Oliveira Carvalho <[email-masked]>
Reply-To: Rafael Oliveira Carvalho <[email-masked]>
Date: Wed, 14 Aug 2013 08:11:09 -0500
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [dtn-interest] DTN Final Work for College

Hi,

Regards,

---

From: "Scott, Keith L." <[email-masked]>
Date: Wed, 14 Aug 2013 14:20:50 +0000

For an emulation environment I like the Common Open Research Emulator (CORE) available from the Naval Research Laboratory (http://cs.itd.nrl.navy.mil/work/core/).  It's a very nice GUI on top of Linux virtual containers and provides a nice environment for setting up topologies and scenarios.

For implementations I'd suggest considering also the JDTN implementation, available from SourceForge (I wasn't aware that the IBR-DTN implementation was publicly available).  There are some issues with JDTN (I believe, there's some room for interpretation here) with respect to custody transfer, but the code seems well-written and pretty easy to understand.

Tchau,

                        --keith

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ivancic, William D. (GRC-RHN0)
Sent: Wednesday, August 14, 2013 10:15 AM
To: Rafael Oliveira Carvalho; [email-masked]
Subject: Re: [dtn-interest] DTN Final Work for College

Rafael,

I suggest looking at

As far as code goes, all of my small business subcontractors have "Independently" chosen IBR-DTN.  It really depends on how much you want to manipulate the code.  DTN-IBR was a fresh start. (Note, I am not a coder, but , my understanding is DTN2 is not the easiest piece to manipulate due to it genetics and evolutionary history. Others would have better insight.)

Will Ivancic

Hi,

Regards,
Service Delivery Latam - Terra Brasil

---

From: Juliano Fischer Naves <[email-masked]>
Date: Sat, 17 Aug 2013 11:21:55 -0400

Hi Rafael,
I worked with forwarding and buffer management policies for DTN's.
I used the Opportunistic Network Simulator (TheONE) [1] to test the
proposals.
I'm available to help you as much as possible.
If you choose to use ONE, I can help you with the simulator and simulation
environment.
However, I must warn you also there are some issues regarding custody
transfer with ONE and this simulator focuses on the "routing layer", using
a very simple physical/link layers models.

Good luck.

[1] - http://www.netlab.tkk.fi/tutkimus/dtn/theone/

Juliano Fischer Naves
Ph.D. Student
IC/UFF - Brazil

2013/8/14 Scott, Keith L. <[email-masked]>

>  For an emulation environment I like the Common Open Research Emulator
> (CORE) available from the Naval Research Laboratory (
> http://cs.itd.nrl.navy.mil/work/core/).  It’s a very nice GUI on top of
> Linux virtual containers and provides a nice environment for setting up
> topologies and scenarios.****
>
> ** **
>
> For implementations I’d suggest considering also the JDTN implementation,
> available from SourceForge (I wasn’t aware that the IBR-DTN implementation
> was publicly available).  There are some issues with JDTN (I believe,
> there’s some room for interpretation here) with respect to custody
> transfer, but the code seems well-written and pretty easy to understand.**
> **
>
> ** **
>
> Tchau,****
>
> ** **
>
>                         --keith****
>
> ** **
>
> *From:* [email-masked] [mailto:
> [email-masked]] *On Behalf Of *Ivancic, William D.
> (GRC-RHN0)
> *Sent:* Wednesday, August 14, 2013 10:15 AM
> *To:* Rafael Oliveira Carvalho; [email-masked]
> *Subject:* Re: [dtn-interest] DTN Final Work for College****
>
> ** **
>
> Rafael,
>
> As far as code goes, all of my small business subcontractors have
> “Independently” chosen IBR-DTN.  It really depends on how much you want to
> manipulate the code.  DTN-IBR was a fresh start. (Note, I am not a coder,
> but , my understanding is DTN2 is not the easiest piece to manipulate due
> to it genetics and evolutionary history. Others would have better insight.)
>
> If you want to develop something useful to the community, I have been
> wanting a DTN Trace Route tool for four or five years.  It is not a simple
> thing if you consider disconnections and that paths may change and that the
> return path may be completely different than the forward path.
>
>
> See slides 13 and 17.  Note, some of these have test applications  been
> done, but usually without log periods of disconnection or disruption that
> require some real thought.
>
>
> ****
>  ------------------------------
>
> *From: *Rafael Oliveira Carvalho <[email-masked]>
> *Reply-To: *Rafael Oliveira Carvalho <[email-masked]>
> *Date: *Wed, 14 Aug 2013 08:11:09 -0500
> *To: *"[email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>
> *Subject: *[dtn-interest] DTN Final Work for College
>
> Hi,
>
> I been read a lot about de DTN, i even spoke with Kevin Gifford, and i
> really interesting in meke the DTN the theme of my Final Work on College.
> I'm Brazilian, so sorry my english case it's wrong, in my search about the
> subject i found this DTNRG, and i think that you can help me with tecnica
> material and information to create the final work.
> Service Delivery Latam – Terra Brasil ****
>
> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest
>
>