Subject: Re: [dtn-interest] [dtn-users] RFC: public DTN service in a cloud

From: Lalit <[email-masked]>
Date: Thu, 3 Apr 2014 10:22:33 +0530

Hello *Dmitry Monakhov*

 *Are you working on this thread? I would like to know your progress on
this.*

*I think there will be a bundle security issue in case of bundle uploading
to gdata. *

*Regards,*
*Lalit*

   - *From*: Dmitry Monakhov <dmonlist at gmail.com <[email-masked]>
   - *To*: dtn-users at irtf.org <[email-masked]>
   - *Date*: Wed, 22 Feb 2012 11:21:22 +0000
   - *List-id*: "The Delay-Tolerant Networking Research Group \(DTNRG\) -
   Users." <dtn-users.irtf.org>

------------------------------

Hello,
I want use dnt as exchange protocol in MANET for mobile devices
for a general purpose data exchange. Ideally user just have to install
an DTN application on his phone and all services just works
1) file transfer
2) email/twitter/block posting
Bytewalla already allow to exchange files via devices.
But in order to route data via internet we need  dedicated
DTN services/gateways which is very not suitable for non experienced
users because some extra work is required.

As an alternative we can exploit a cloud service for that purpose.
For example we can use google gdata api like follows:

*Specify eid for cloud like follows dtn://dnt.google.docs/dst_user
*Send_to_cloud procedure:
  0) login to gdata api
  1) create empty file
  2) copy bundle content to it
  3) add required attributes to that document (dtn_tag, eid_tag and etc.)
  3) share this document with dst_user
*Recv from cloud procedure
  0) login to gdata api
  1) search for documents with dtn_tag
  2) copy file to local storage
  3) import file to local dnt service.

What do you think about that? Was it discussed already?
What is the best way to implement such gateway?
Currently I'm look in to external router level.

---

From: "Scott, Keith L." <[email-masked]>
Date: Thu, 3 Apr 2014 06:48:21 +0000

This sounds to me like a gdata convergence layer for DTN, an interesting idea.  DTN2 had at one point a notion of a 'file' convergence layer (for putting bundles on e.g. USB memory sticks) though I don't know what the implementation status is.  A benefit of integrating this as a convergence layer would be that things like integrating the destination addressing, bundle security, etc. should 'just work'.

                        --keith

From: dtn-interest [mailto:[email-masked]] On Behalf Of Lalit
Sent: Thursday, April 03, 2014 6:53 AM
To: [email-masked]
Subject: Re: [dtn-interest] [dtn-users] RFC: public DTN service in a cloud

Hello Dmitry Monakhov

Are you working on this thread? I would like to know your progress on this.

I think there will be a bundle security issue in case of bundle uploading to gdata.

Regards,
Lalit

*        From: Dmitry Monakhov <dmonlist at gmail.com<mailto:[email-masked]>>
*        To: dtn-users at irtf.org<mailto:[email-masked]>
*        Date: Wed, 22 Feb 2012 11:21:22 +0000
*        List-id: "The Delay-Tolerant Networking Research Group \(DTNRG\) - Users." <dtn-users.irtf.org<http://dtn-users.irtf.org>>
________________________________

Hello,

1) file transfer

  0) login to gdata api

  1) create empty file

  0) login to gdata api