Subject: [dtn-interest] Multicast routing

From: "Prof. Marcelo" <[email-masked]>
Date: Sun, 1 Jun 2014 23:30:04 -0300

Hello everybody, how are you?

I don´t know if here is the best place to this question, but I think here
it's! Somebody could help me? I'd like to know what i the state of art in
multicast routing for DTN? I read some papers, like surveys and performance
comparison, but all of then date from 2009. Nowadays what are you using for
multicast routing in DTN?

Thanks!

Marcelo Guido

---

From: waldir moreira <[email-masked]>
Date: Mon, 2 Jun 2014 14:55:43 +0000

Dear Marcelo,
Our group has gone in this direction with SCORP, that exploits groups with similar interests. SCORP forwards data based on the interest that devices present on content (similar to multicast join groups).
For further info, please refer to http://copelabs.ulusofona.pt/scicommons/index.php/publications/show/438 
As a side note, SCORP is based on dLife that has been presented to IRTF DTNRG.http://datatracker.ietf.org/doc/draft-moreira-dlife/
http://copelabs.ulusofona.pt/scicommons/index.php/publications/show/270
BR,
Waldir Aranha Moreira Junior, M.Sc.
Researcher at the Association for Research and Development in Cognition and People Centric Computing - COPELABS/ULHT/ULP
MAP-Tele Doctoral Programme Student - UA/Aveiro
Member of the Research Group on Computer Networks and Multimedia Communications - GERCOM/UFPA
LinkedIn profile

Begin forwarded message:From: "Prof. Marcelo" <[email-masked]>
Subject: [dtn-interest] Multicast routing
Date: June 2, 2014 3:30:04 AM GMT+01:00
To: "[email-masked]" <[email-masked]>

I don´t know if here is the best place to this question, but I think here it's! Somebody could help me? I'd like to know what i the state of art in multicast routing for DTN? I read some papers, like surveys and performance comparison, but all of then date from 2009. Nowadays what are you using for multicast routing in DTN?

Thanks!

Marcelo Guido

_______________________________________________
dtn-interest mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/dtn-interest

Melhores Cumprimentos/Best Regards/Mit Freundlichen GruessenPaulo Mendes------------------------------------------------------------
Paulo Mendes, Ph.D
Vice-director of the Research Unit in Cognition and People Centric Computing (COPELABS)
Director of the Ph.D program on Informatics - New Media and Pervasive Systems (NEMPS)
Associated Professor at University Lusofona, Portugal
http://copelabs.ulusofona.pt/~pmendes
Tel.: +351 217 50 50 22

---

From: "Burleigh, Scott C (312G)" <[email-masked]>
Date: Mon, 2 Jun 2014 15:03:51 +0000

I think there are some relevant research papers in the proceedings of 2012 IEEE INFOCOM and the 2013 IEEE International Conference on Communications.

There’s a multicast mechanism in ION that runs very well, but it’s not standard and it only works for nodes that can be identified by “ipn”-scheme EIDs.  The spec is in an expired Internet Draft: https://datatracker.ietf.org/doc/draft-burleigh-dtnrg-imc/.

Scott

From: dtn-interest [mailto:[email-masked]] On Behalf Of Prof. Marcelo
Sent: Sunday, June 01, 2014 7:30 PM
To: [email-masked]
Subject: [dtn-interest] Multicast routing

---

From: "Zegura, Ellen Witte" <[email-masked]>
Date: Mon, 2 Jun 2014 15:19:56 +0000

I know you are asking for current state-of-the-art, but I wanted to also point out what may be the first paper on multicast routing in DTNs:

"Multicasting in Delay Tolerant Networks: Semantic Models and Routing Algorithms", Zhao, Ammar and Zegura, Proceedings of the 2005 ACM SIGCOMM Workshop on Delay-Tolerant Networking.

http://dl.acm.org/citation.cfm?id=1080145&CFID=349769107&CFTOKEN=37406662

Best - Ellen

On Jun 2, 2014, at 11:03 AM, Burleigh, Scott C (312G) <[email-masked]<mailto:[email-masked]>> wrote:

Scott

From: dtn-interest [mailto:[email-masked]] On Behalf Of Prof. Marcelo
Sent: Sunday, June 01, 2014 7:30 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [dtn-interest] Multicast routing

[email-masked]<mailto:[email-masked]>

---

From: Elwyn Davies <[email-masked]>
Date: Mon, 02 Jun 2014 16:52:12 +0100

Hi.

Attached are the bibtex refs for a selection of DTN multicast routing 
papers, some of which are more recent than 2009.

Part of the issue is that we have never really sorted out multicast 
addressing in DTN.  In principle EIDs can be multi-point but the DTN2 
code doesn't handle the multi-point case in any sensible way.

I looked at how to handle this when implementing the netinf ICN protocol 
over the BP and came up with some ideas that actually hark back to the 
service type addressing/naming that was discussed in DTNRG.  See 
draft-irtf-dtnrg-dtn-uri-scheme-00.txt and a presentation at the DTNRG 
meeting at Google in 2009 (see DTNRG slides at IETF 74 for web ref).  
There was also intentional naming - see draft-pbasu-dtnrg-naming-00.tx 
and presentations at IETF 65, 71, Google meeting before IETF 74, 75.

Unfortunately very little of this has been implemented.

Regards,
Elwyn

On 02/06/14 03:30, Prof. Marcelo wrote:
> I don´t know if here is the best place to this question, but I think 
> here it's! Somebody could help me? I'd like to know what i the state 
> of art in multicast routing for DTN? I read some papers, like surveys 
> and performance comparison, but all of then date from 2009. Nowadays 
> what are you using for multicast routing in DTN?
>
> Thanks!
>
> Marcelo Guido
>
>