Subject: [dtn-interest] DTN static routing

From: Nabil Benamar <[email-masked]>
Date: Tue, 21 Apr 2015 18:48:21 +0100

Hi All,

I would like to work on the topic of static routing in DTN for which I have
volunteered in IETF'92. My question is whether there some previous
documents that have treated this aspect in this IRTF or IETF ?

Thanks

-- 

Best Regards

*nabilbenamar.ipv6-lab.net <http://nabilbenamar.ipv6-lab.net/>*

---

From: Greg Troxel <[email-masked]>
Date: Tue, 21 Apr 2015 18:08:57 -0400

> documents that have treated this aspect in this IRTF or IETF ?

Could you expand on what static routing in DTN means?  It seems if D
stands for Disruption, then perhaps that means static paths and one
waits sequentially for links to work.  Would these be configured by
humans?  What aspect, if any, would be controlled by a routing protocol?

---

From: "Ivancic, William D. (GRC-LCA0)" <[email-masked]>
Date: Wed, 22 Apr 2015 12:35:15 +0000

My understanding is Static mean hard wired.  You know what, where and when
- similar to IP static routing where you know what and where.  No protocol
is involved.  It is simply configuration.  You propagate the forwarding
table.

If I recall correctly, static routes usually get preference over dynamic
routes.

Will

---

From: Greg Troxel <[email-masked]>
Date: Wed, 22 Apr 2015 08:37:52 -0400

> If I recall correctly, static routes usually get preference over dynamic

That makes sense.  I wonder then what it means to work on it - to fix up
the reference implementation so that it has equivalents to "netstat -r",
"route add", etc.?  Or to write a document giving guidance to people
deciding which static routes to add?   Or ?

---

From: "Ivancic, William D. (GRC-LCA0)" <[email-masked]>
Date: Wed, 22 Apr 2015 12:53:48 +0000

In line.

On 4/22/15 8:37 AM, "Greg Troxel" <[email-masked]> wrote:

>That makes sense.  I wonder then what it means to work on it

Me too.  

>- to fix up

I guess one thing would be to state whether or not the "when" is required.

A second is to state whether "Static" or "Dynamic" has precedence.
Actually, I prefer dynamic if it is available. If you are doing Static
routing, it is because you do not have Dynamic routing. Static tends to
get you in trouble.  We may think we know all, but we usually don't.

I think this should be a very short document.  Maybe it could actually be
incorporated into 5050bis or some other document that states default
assumptions.

Will

---

From: Nabil Benamar <[email-masked]>
Date: Wed, 22 Apr 2015 15:18:31 +0100

Hi All,

Thank you for your insights and comments!
In fact, I have suggested during the DTN session in Dallas why not to work
on Dynamic routing instead of static routing. I got an answer from the
chairs that we don't know which routing protocols could be considered !!
And this is the reason that pushed John and I to volunteer for static with
the intention to provide a document (short or detailed ) on the aspect !

We do static routing in some cases even if Dynamic routing is available.
It's the case when one wants a stable path (through a firewall) for the
packets.

-- 

Best Regards

---

From: "Ivancic, William D. (GRC-LCA0)" <[email-masked]>
Date: Wed, 22 Apr 2015 14:22:14 +0000

With DTN, a Static Route , of course,  must specify the convergence layer as well.  Thus:  What, Where, ?When?  And  Convergence Layer.

Will

From: Nabil Benamar <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, April 22, 2015 10:18 AM
To: William Ivancic <[email-masked]<mailto:[email-masked]>>
Cc: Greg Troxel <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [dtn-interest] DTN static routing

Hi All,

Thank you for your insights and comments!
In fact, I have suggested during the DTN session in Dallas why not to work on Dynamic routing instead of static routing. I got an answer from the chairs that we don't know which routing protocols could be considered !! And this is the reason that pushed John and I to volunteer for static with the intention to provide a document (short or detailed ) on the aspect !

We do static routing in some cases even if Dynamic routing is available. It's the case when one wants a stable path (through a firewall) for the packets.

On Wed, Apr 22, 2015 at 1:53 PM, Ivancic, William D. (GRC-LCA0) <[email-masked]<mailto:[email-masked]>> wrote:
In line.

On 4/22/15 8:37 AM, "Greg Troxel" <[email-masked]<mailto:[email-masked]>> wrote:

>
>"Ivancic, William D. (GRC-LCA0)" <[email-masked]<mailto:[email-masked]>> writes:
>

Me too.

Will

--

Best Regards

[http://nabilbenamar.ipv6-lab.net/sites/default/files/card_0.jpg]

nabilbenamar.ipv6-lab.net<http://nabilbenamar.ipv6-lab.net/>

---

From: Paulo Mendes <[email-masked]>
Date: Thu, 23 Apr 2015 22:24:41 +0100

Dear Nabil

For me it makes no sense to talk about static routing when we are talking about networks that should be able exploit any forwarding opportunistic to overcome the problem of facing intermittent Internet connectivity. If you’re talking about Delay-tolerant Networks as in transmissions over long delay links, it makes no sense to talk about routing at all, since the problem is more a reliable transport problem. On the other hand if you are talking about Disruptive-tolerant Networks, then you need dynamic routing to overcome the intermittent connectivity, implementing a store-carry-forward algorithm.

What chairs are you referring to? It should be from the new DTNWG and not from DTNRG. To the best of my knowledge there were presented at least two routing proposals to DTNRG. One is Prophet, which is now RFC6693, and the other is dLife (https://datatracker.ietf.org/doc/draft-moreira-dlife/ <https://datatracker.ietf.org/doc/draft-moreira-dlife/> ). dLife last version is the fourth one. In the meantime, due to lack of feedback, we didn’t releases version 5 in the DTNRG. Currently dLife is being exploited in the European project UMOBILE (http://www.umobile-project.eu <http://www.umobile-project.eu/>).

Paulo

> On 22 Apr 2015, at 15:18, Nabil Benamar <[email-masked]> wrote:
> 
> Hi All,
> 
> On Wed, Apr 22, 2015 at 1:53 PM, Ivancic, William D. (GRC-LCA0) <[email-masked] <mailto:[email-masked]>> wrote:
> In line.
> 
> On 4/22/15 8:37 AM, "Greg Troxel" <[email-masked] <mailto:[email-masked]>> wrote:
> 
> >
> >"Ivancic, William D. (GRC-LCA0)" <[email-masked] <mailto:[email-masked]>> writes:
> >
> nabilbenamar.ipv6-lab.net <http://nabilbenamar.ipv6-lab.net/>
> 
> 
> 
> _______________________________________________
> dtn-interest mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/dtn-interest <https://www.irtf.org/mailman/listinfo/dtn-interest>
Melhores Cumprimentos/Best Regards/Mit Freundlichen Gruessen
Paulo Mendes
------------------------------------------------------------
Paulo Mendes, Ph.D
Vice-director of the Research Unit in Cognition and People Centric Computing (COPELABS)
Director of the Ph.D program on Informatics - New Media and Pervasive Systems (NEMPS)
Associated Professor at University Lusofona, Portugal

http://copelabs.ulusofona.pt/~pmendes
Tel.: +351 217 50 50 22

---

From: "Ivancic, William D. (GRC-LCA0)" <[email-masked]>
Date: Mon, 27 Apr 2015 13:10:01 +0000

IN LINE

On 4/27/15 5:47 AM, "Rick Taylor" <[email-masked]> wrote:

>Nabil, et al.
>
>I have been mulling over the comments here about static routing, and
>although I do agree with most of the comments along the lines of "Static
>routes are just entries in a config file stating where to forward
>bundles, dynamic routing is much harder/interesting", I do have a
>question to those interested:
>
>What do I put in my 'static routing table' for DTN? (Please note I am
>not asking about a specific DTN implementation, this is a more general
>question)

Well, for one, it is convergence layer dependent - at least the way DTN2
and ION work if my recollections is correct.

I think a static route in DTN needs to know when and  for how long
(contact time),what convergence layer and what is the next hop URL.

>
>For IPv4, I would have an entry like: 10.10.0.0/16 via 10.1.1.1. But in
>a DTN network, endpoints have string EIDs, with no concept of
>subnetting.  I know there has been some work on intermediate node ids,
>but I am not sure if the concept of 'subnetting' or grouping has been
>explored.
>
>So, yes, static routing seems like a simple topic, but unless every
>implementation is happy to have a routing table containing a next hop
>entry for every potentially routeable endpoint, and every dynamic
>routing protocol is happy to exchange such potentially large sets of
>routes, there has to be some work done in endpoint
>aggregation/sub-netting, and this, I suggest, would be the most useful
>output from any work on static routing in DTNs.

This is naming and addressing to me.   Yes, work needs to be done here,
but I think that was declared out of scope for the newly formed DTN WG -
until the basics are complete and then a recharter.  Same goes for routing
protocols if I understood correctly.  However, neither is not out of scope
for the DTNRG.

Will

---

From: "Juan A. Fraire" <[email-masked]>
Date: Mon, 27 Apr 2015 11:27:25 -0300

Some comments in-line.

> (contact time),what convergence layer and what is the next hop URL.

We have been working in the contact plan design problem (predictable DTN)
for a while now, and I think that static routing should be thought in a way
it
can coexist and exploit contact plan information. Indeed, contact time and
CLA-to-use are already part of the contact plan (used either for dynamic or
static
routing), while next hop should be part of the static routing table. An
interesting
discussion might arise regarding whether if the next hop is enough, since
the
full path to destination might be necessary for congestion avoidance and/or
embedding the route path in the bundle header (EB-CGR).

> protocols if I understood correctly.  However, neither is not out of scope

I agree with Will here.

> Will

J. Fraire

> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest
>

---

From: Amy Alford <[email-masked]>
Date: Mon, 27 Apr 2015 12:29:09 -0400

Somebody correct me if I'm wrong here, but DTN2 allows wildcarding of
eids.  This is not an ideal solution, but it does let you do grouping if
you pick your eids appropriately.  I allow wildcarding in the rules tables
for my internal version of BSP/SBSP for the same reason.
- Amy

On Mon, Apr 27, 2015 at 5:47 AM, Rick Taylor <[email-masked]
> wrote:

> Hopefully this sounds like work that the IETF should tackle, rather than
> the IRTF, it seeming more like an 'engineering' task to me.
>
> Comments anyone?
>
> Rick Taylor
>
> On 23/04/15 22:25, Paulo Mendes wrote:
> > Dear Nabil
> >
> > For me it makes no sense to talk about static routing when we are
> > talking about networks that should be able exploit any forwarding
> > opportunistic to overcome the problem of facing intermittent Internet
> > connectivity. If you’re talking about Delay-tolerant Networks as in
> > transmissions over long delay links, it makes no sense to talk about
> > routing at all, since the problem is more a reliable transport problem.
> > On the other hand if you are talking about Disruptive-tolerant Networks,
> > then you need dynamic routing to overcome the intermittent connectivity,
> > implementing a store-carry-forward algorithm.
> >
> > What chairs are you referring to? It should be from the new DTNWG and
> > not from DTNRG. To the best of my knowledge there were presented at
> > least two routing proposals to DTNRG. One is Prophet, which is now
> > RFC6693, and the other is dLife
> > (https://datatracker.ietf.org/doc/draft-moreira-dlife/ ). dLife last
> > version is the fourth one. In the meantime, due to lack of feedback, we
> > didn’t releases version 5 in the DTNRG. Currently dLife is being
> > exploited in the European project UMOBILE (http://www.umobile-project.eu
> ).
> >
> > Paulo
> >
> >> On 22 Apr 2015, at 15:18, Nabil Benamar <[email-masked]
> >> <mailto:[email-masked]>> wrote:
> >>
> >> Hi All,
> >>
> >> In fact, I have suggested during the DTN session in Dallas why not to
> >> work on Dynamic routing instead of static routing. I got an answer
> >> from the chairs that we don't know which routing protocols could be
> >> considered !! And this is the reason that pushed John and I to
> >> volunteer for static with the intention to provide a document (short
> >> or detailed ) on the aspect !
> >>
> >> We do static routing in some cases even if Dynamic routing is
> >> available. It's the case when one wants a stable path (through a
> >> firewall) for the packets.
> >>
> >>
> >> On Wed, Apr 22, 2015 at 1:53 PM, Ivancic, William D.
> >> (GRC-LCA0)<[email-masked]
> >> <mailto:[email-masked]>>wrote:
> >>
> >>     In line.
> >>
> >>     >"Ivancic, William D. (GRC-LCA0)" <[email-masked]
> <mailto:[email-masked]>>
> >>     writes:
> >>     >
> >>     >> My understanding is Static mean hard wired.  You know what,
> where and
> >>     >>when
> >> *
> >> *
> dtn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dtn
>

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Mon, 27 Apr 2015 20:25:21 +0000

ION also supports some primitive wild-carding of “dtn”-scheme endpoint IDs, and it additionally supports “ipn”-scheme static routing on the basis of “groups”, i.e., ranges of node numbers (which can nest).  Again, not ideal, but simple.

All of these mechanisms are implementation-specific, though.  I’m not yet clear on what standardization of static routing would look like.

Scott

From: dtn-interest [mailto:[email-masked]] On Behalf Of Amy Alford
Sent: Monday, April 27, 2015 9:29 AM
To: Rick Taylor
Cc: [email-masked]; [email-masked]
Subject: Re: [dtn-interest] [dtn] DTN static routing

Somebody correct me if I'm wrong here, but DTN2 allows wildcarding of eids.  This is not an ideal solution, but it does let you do grouping if you pick your eids appropriately.  I allow wildcarding in the rules tables for my internal version of BSP/SBSP for the same reason.
- Amy

On Mon, Apr 27, 2015 at 5:47 AM, Rick Taylor <[email-masked]<mailto:[email-masked]>> wrote:
Nabil, et al.

For IPv4, I would have an entry like: 10.10.0.0/16<http://10.10.0.0/16> via 10.1.1.1. But in
a DTN network, endpoints have string EIDs, with no concept of
subnetting.  I know there has been some work on intermediate node ids,
but I am not sure if the concept of 'subnetting' or grouping has been
explored.

Comments anyone?

Rick Taylor

On 23/04/15 22:25, Paulo Mendes wrote:
> exploited in the European project UMOBILE (http://www.umobile-project.eu).
>
> Paulo
>
>> On 22 Apr 2015, at 15:18, Nabil Benamar <[email-masked]<mailto:[email-masked]>
>> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>>
>> Hi All,
>>
>> (GRC-LCA0)<[email-masked]<mailto:[email-masked]>
>> <mailto:[email-masked]<mailto:[email-masked]>>>wrote:
>>
>>     In line.
>>
>>     On 4/22/15 8:37 AM, "Greg Troxel" <[email-masked]<mailto:[email-masked]>
>>     <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>>
>>     >
>>     >"Ivancic, William D. (GRC-LCA0)" <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>>     writes:
>>     >
>>     *nabilbenamar.ipv6-lab.net<http://nabilbenamar.ipv6-lab.net> <http://nabilbenamar.ipv6-lab.net/>*
>>
>>
>> *
>> *
>> [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
> Tel.: +351 217 50 50 22<tel:%2B351%20217%2050%2050%2022>
>

_______________________________________________
dtn mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dtn