Subject: Re: [dtn-interest] FW: DTN2 Release

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 22 Jun 2016 14:39:45 +0200

I was wondering whether this ISS release is what reportedly runs on the 
ISS now?

Report:

June 21st, 2016, "New Solar System Internet Technology Debuts on the 
International Space Station"
http://www.nasa.gov/feature/new-solar-system-internet-technology-debuts-on-the-international-space-station

Alex

Le 03/03/2016 à 18:11, Vint Cerf a écrit :
> This is very good news - thank you for sharing - what kinds of
> applications might we expect to hear about from ISS this year?
>
> vint
>
>
> On Thu, Mar 3, 2016 at 11:39 AM, Pitts, Robert L. (MSFC-EO50)[HOSC
> SERVICES CONTRACT] <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Vint, ____
>
>     __ __
>
>     I thought you might be interested in our current ISS release and
>     what we are releasing on sourceforge.  The enhancements are critical
>     to our operational capabilities.____
>
>     __ __
>
>     Lee____
>
>     __ __
>
>     *From:*Pitts, Robert L. (MSFC-EO50)[HOSC SERVICES CONTRACT]
>     *Sent:* Thursday, March 03, 2016 9:29 AM
>     *To:* Scott, Keith L.; Burleigh, Scott C (JPL-312B)[Jet Propulsion
>     Laboratory]; Schlesinger, Adam M. (JSC-XS111)
>     *Cc:* Nichols, Kelvin F. (MSFC-EO50); Zoller, David A.
>     (MSFC-EO50)[HOSC SERVICES CONTRACT]
>     *Subject:* FW: DTN2 Release
>     *Importance:* High____
>
>     __ __
>
>     To all,____
>
>     __ __
>
>     We have provided a group of patches to the DTN2.9 on sourceforge.
>     https://sourceforge.net/p/dtn/patches/8/    These patches contain
>     the modifications used in operations at Marshall Space Flight Center
>     (MSFC) in support of the International Space Station and several
>     recent additions that will be rolled into it in the future. MSFC
>     hosts a DTN2 based gateway node on the ground that communicates via
>     LTP over UDP with an onboard ION gateway node to provide DTN
>     capabilities to payloads.____
>
>     Included are:____
>
>     __·         __Performance improvements____
>
>     __·         __IPN Scheme support fixes and enhancements____
>
>     __·         __LTP over UDP (LTPUDP) Convergence Layer____
>
>     __·         __LTPUDP with LTP Authentication extensions____
>
>     __·         __STCP Convergence Layer (ION innovation)____
>
>     __·         __External Router enhancements and our EHS Router____
>
>     __·         __Extended Class of Service support (only EHS Router
>     makes use of it for routing decisions)____
>
>     __·         __Aggregate Custody Signal support____
>
>     __·         __Delay Tolerant Payload Conditioning____
>
>     __ __
>
>     There are several new or newly enhanced items that such as we have
>     LTP with Auth an independent capability to test with.  LTP over UDP
>     is completely re-engineered, STCP included with the ION model, the
>     external router has been rewritten and enhanced to allow us to
>     manage our uplinks based on AOS/LOS and control center needs, and
>     various fixes or enhancements.____
>
>     __ __
>
>     Lee____
>
>     __ __
>
>     *From:*Zoller, David A. (MSFC-EO50)[HOSC SERVICES CONTRACT]
>     *Sent:* Monday, February 29, 2016 1:37 PM
>     *To:* Pitts, Robert L. (MSFC-EO50)[HOSC SERVICES CONTRACT]; Watts,
>     Mark S. (MSFC-EO50)[HOSC SERVICES CONTRACT]
>     *Subject:* DTN2 Release____
>
>     __ __
>
>     I believe we are ready to upload the patches – probably this
>     afternoon or evening. Attached is the document with one page needing
>     a screenshot of the patch page to complete. ____
>
>     __ __
>
>     David Zoller____
>
>     COLSA Corporation____
>
>     MSFC/4666 - 2103  ____
>
>     (Office:(256) 544-1820 <tel:%28256%29%C2%A0544-1820>
>     *EMail: [email-masked] <mailto:[email-masked]>____
>
>     __ __
>
>
>
>
> --
> New postal address:
> Google
> 1875 Explorer Street, 10th Floor
> Reston, VA 20190
>
>
> _______________________________________________
> dtn-interest mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-interest
>

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Wed, 22 Jun 2016 16:15:27 +0000

Exactly.  As Lee reported in March, we are running a DTN2-based gateway node on the ground that communicates via LTP over UDP with an onboard ION gateway node to provide DTN capabilities to payloads.

Scott

-----Original Message-----
From: dtn-interest [mailto:[email-masked]] On Behalf Of Alexandru Petrescu
Sent: Wednesday, June 22, 2016 5:40 AM
To: [email-masked]
Subject: Re: [dtn-interest] FW: DTN2 Release

I was wondering whether this ISS release is what reportedly runs on the ISS now?

Report:

June 21st, 2016, "New Solar System Internet Technology Debuts on the International Space Station"
http://www.nasa.gov/feature/new-solar-system-internet-technology-debuts-on-the-international-space-station

Alex

Le 03/03/2016 à 18:11, Vint Cerf a écrit :
>     I believe we are ready to upload the patches - probably this

---

From: "Juan A. Fraire" <[email-masked]>
Date: Wed, 22 Jun 2016 18:45:25 +0200

Dear all,

Congratulations, its great to see DTN implementations maturing. However I
wonder which is the reason (besides interoperability validation I suppose)
of having ION on board and DTN2 on ground. Appreciate any inputs on the
latter.

Regards,

Juan Fraire

On Wed, Jun 22, 2016 at 6:15 PM, Burleigh, Scott C (312B) <
[email-masked]> wrote:

> Exactly.  As Lee reported in March, we are running a DTN2-based gateway
> node on the ground that communicates via LTP over UDP with an onboard ION
> gateway node to provide DTN capabilities to payloads.
>
> Scott
>

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Wed, 22 Jun 2016 16:58:52 +0000

Good question.  I’d say the root answer is that NASA likes to preserve options wherever possible.  ION was designed to be usable on spacecraft.  It works fine in ground nodes too (some NASA ground system nodes do run ION, especially Windows machines), but running DTN2 in ground system nodes preserves an alternative while also serving as a check on the RFC compliance of ION.

Scott

From: Juan A. Fraire [mailto:[email-masked]]
Sent: Wednesday, June 22, 2016 9:45 AM
To: Burleigh, Scott C (312B) <[email-masked]>
Cc: Alexandru Petrescu <[email-masked]>; [email-masked]
Subject: Re: [dtn-interest] FW: DTN2 Release

Dear all,

Congratulations, its great to see DTN implementations maturing. However I wonder which is the reason (besides interoperability validation I suppose) of having ION on board and DTN2 on ground. Appreciate any inputs on the latter.

Regards,

Juan Fraire
[https://mailtrack.io/trace/mail/19748523c9e6a12cbbfd667f0479abd3ea6fcfe1.png?u=298567]

On Wed, Jun 22, 2016 at 6:15 PM, Burleigh, Scott C (312B) <[email-masked]<mailto:[email-masked]>> wrote:
Exactly.  As Lee reported in March, we are running a DTN2-based gateway node on the ground that communicates via LTP over UDP with an onboard ION gateway node to provide DTN capabilities to payloads.

Scott

-----Original Message-----
From: dtn-interest [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Alexandru Petrescu
Sent: Wednesday, June 22, 2016 5:40 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [dtn-interest] FW: DTN2 Release

Report:

Alex

Le 03/03/2016 à 18:11, Vint Cerf a écrit :
> SERVICES CONTRACT] <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>
>     Vint, ____
>
>     __ __
>
>     (Office:(256) 544-1820<tel:%28256%29%20544-1820> <tel:%28256%29%C2%A0544-1820>
>     *EMail: [email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>____
>
>     __ __
>
>
>
>
> --
> New postal address:
> Google
> [email-masked]<mailto:[email-masked]>

_______________________________________________
dtn-interest mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/dtn-interest

_______________________________________________
dtn-interest mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/dtn-interest