Subject: [dtn-users] problem-dtntest

From: gokul nath <[email-masked]>
Date: Tue, 20 Mar 2012 14:41:50 +0530

Hi,

I have been trying to run dtntest program.

So in terminal, through dtntest directory, I gave the command "./dtntest"
and I got  dtntest% prompt to run commands.

Then I tried, *dtn _open* and *dtn_close *commands which are working
properly.

But when I tried with *dtn_register* command with its requirements
(command, handle, endpoint and expiration) I found an error denoting that
the *specified endpoint* (I set my local eid)  is an invalid option and the
command given is as follows:

dtntest%* dtn_register  0  dtn://sip168.dtn  60 *

error: invalid option 'dtn://sip168.dtn'
while executing "*dtn_register  0  dtn://sip168.dtn  60*"
("uplevel" body line 1)
invoked from within
"uplevel \#0 $command($input)"
dtntest%

How to proceed?

Thanks in advance.
Gokul

---

From: "Andresen, Jason R." <[email-masked]>
Date: Tue, 20 Mar 2012 14:17:41 +0000

An endpoint consists of two parts, the "host" part and the "service" part.  You only specified the host.  Try something like this instead: dtn_register 0 dtn://sip168.dtn/testregister 60
________________________________________
From: [email-masked] [[email-masked]] on behalf of gokul nath [[email-masked]]
Sent: Tuesday, March 20, 2012 5:11 AM
To: Elwyn Davies; [email-masked]
Subject: [dtn-users] problem-dtntest

Hi,

So in terminal, through dtntest directory, I gave the command "./dtntest" and I got  dtntest% prompt to run commands.

Then I tried, dtn _open and dtn_close commands which are working properly.

But when I tried with dtn_register command with its requirements (command, handle, endpoint and expiration) I found an error denoting that the specified endpoint (I set my local eid)  is an invalid option and the command given is as follows:

dtntest% dtn_register  0  dtn://sip168.dtn  60

error: invalid option 'dtn://sip168.dtn'
while executing "dtn_register  0  dtn://sip168.dtn  60"
("uplevel" body line 1)
invoked from within
"uplevel \#0 $command($input)"
dtntest%

How to proceed?

Thanks in advance.
Gokul