Subject: [dtn-users] How to limit the bundle storage capacity of a DTN2 node

From: Patrice Raveneau <[email-masked]>
Date: Mon, 05 Mar 2012 19:57:28 +0100

Hello all,

I would like to limit the storage capacity of a node using the DTN2 
implementation.
I could not find any information about it in the documentation.
Is it possible? If yes, how can I manage it?

Thanks in advance.

Regards,

-- 
Patrice

---

From: Tom Sparks <[email-masked]>
Date: Mon, 5 Mar 2012 14:30:21 -0800 (PST)

--- On Tue, 6/3/12, Patrice Raveneau <[email-masked]> wrote:

> Hello all,
> 
> I would like to limit the storage capacity of a node using
> the DTN2 implementation.

the only two options I know of are Disk partitioning[1] or disk quota[2],
but I dont know how they would affect DTN2

[1] http://en.wikipedia.org/wiki/Disk_partitioning
[2] http://en.wikipedia.org/wiki/Disk_quota
> -- Patrice

---
tom_a_sparks "It's a nerdy thing I like to do"

---

From: Brenton Walker <[email-masked]>
Date: Mon, 05 Mar 2012 17:41:36 -0500

Hi Patrice,
     This config line should work.  We have used it to limit the storage 
on nodes in some experiments a couple years ago.  The quota might 
exclude primary and extension block data.

storage set payload_quota <bytes>
     storage quota in bytes for bundle payloads (default 0 - is unlimited)
     valid options:    number

Typing "help storage" in the dtnd console gives you all the 
storage-related options.

Thanks,
Brenton