Subject: [dtn-users] DTN2 tutorials

From: Tom O'Reilly <[email-masked]>
Date: Wed, 2 May 2012 14:36:31 -0700

Are there any real "hands-on" DTN2 tutorials beyond the extremely  
trivial examples in the DTN2 docs/ directory? Those examples are not  
very useful in building a larger directory.

Most of the "tutorials" listed at http://www.dtnrg.org/wiki/Docs#head-1375af1c39adfa7a05ac36d64ad76582533d2b26 
  are not hands-on tutorials in the usual sense, and most do not deal  
with DTN2 specifically.

An step-by-step example showing how to build a multi-node tcp/udp  
network with DTN2, showing actual configuration files would be very  
useful.

Thanks,
Tom

---

From: Tom O'Reilly <[email-masked]>
Date: Wed, 2 May 2012 14:41:22 -0700

On May 2, 2012, at 2:36 PM, Tom O'Reilly wrote:

> Those examples are not very useful in building a larger directory.

I mean a larger network, not directory.

> _______________________________________________
> dtn-users mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-users

------------------------------------------------
Thomas C. O'Reilly
Monterey Bay Aquarium Research Institute
7700 Sandholdt Road
Moss Landing, CA 95039
831-775-1766
[email-masked]
http://www.mbari.org
"The machine does not isolate man from the great mysteries of nature,
but plunges him more deeply into them."

     - ANTOINE DE SAINT-EXUPERY
       "Wind, Sand, and Stars" (1939)

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Thu, 3 May 2012 07:29:20 -0500

Any "large" network (greater than 4 or 5 nodes) and you'll want some type of routing protocol like Prophet, Epidemic, RAPID or APLE  or something.   It depends on your network and what you want to do.  CGR is also in there, but that is for very predictable networks like Space (Orbital Mechanics) and probably not for super large networks due to scaling.

- Will
On May 2, 2012, at 5:41 PM, Tom O'Reilly wrote:

Most of the "tutorials" listed at http://www.dtnrg.org/wiki/Docs#head-1375af1c39adfa7a05ac36d64ad76582533d2b26 are not hands-on tutorials in the usual sense, and most do not deal with DTN2 specifically.

An step-by-step example showing how to build a multi-node tcp/udp network with DTN2, showing actual configuration files would be very useful.

Thanks,
Tom

_______________________________________________
dtn-users mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/dtn-users

[email-masked]<mailto:[email-masked]>

_______________________________________________
dtn-users mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/dtn-users

******************************
William D. Ivancic
Phone 216-433-3494
Fax 216-433-8705
Networking Lab 216-433-2620
Mobile 440-503-4892
http://roland.grc.nasa.gov/~ivancic

---

From: "Scott, Keith L." <[email-masked]>
Date: Thu, 3 May 2012 12:33:20 +0000

If it's DTN2-based, the dtlsr router coupled with the IP-based neighbor discovery mechanisms will form decent-sized networks, provided the mobility is low enough for dtlsr to keep up.

Just out of curiosity: how large is large?  10, 100, 500, 1000?

                                --keith

From: [email-masked] [mailto:[email-masked]] On Behalf Of Tom O'Reilly
Sent: Wednesday, May 02, 2012 5:41 PM
To: Tom O'Reilly
Cc: [email-masked]
Subject: Re: [dtn-users] DTN2 tutorials

Thanks,
Tom

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Thu, 3 May 2012 07:49:38 -0500

If you want to get a feel for different routing protocols GRC's DTNbone network uses DTLSR and, I believe Ohio University uses CGR.

http://www.dtnrg.org/wiki/DtnBone

- Will

On May 3, 2012, at 8:33 AM, Scott, Keith L. wrote:

If it’s DTN2-based, the dtlsr router coupled with the IP-based neighbor discovery mechanisms will form decent-sized networks, provided the mobility is low enough for dtlsr to keep up.

                                --keith