Subject: Re: [dtn-users] dtn multicasting -?

From: "Victor Lyamtsev" <[email-masked]>
Date: Mon, 31 Dec 2012 14:08:45 +0000

William, Elwyn:
What i want to accomplish: reliable one-to-many message distribution in challenged MANETS, DTN is  considered as one of the approaches... 
In IP the concept is pretty clear: the same packet must be replicated to the range of endpoints within class D address. The confusing part was that i didn't find ( or, missed?) any part of DTN standards that would define DTN multicasting as such, just many papers on the topic.
Thank you very much for clarifications and happy New Year.
-Victor

------- Original Message -------
On 12/31/2012 1:26 PM Ivancic, William D. (GRC-RHN0) wrote:
Victor,  I agree with Elwyn that looking at multicast EID more like a
service may help.  Get a copy of John Day's book Patterns in Network
Architecture - not an easy read.  Chapter 9 goes into multicast,
multi-homing and mobility and such and gives a good discussion on what those
concepts really mean.  In the IP protocol we have multicast addresses, but
they really are not addresses in the normal sense.  Rather a multicast
address represents a set of endpoints.  Thus, a multicast EID represents a
set of EIDs (multicast group members). I think if you look at IP multicast
you can easily confused.

The other thing to consider is what do you really want to accomplish with
multicast?  There may be  better ways.  Information Centric Networking has a
lot of multicast like features that may be all you need.

--Will

******************************

> From: Elwyn Davies <[email-masked]>
> Date: Fri, 28 Dec 2012 13:35:30 -0600
> To: Victor Lyamtsev <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Subject: Re: [dtn-users] dtn multicasting -?
> 
> Hi.
> 
> The nearest thing to multicasting in DTN2 is epidemic routing which
> tries to send a received bundle to every other contact that the node
> makes until the bundle expires.
> 
> At present the MULTINODE endpoint concept is effectively not implemented
> at all in DTN2 although the low levels have the concept defined.  This
> would potentially give you a form of multicast group.
> 
> The feature has been requested for ION
> (http://sourceforge.net/p/ion-dtn/feature-requests/3/) this year.
> 
> I would also like to have it for certain ICN-like operations  but
> implementing multinode capabilities requires a considerable amount of
> work in DTN2:
> - allowing nodes to have more than one local EID
> - new discovery/announcement processes for offering auxiliary EIDs as
> well as the 'master' one that identifies the administrative name.
> - managing 'auxiliary' logical links and routes that use the master
> physical link to reach EIDs containing the auxiliary EIDs
> - adapting exiting routing/forwarding protocols to deal with MULTINODE
> EIDs
> 
> It might be possible to simplify the work on routing by treating the
> multipoint EID as a form of service on the 'master' EID rather than an
> independent EID in its own right.  Thus sending to
> dtn://some.multicast.service/zzz which is marked as a MULTIPOINT EID is
> effectively equivalent to sending to dtn:/*/some.multicast.service/zzz.
> 
> However, don't hold your breath for an imminent implementation in DTN2.
> 
> Regards,
> Elwyn
>  
> On Fri, 2012-12-28 at 15:28 +0000, Victor Lyamtsev wrote:
>> Hello,
>> Is there any completed standard/ implementation of bundle multicasting?
>> P.S. I am not asking about something like NORM convergence layer with
>> multicasting over ip, but the scenario with non-ip transport...
>> Thank you,
>> _______________________________________________
>> dtn-users mailing list
>> [email-masked]
>> https://www.irtf.org/mailman/listinfo/dtn-users
> 
> _______________________________________________
> dtn-users mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-users

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Mon, 31 Dec 2012 09:37:37 -0600

A few things to think about.

One-to-many.  Home much is many?  5, 10, 50,000?  If low, duplicate unicast
my actually result in less system-wide resource utilization.

Is your manet experiencing disconnection and disruption?

Are you multicast groups pre-defined prior to deployment or is there dynamic
join and leave?  Dynamic creation of multicast groups in a manet, is, to the
best of my knowledge, not well defined.  Dynamic creation of multicast
groups in a DTN is definitely not defined.

You might take a look at this paper for at least some EID naming concepts:

Endpoint Naming for Space Delay / Disruption Tolerant Networking

http://www.mitre.org/work/tech_papers/2010/09_5229/09_5229.pdf

FYI, I may be able to create an EID such as:
dtn://lat35.*lon-74.*
And I may even figure out how to send it to that location.  Now, how do the
devices at that location know to listen?

Lots of research and deployment issues that still need addressing.

-- Will

******************************
William D. Ivancic
Phone 216-433-3494
Fax 216-433-8705
Networking Lab 216-433-2620
Mobile 440-503-4892
http://roland.grc.nasa.gov/~ivancic

> From: Victor Lyamtsev <[email-masked]>
> Date: Mon, 31 Dec 2012 08:08:45 -0600
> To: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>,
> "[email-masked]" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, "[email-masked]"
> <[email-masked]>
> Subject: RE: Re: [dtn-users] dtn multicasting -?
> 
> William, Elwyn:
> What i want to accomplish: reliable one-to-many message distribution in
> challenged MANETS, DTN is  considered as one of the approaches...
> In IP the concept is pretty clear: the same packet must be replicated to the
> range of endpoints within class D address. The confusing part was that i
> didn't find ( or, missed?) any part of DTN standards that would define DTN
> multicasting as such, just many papers on the topic.