Subject: [dtn-users] BP-RI implementation test

From: Maël Auzias <[email-masked]>
Date: Wed, 19 Mar 2014 09:42:12 +0100

Hi everyone,

I'm testing the BP-RI
<http://masaka.cs.ohiou.edu/ocp/bundling.html>implementation. Once I
got it compiled without any error I try to run it as
described in the README.

However an error occurs at the start, here is the output:

*root@pc-mna-78:~/BP-RI/classes# java edu.ohiou.ocp.dtn.BPServer* #more
configuration details below
Off-World Communication Protocols Research Group BP-RI: 1.0
 Starting BP Server:v1.0...
BPServer failed to bind to //localhost/BPServer! - Connection refused to
host: localhost; nested exception is:
    java.net.ConnectException: Connection refused

Did someone already get through this one ?
Also I cannot find anything related with dynamic neighbors discovery
(neither in the source code, neither in the doc, neither in the conf-file),
is there any mechanism which take care of it ?

Configuration details
*root@pc-mna-78:~/BP-RI/classes# route -n*
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use
Iface
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0
wlan0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0
wlan0

*root@pc-mna-78:~/BP-RI/classes# ifconfig *
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4808 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4808 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1011705 (987.9 KiB)  TX bytes:1011705 (987.9 KiB)

wlan0     Link encap:Ethernet  HWaddr 0c:60:76:66:2d:64
          inet addr:192.168.0.78  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::e60:76ff:fe66:2d64/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11742 errors:0 dropped:0 overruns:0 frame:6484792
          TX packets:17905 errors:31 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:682229 (666.2 KiB)  TX bytes:10328677 (9.8 MiB)
          Interrupt:17

---

From: "Ivancic, William D. (GRC-RHN0)" <[email-masked]>
Date: Wed, 19 Mar 2014 13:32:56 +0000

I think that is really old.  It is based on the Internet Draft –04, not even RFC5050.

I suggest working with some newer code.  Look at the wiki.

http://www.dtnrg.org/wiki/Code

But even the wiki has a lot of dated material.

I will not endorse one implementation over another as I really haven't done much here lately.  I will say that I have a number of small business doing research for NASA that have gravitated to IBR-DTN.  You might want to try that one.  ION also has been well maintained to date. ION supports LTP.  I do not believe IBF-DTN does.  ION also supports IPN naming, Contract Graph Routing and CBHE (Compressed Bundle Header Encoding).  If you are looking at space applications and deterministic routing, ION may be a better choice.  If you are looking a opportunistic routing, IBR-DTN may be better.

Will

From: Maël Auzias <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 19, 2014 4:42 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [dtn-users] BP-RI implementation test

Hi everyone,

I'm testing the BP-RI<http://masaka.cs.ohiou.edu/ocp/bundling.html> implementation. Once I got it compiled without any error I try to run it as described in the README.

root@pc-mna-78:~/BP-RI/classes# java edu.ohiou.ocp.dtn.BPServer#more configuration details below
Off-World Communication Protocols Research Group BP-RI: 1.0
 Starting BP Server:v1.0...
BPServer failed to bind to //localhost/BPServer! - Connection refused to host: localhost; nested exception is:
    java.net.ConnectException: Connection refused

Did someone already get through this one ?
Also I cannot find anything related with dynamic neighbors discovery (neither in the source code, neither in the doc, neither in the conf-file), is there any mechanism which take care of it ?

Configuration details
root@pc-mna-78:~/BP-RI/classes# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 wlan0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0

root@pc-mna-78:~/BP-RI/classes# ifconfig

---

From: Maël Auzias <[email-masked]>
Date: Wed, 19 Mar 2014 14:50:03 +0100

Hello Will,

Thanks for the answer !
I saw that it's not based on the RFC and a bit old (2005 -according to the
website date-).
I tried IBR-DTN (which is great!) but for some reasons I wanted to try a
Java implementation.
Note also that the wiki references Java DTN (the last on the webpage) which
does not exist anymore and lead to DTN2.9.

I found out what was the problem. It might look like I'm answering myself
about the problem, but it could be useful if anyone crawl the mailing list
archive for the same problem, here is the solution:

The README file does not notice that rmiregistery should be running.
Well... It should be though.
In a terminal:
#export
CLASSPATH=$CLASSPATH:/absolute/path/to/BP-RI/PackageDeps/LTP-RI-1.2-runtime.jar:/absolute/path/to/BP-RI/PackageDeps/commons-validator-1.4.0.jar:/absolute/path/to/BP-RI/classes
#cd /absolute/path/to/BP-RI/classes
#rmiregistry

Then it should work.
I still have an issue though : I cannot write anything in the Eclipse and
if ever I launch it from the console the program stop as soon as the
program console is waiting.
Once I get through I'll send another mail to explain the process of getting
it working.

On Wed, Mar 19, 2014 at 2:32 PM, Ivancic, William D. (GRC-RHN0) <
[email-masked]> wrote:

>   I think that is really old.  It is based on the Internet Draft -04, not
> even RFC5050.
>
>  I will not endorse one implementation over another as I really haven't
> done much here lately.  I will say that I have a number of small business
> doing research for NASA that have gravitated to IBR-DTN.  You might want to
> try that one.  ION also has been well maintained to date. ION supports LTP.
>  I do not believe IBF-DTN does.  ION also supports IPN naming, Contract
> Graph Routing and CBHE (*Compressed Bundle Header Encoding).  If you are
> looking at space applications and deterministic routing, ION may be a
> better choice.  If you are looking a opportunistic routing, IBR-DTN may be
> better.  *
>
>  Will
>
>
>   From: Maël Auzias <[email-masked]>
> To: "[email-masked]" <[email-masked]>
>  I'm testing the BP-RI <http://masaka.cs.ohiou.edu/ocp/bundling.html>implementation. Once I got it compiled without any error I try to run it as
> described in the README.
>
> *root@pc-mna-78:~/BP-RI/classes# java edu.ohiou.ocp.dtn.BPServer*#more

---

From: Johannes Morgenroth <[email-masked]>
Date: Wed, 19 Mar 2014 14:56:46 +0100

Just to complete the specs...

Am 19.03.2014 14:32, schrieb Ivancic, William D. (GRC-RHN0):
> ION supports LTP.  I do not believe IBR-DTN does.

Thats right.

> ION also supports IPN naming, Contract Graph Routing and CBHE (/Compressed Bundle Header
> Encoding).  If you are looking at space applications and deterministic
> routing, ION may be a better choice.  If you are looking a opportunistic
> routing, IBR-DTN may be better.  /

IBR-DTN also supports IPN naming and CBHE. However, I agree with you
that ION might be better suited for space applications.

Regards,
Johannes

-- 
Johannes Morgenroth     Institut fuer Betriebssysteme und Rechnerverbund
Tel.: +49-531-391-3249                           Muehlenpfordtstrasse 23
Fax.: +49-531-391-5936      TU Braunschweig         D-38106 Braunschweig

---

From: Jayram Déshpandé <[email-masked]>
Date: Wed, 19 Mar 2014 12:35:49 -0700 (PDT)

Hello Maël ,

BP-RI implementation is based upon ID-04.  We wanted to provide a Java based option to run BP Over LTP.
It has not been kept up-to-date to reflect the latest RFC.  Dynamic neighbors discovery is not supported.

You are welcome to try it out but its not maintained currently to support feature requests/enhancements.  

Regards,
-Jay

--
GPG Key Fingerprint: 8FC7 1E39 5D45 FFB9 3161  79A0 FFDF 48DD FE67 F788

On Wednesday, March 19, 2014 1:42 AM, Maël Auzias <[email-masked]> wrote:
 
Hi everyone,

I'm testing the BP-RI implementation. Once I got it compiled without any error I try to run it as described in the README.

root@pc-mna-78:~/BP-RI/classes# java edu.ohiou.ocp.dtn.BPServer #more configuration details below

Configuration details

_______________________________________________
dtn-users mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/dtn-users

---

From: Jayram Déshpandé <[email-masked]>
Date: Wed, 19 Mar 2014 14:30:21 -0700 (PDT)

In addition,  You can find many more details about 
configuration and such in the Appendix section  (Starting page 99) from 
my thesis work here at [1]: 

Regards,
-Jay

[1]  http://rave.ohiolink.edu/etdc/view?acc_num=ohiou1163644692

On Wednesday, March 19, 2014 12:36 PM, Jayram Déshpandé <[email-masked]> wrote:
 
Hello Maël ,

Regards,
-Jay

 
Hi everyone,

Configuration details

---

From: "Burleigh, Scott C (312G)" <[email-masked]>
Date: Wed, 19 Mar 2014 23:50:05 +0000

One other note: if you're still looking for a good Java implementation you might want to check out JDTN: http://sourceforge.net/projects/jdtn/?source=directory.  Keith Scott has worked with this code a bit and speaks highly of it.

Scott

From: dtn-users [mailto:[email-masked]] On Behalf Of Maël Auzias
Sent: Wednesday, March 19, 2014 6:50 AM
To: Ivancic, William D. (GRC-RHN0)
Cc: [email-masked]
Subject: Re: [dtn-users] BP-RI implementation test

Hello Will,

Thanks for the answer !
I saw that it's not based on the RFC and a bit old (2005 -according to the website date-).
I tried IBR-DTN (which is great!) but for some reasons I wanted to try a Java implementation.
Note also that the wiki references Java DTN (the last on the webpage) which does not exist anymore and lead to DTN2.9.

I found out what was the problem. It might look like I'm answering myself about the problem, but it could be useful if anyone crawl the mailing list archive for the same problem, here is the solution:
The README file does not notice that rmiregistery should be running. Well... It should be though.
In a terminal:
#export CLASSPATH=$CLASSPATH:/absolute/path/to/BP-RI/PackageDeps/LTP-RI-1.2-runtime.jar:/absolute/path/to/BP-RI/PackageDeps/commons-validator-1.4.0.jar:/absolute/path/to/BP-RI/classes
#cd /absolute/path/to/BP-RI/classes
#rmiregistry
Then it should work.
I still have an issue though : I cannot write anything in the Eclipse and if ever I launch it from the console the program stop as soon as the program console is waiting.
Once I get through I'll send another mail to explain the process of getting it working.

On Wed, Mar 19, 2014 at 2:32 PM, Ivancic, William D. (GRC-RHN0) <[email-masked]<mailto:[email-masked]>> wrote:
I think that is really old.  It is based on the Internet Draft -04, not even RFC5050.

Will

Hi everyone,

Configuration details

---

From: "Jim Miner (jminer)" <[email-masked]>
Date: Thu, 20 Mar 2014 01:27:38 +0000

Hi folks,

With regard to the older, non-compliant Java implementation, you might be
thinking of the Ohio University Java implementation, which was not RFC
compliant and done in about the 2005 timeframe.  JDTN is distinct from the
Ohio University implementation.  JDTN is compliant with RFC 5050 and is a
bit more recent than 2005, the last work done on it was 2011.  It
implements RFC 5326 (LTP), as well as the TCP and UDP drafts for
adaptation layers.  It is interoperable with DTN2, and with ION, and has
provisions for dealing with ION bundle header compression.  It can serve
as a gateway between ground based DTN2 hosts and space based ION hosts.
It has a default bundle routing facility based on static routes, but
alternate routing implementations can be plugged in.  We did develop an
android application, but in the fast-paced world of android development it
might be considered a bit aged.  One proviso: it does not address Bundle
Security extensions.  One other qualification: all of these statements
were true in 2011, but I have not really kept up with DTN since then.

http://sourceforge.net/projects/jdtn/

Regards, Jim Miner
Cisco Systems, Inc.

On 3/19/14 7:50 PM, "Burleigh, Scott C (312G)"
<[email-masked]> wrote:

>One other note: if you¹re still looking for a good Java implementation
>you might want to check out JDTN:
>http://sourceforge.net/projects/jdtn/?source=directory.  Keith Scott has
>worked with this code a bit and speaks highly of it.
> 
>Scott
> 
>Note also that the wiki references Java DTN (the last on the webpage)
>which does not exist anymore and lead to DTN2.9.
>
> 
>
>about the problem, but it could be useful if anyone crawl the mailing
>list archive for
> the same problem, here is the solution:
>
>CLASSPATH=$CLASSPATH:/absolute/path/to/BP-RI/PackageDeps/LTP-RI-1.2-runtim
>e.jar:/absolute/path/to/BP-RI/PackageDeps/commons-validator-1.4.0.jar:/abs
>olute/path/to/BP-RI/classes
>
>On Wed, Mar 19, 2014 at 2:32 PM, Ivancic, William D. (GRC-RHN0)
><[email-masked]> wrote:
>I think that is really old.  It is based on the Internet Draft 04, not
>even RFC5050.
>
> 
>
>doing research for NASA that have gravitated
> to IBR-DTN.  You might want to try that one.  ION also has been well
>maintained to date. ION supports LTP.  I do not believe IBF-DTN does.
>ION also supports IPN naming, Contract Graph Routing and CBHE (Compressed
> Bundle Header Encoding).  If you are looking at space applications and
>deterministic routing, ION may be a better choice.  If you are looking a
>opportunistic routing, IBR-DTN may be better.
>
> 
>
>Will
>
> 
>
>
>
>
>
> 
>
>From:
>I'm testing the
>BP-RI <http://masaka.cs.ohiou.edu/ocp/bundling.html> implementation. Once
>I got it compiled without any error I try to run it as described in the
>README.
>
>
>(neither in the source code, neither in the doc, neither in the
>conf-file), is there any mechanism which
> take care of it ?
>
>Configuration details