Subject: [dtn-users] DTN Routing

From: Murugadoss <[email-masked]>
Date: Wed, 24 Sep 2014 16:28:47 +0900 (GMT)

Hello,
I am working on DTN Routing for my study. I am using DTN2 code to test DTN routing algorithms. I want to test a scenario of "Loop Back". The system setup is like, I have 2 Nodes (A &amp; B), I want to send and receive a packet in A routed Via B. Currently I am using Static route type in the configuration file and link and route as,
 
Node A : (dtn://ubuntu10.dtn)
route set type static
link add link_dtn1 &lt;IP_Addrs&gt; ONDEMAND tcp
route add dtn://ubuntu1210.dtn/* link_dtn1

Node B:(dtn://ubuntu1210.dtn)
link add link_dtn2 &lt;IP_Addrs&gt; ONDEMAND tcp
route add dtn://ubuntu10.dtn/* link_dtn2
 
Send Message using.,
./dtnsend -s dtn://ubuntu10.dtn/a  -d dtn://ubuntu10.dtn/b  -t m -p "message loop"
 
My packet is held at B, it not routed back to Node A. 
 
Can any one please help me ?
 
Thank you

Thanks &amp; Regards
Murugadoss

---

From: Gerardo Izquierdo <[email-masked]>
Date: Wed, 24 Sep 2014 14:59:11 +0200

Could it be a "split-horizon" issue?, not sending information trought the
same interface we have received it?
if so, if you can establish a third point you can test it via A => B => C
=> A.

Regards.
Gerardo.

P.S. Sorry by my poor English.

2014-09-24 9:28 GMT+02:00 Murugadoss <[email-masked]>:

> Hello,
>
> I am working on DTN Routing for my study. I am using DTN2 code to test DTN
> routing algorithms. I want to test a scenario of "Loop Back". The system
> setup is like, I have 2 Nodes (A & B), I want to send and receive a packet
> in A routed Via B. Currently I am using Static route type in the
> configuration file and link and route as,
>
>
>
> link add link_dtn1 <IP_Addrs> ONDEMAND tcp
>
> link add link_dtn2 <IP_Addrs> ONDEMAND tcp
>
> Thanks & Regards
> _______________________________________________
> dtn-users mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/dtn-users
>
>

---

From: Murugadoss <[email-masked]>
Date: Fri, 26 Sep 2014 17:45:01 +0900 (GMT)

Thanks for your reply. 
My intention of the test is to understand the reverse path (eg: A =&gt; B =&gt; A =&gt; D =&gt; A). 
 
I addition, I got stuck with the test setup of kind  A =&gt; B =&gt; C =&gt; D, when configuring the link and route in configuration life.
 
Config File: 
link add link1 &lt; SysB_ip&gt;  [opts]
route add &lt;Des_eid&gt; link1
 
My question is, the &lt;Dest_eid&gt; should be the EID of  D or C ?
Is there an option to specify multiple-hop link at Source Config file ??
 
Thanks
Murugadoss

----- Original Message -----
From: Gerardo Izquierdo &lt;[email-masked]&gt;
To: [email-masked]
Date: Wed, 24 Sep 2014 21:59:11 +0900 (GMT)
subject: Re: [dtn-users] DTN Routing

Could it be a "split-horizon" issue?, not sending information trought the same interface we have received it? 
if so, if you can establish a third point you can test it via A =&gt; B =&gt; C =&gt; A. 

Regards. 
Gerardo. 

2014-09-24 9:28 GMT+02:00 Murugadoss &lt;[email-masked]&gt;: 

Hello,

 
Send Message using.,

 
Thank you

Thanks &amp; Regards 
Murugadoss

---

From: "Zoller, David A. (MSFC-EO50)[HOSC SERVICES CONTRACT]" <[email-masked]>
Date: Fri, 26 Sep 2014 12:49:54 +0000

Hi Murugadoss,
I ran a test this morning and confirmed your initial results that the bundles get stuck in node B. In TableBasedRouter::should_fwd, there is a check to prevent sending the bundle back to its previous hop. You would have to remove that check to force a loopback which will probably result in a continuous loop rather than just a loopback.

My intention of the test is to understand the reverse path (eg: A => B => A => D => A).
You would probably have to add special routing code if you want A to send the bundle to B the first time through and then D the second time through.

I addition, I got stuck with the test setup of kind  A => B => C => D, when configuring the link and route in configuration life.

To send a bundle from A to D, A needs to be configured to send any bundle with a destination of D to B. A does not even need to “know” that C exists. B would need to be configured to send it to C and then C would need to be configured to send it D. This would set up a one-way path from A to D:
Config file for A:
     link add link_to_B <SysB_ip> [opts]
     route add D/* link_to_B

Config file for B:
     link add link_to_C <SysC_ip> [opts]
     route add D/* link_to_C

Config file for C:
     link add link_to_D <SysD_ip> [opts]
     route add D/* link_to_D

I hope this helps,
DZ

From: dtn-users [mailto:[email-masked]] On Behalf Of Murugadoss
Sent: Friday, September 26, 2014 3:45 AM
To: [email-masked]
Subject: Re: [dtn-users] DTN Routing

Thanks for your reply.

My intention of the test is to understand the reverse path (eg: A => B => A => D => A).

I addition, I got stuck with the test setup of kind  A => B => C => D, when configuring the link and route in configuration life.

Config File:

link add link1 < SysB_ip>  [opts]

route add <Des_eid> link1

My question is, the <Dest_eid> should be the EID of  D or C ?

Thanks

Murugadoss

----- Original Message -----
From: Gerardo Izquierdo <[email-masked]<mailto:[email-masked]>>
To: [email-masked]<mailto:[email-masked]>
Date: Wed, 24 Sep 2014 21:59:11 +0900 (GMT)
subject: Re: [dtn-users] DTN Routing

Could it be a "split-horizon" issue?, not sending information trought the same interface we have received it?
if so, if you can establish a third point you can test it via A => B => C => A.

Regards.
Gerardo.

2014-09-24 9:28 GMT+02:00 Murugadoss <[email-masked]<mailto:[email-masked]>>:

Hello,

I am working on DTN Routing for my study. I am using DTN2 code to test DTN routing algorithms. I want to test a scenario of "Loop Back". The system setup is like, I have 2 Nodes (A & B), I want to send and receive a packet in A routed Via B. Currently I am using Static route type in the configuration file and link and route as,

route set type static

Send Message using.,

Thank you

Thanks & Regards
Murugadoss

_______________________________________________
dtn-users mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/dtn-users

[http://mail.hanyang.ac.kr:80/historySent.ds?act=confirm&sender=bXVydWdhZG9zc0BoYW55YW5nLmFjLmty&receiver=ZHRuLXVzZXJzQGlydGYub3Jn&subject=UmU6UmU6IFtkdG4tdXNlcnNdIERUTiBSb3V0aW5n&msgid=NjA2MzI5NTk1OTg4NTk1NDA1Nw%3d%3d]