Subject: [dtn-users] DTN2 compilation problems on Arch Linux Raspberry Pi

From: Nik Ansell <[email-masked]>
Date: Sun, 29 Nov 2015 16:55:50 +0400

Hi,

I am conducting a research project to compare the energy consumption and
delivery profiles of ION, DTN2 and IBR-DTN.

Having successfully setup ION, I am now trying to compile oasys on Arch
Linux using a Raspberry Pi 2 B.
I have run build_configure.sh, which seemed to run OK after I installed
autoconf and applied the tclv8.6 fix.

However, when I run ./configure it fails as follows:
checking for the version of the GNU C compiler... 5.2
checking for the version of the GNU C++ compiler... 5.2
error: unsupported compiler version 5.2

Does anyone know if this is a simple fix?
Can I edit a file somewhere to look for 5.2?

Any help would be really appreciated, thanks!

Kind Regards,
Nik

---

From: Nik Ansell <[email-masked]>
Date: Tue, 1 Dec 2015 00:13:07 +0400

Managed to figure this one out, just add |5.* to the following files:

oasys-1.6.0/aclocal.m4
line 881:   3.*|4.*|5.*)

oasys-1.6.0/aclocal/gcc.ac
line 120:   3.*|4.*|5.*)

oasys-1.6.0/configure
line 8166: 3.*|4.*|5.*)

dtn-2.9.0/aclocal.m4
line 1335:  3.*|4.*|5.*)

dtn-2.9.0/configure
line 6243:  3.*|4.*|5.*)

It seemed to compile OK and dtnd started OK too.

Kind Regards,
Nik