Subject: [dtn] conf call to discuss charter

From: Marc Blanchet <[email-masked]>
Date: Tue, 23 Sep 2014 11:30:39 -0400

Hello,
 Fred and I would like to move forward with the charter discussion. We think that having a conf call soon will help to converge.  Obviously, no single time fits everywhere, everybody, and this one is a compromise. 
Therefore, you are all invited to attend the conf call on:
 
 tuesday 30th 10h00 Eastern conf call for 90 minutes.  

The agenda of the call is to discuss the charter.  Details of the webex info will be sent in a separate email.

Regards, Marc&Fred

---

From: "Birrane, Edward J." <[email-masked]>
Date: Tue, 30 Sep 2014 15:53:14 +0000

Hello,

  Below are the notes taken from the conference call today.  These notes are also attached to this e-mail as a PDF document.

-Ed

DTN Charter Conference Call
9/30/2014, 10:00 - 11:00 US Eastern Time

Summary:
Marc Blanchet (MB) led the conference call, which was attended by approximately 20 callers. Amongst the conference call attendees, a consensus was reached on a DTN WG charter that specifies a revision to the existing RFC5050 specification and security protocol in the context of a document to capture driving problem statements, protocol requirements, lessons learned, and rationale for items in a work plan.

Discussion Notes:
Stephen Farrell (SF) withdrew proposal for a different WG charter that sought better alignment with existing Internet technologies to ease adoption of DTN on the Internet. 
o	SF noted that some people liked the idea, but no support emerged to work on the concepts.  Will Ivancic (WI) expressed support for the concept. Kevin Fall (KF) liked the idea, but recommended that the work be undertaken in the IRTF group, where he may be able to support it. Elwyn Davies (ED) also supported the concept and may have time to work on it, though his plate is very full.
o	KF asked how we assess that the proposal is better or "far more likely to be deployed" than what we have, as proposing this implies a concern that the existing work is not useable enough. SF responded that it was a fair question, and not necessary to answer since the proposal is withdrawn. Over decades things like CDNs exist where they did not before, the world has changed, and there is a concern that RFC5050 will not be widely deployed.
o	ED mentioned a desire to see the block structure revisited as there is no easy way of ensuring a received bundle has the same blocks at the destination as at the source.
o	SF suggested that in the context of the teleconference, his proposal should be withdrawn to go forward with a modest change to RFC5050.

MB proposed working on the problem statement and then moving on to the work items we want to work on, with some blessing from the IESG so they are not worried about us going everywhere.
o	John Dowdell (JD) noted that goals should be set on 12 month timescales, specifically noting getting RFC5050 and security "ready for prime time". 

MB started discussion on the first charter work item.
o	WI proposed that a lessons learned be added to the first charter work item. General agreement that this would be very useful. 
o	KF asked if the charter intends to keep compatibility over non-IP networks. General consensus that keeping this compatibility is important. WI mentioned that items such as neighbor discovery will become problematic in mixed networks.  
o	Agreed first charter item will cover lessons learned, keep non-IP network transport, and consider items such as neighbor discovery. KF noted that he had several editorial comments on the charter which could be discussed later.
o	WI expressed support for focusing on problem statement and use cases before doing revisions to RFC5050. SB agreed that this approach was captured in the charter.
o	KF mentioned that this effort should be a cut through the existing previous work to ensure it is OK in an Internet setting while preserving ability to work in non-Internet environments. So should be the minimal structure set of BP, convergence layer protocols, and identification of goals and priorities of original architecture and setting.
o	Some discussion on what to name the problem statement document. Fred Templin (FT) confirmed that problem statement, use cases, requirements are not starting from scratch.
o	KF noted that changes are driven by something, and the WG should consider what that something is when deciding on what to change. Change drivers may be deployment experience or extra thinking on the problem. Some problems discussed to date stem from artifacts of implementation or the overall applicability of the design to the environment. Recommended a work plan. MB noted that work plans should be administrative documents as the work done is informed by the IESG. SB recommended instead of work plan we capture these items as a development strategy. 
o	KF recommended removing or clarifying requirements. Agreement to keep the word requirements and clarify it to mean technical requirements on the protocol.
o	General agreement to remove the "out of scope" section of the charter. MB noted that some items lilsted as out-of-scope may be part of a recharter. MB noted that IESG oversees rechartering and rescoping so there already exists a gate for adding new work. WI was fine with removing out-of-scope text as long as features necessary for deployment are addressed in the problem statement/requirements/lessons learned document.

MB queried conference and based on responses declared a consensus for the charter amongst members on the call.  Next steps will be to send the charter to the mailing list where, barring significant negative feedback, it is likely there will be consensus.
o	SB noted that if the IESG approves the charter, the WG is, by definition, the set of people willing to abide by the charter.  MB agreed so long as the consensus is sufficient to accomplish the work. 
o	MB noted that there is an RFC describing how to hold a BOF and what questions should be asked and answered and that the prior IETF DTN BOF accomplished those items. With an agreed-upon charter the IESG should be able to proceed. 
o	MB noted that a new BOF may be scheduled for the next IETF unless the DTN WG is approved prior, in which case the BOF could become the first WG meeting.

-Ed

---
Ed Birrane
Principal Professional Staff, Space Exploration Sector
Johns Hopkins Applied Physics Laboratory
(W) 443-778-7423 / (F) 443-228-3839

> -----Original Message-----
> From: dtn [mailto:[email-masked]] On Behalf Of Marc Blanchet
> Sent: Tuesday, September 23, 2014 11:31 AM
> To: [email-masked]
> Subject: [dtn] conf call to discuss charter
> 
> Hello,
>  Fred and I would like to move forward with the charter discussion. We think
> that having a conf call soon will help to converge.  Obviously, no single time
> fits everywhere, everybody, and this one is a compromise.
> _______________________________________________
> dtn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dtn