Subject: [dtn] DTN routing

From: SHiVi SHuKLa <[email-masked]>
Date: Mon, 16 Feb 2015 21:57:26 +0530

Hello....
In dtn.. how a node come to know about the other node... how nodes know
about the neighbors and after identification say 5 nodes are in neighbor
then how the forwarding is done... is it broadcasting or one to one... and
if one to one... then is it queued???

Shivi Shukla.

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Wed, 18 Feb 2015 01:30:53 +0000

Hi, Shivi.  I would say we are still pretty far from having a comprehensive answer to this question.  For small networks, awareness of the other nodes in the network can be conveyed by configuration management.  For ad hoc networks, node discovery protocols do at least part of the job, and bundle multicasting may do much of the rest.  Ultimately I think there will be a need for a confederated node registration structure that propagates this sort of information, but I don't know of any work along this line that has been done yet.

Scott

From: dtn [mailto:[email-masked]] On Behalf Of SHiVi SHuKLa
Sent: Monday, February 16, 2015 8:27 AM
To: [email-masked]
Subject: [dtn] DTN routing

Hello....
In dtn.. how a node come to know about the other node... how nodes know about the neighbors and after identification say 5 nodes are in neighbor then how the forwarding is done... is it broadcasting or one to one... and if one to one... then is it queued???

Shivi Shukla.