Subject: Re: [dtn] DTN use case update

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 11 Feb 2015 22:13:14 +0000

Hi, I updated the DTN use cases as follows:

- added GEO and LEO satellite use cases
- reworded civil aviation use case to clarify aspects that do not
  require DTN.

Please review and comment:

http://trac.tools.ietf.org/wg/dtn/trac/wiki/WikiStart#

Thanks - Fred
[email-masked]

---

From: Gelard Patrick <[email-masked]>
Date: Thu, 12 Feb 2015 08:27:10 +0000

Hello, 

An extension of theses uses cases to the small, low-cost satellites LEO constellation (Like OneWeb project or SpaceX project with 4000 microsatellite), Flotille of balloon (like Google Loon project),  would It be relevant ? 

And in the context of IoT/M2M for Smart Industry (Smart Product Management, Animal Tracking, ...), Smart Environment Monitoring (Forest Fire Detection, Air Pollution, Landslide and Avalanche Prevention, Earthquake detection, Protecting wildlife, Meteorological Station Network, Marine and Coastal Surveillance,  Water Management, ...), in additional to Smart Transport (VDTN) ?

Best Regard
Patrick

-----Message d'origine-----
De : dtn [mailto:[email-masked]] De la part de Templin, Fred L
Envoyé : mercredi 11 février 2015 23:13
À : [email-masked]
Objet : Re: [dtn] DTN use case update

Thanks - Fred

_______________________________________________
dtn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtn

---

From: Kiyohisa Suzuki <[email-masked]>
Date: Thu, 12 Feb 2015 17:59:23 +0900

Hello,

It may overlap for LEO/GEO case,

DTE(Direct To Earth) satellite communications at high frequency for 
frequent disruptions caused by cloud and rain attenuation.

Best Regards,
Kiyo

---

From: <[email-masked]>
Date: Thu, 12 Feb 2015 09:15:04 +0000

Dear All,

In the same context of GEO, there is an interesting use-case for ultra-high throughput satellite systems where satellite gateways may suffer from link outage (in case of EHF frequency bands/optical feeder link) and data have to be stored and/or opportunistically forwarded/distributed to more favorable gateways.

Best Regards,

Tomaso

------------------------ 
Deutsches Zentrum für Luft- und Raumfahrt (DLR) 
German Aerospace Center 
Institute of Communications and Navigation | Satellite Networks | Oberpfaffenhofen | 82234 Wessling | Germany 
Tomaso de Cola, Ph.D. 
Telefon +49 8153 28-2156 | Telefax  +49 8153 28-2844 | [email-masked] 
http://www.dlr.de/kn/institut/abteilungen/san 

> -----Original Message-----
> From: dtn [mailto:[email-masked]] On Behalf Of Kiyohisa Suzuki
> Sent: Thursday, February 12, 2015 09:59
> To: [email-masked]
> Subject: Re: [dtn] DTN use case update
> 
> Hello,
> 
> DTE(Direct To Earth) satellite communications at high frequency for frequent
> disruptions caused by cloud and rain attenuation.
> 
> Best Regards,
> Kiyo
>

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 12 Feb 2015 18:46:36 +0000

Hi Patrick,

> From: dtn [mailto:[email-masked]] On Behalf Of Gelard Patrick
> Sent: Thursday, February 12, 2015 12:27 AM
> To: Templin, Fred L; [email-masked]
> An extension of theses uses cases to the small, low-cost satellites LEO constellation (Like OneWeb project or SpaceX project with 4000
> microsatellite), Flotille of balloon (like Google Loon project),  would It be relevant ?

I think these could certainly be added as examples.

> And in the context of IoT/M2M for Smart Industry (Smart Product Management, Animal Tracking, ...), Smart Environment Monitoring
> (Forest Fire Detection, Air Pollution, Landslide and Avalanche Prevention, Earthquake detection, Protecting wildlife, Meteorological
> Station Network, Marine and Coastal Surveillance,  Water Management, ...), in additional to Smart Transport (VDTN) ?

Could you suggest a few bullets? I think they could go under a slightly
reworded category of "Terrestrial/Vehicular Delay Tolerant Networks"?

Thanks - Fred

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 12 Feb 2015 18:53:25 +0000

Hi Kiyo,

A singleton satellite with disruption due to atmospheric conditions would
certainly be in scope. I will add a few words to the wiki.

Thanks - Fred

> Sent: Thursday, February 12, 2015 12:59 AM
> To: [email-masked]

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 12 Feb 2015 18:55:18 +0000

Do you envision a constellation of satellites that might forward to one another
in the event that some satellites have good links while others have disrupted
links? If so, would that require delay tolerant facilities, or is it more of a (near)
real time routing problem? Asked another way, for how long of a delay could
data be ping-ponged between satellites until one with a good downlink is visited?

Thanks - Fred
[email-masked]

> From: dtn [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: Thursday, February 12, 2015 1:15 AM
> To: [email-masked]
> In the same context of GEO, there is an interesting use-case for ultra-high throughput satellite systems where satellite gateways may
> suffer from link outage (in case of EHF frequency bands/optical feeder link) and data have to be stored and/or opportunistically
> forwarded/distributed to more favorable gateways.
> 
> Best Regards,
> 
> Tomaso
> 
> ------------------------

---

From: Abhishek Thakur <[email-masked]>
Date: Fri, 13 Feb 2015 11:59:19 +0530

Our team (www.SWiFiIC.in <http://www.swifiic.in/>) is looking at Deploying
DTN platform for non-real-time communication in rural scenarios. This is
primarily for communication within the village and may have gateways to
reach public Internet. While "Disaster Response and Humanitarian Aid" has
similarities, that use case is not having all the aspects for a long
running self sustainable DTN system. Some of the things we are looking at
are a) simplified management; b) revenue generation for self sustenance; c)
work primarily on commodity hardware (affordable WiFi handheld devices
etc.).

Can we add a scenario for "Communication within the community"? While it
may look experimental in western perspective, we believe that in rural
areas of developing countries we can have more opportunities if the
platform is easily extensible for variety of apps and affordable for the
community.

Warm regards
Abhishek Thakur
<http://www.bits-pilani.ac.in/hyderabad/abhishekthakur/Profile>

On Fri, Feb 13, 2015 at 12:25 AM, Templin, Fred L <[email-masked]
> wrote:

> > In the same context of GEO, there is an interesting use-case for
> ultra-high throughput satellite systems where satellite gateways may
> > suffer from link outage (in case of EHF frequency bands/optical feeder
> link) and data have to be stored and/or opportunistically
> > Institute of Communications and Navigation | Satellite Networks |
> Oberpfaffenhofen | 82234 Wessling | Germany
> > Tomaso de Cola, Ph.D.
> frequent

---

From: Gelard Patrick <[email-masked]>
Date: Fri, 13 Feb 2015 07:57:24 +0000

>> Could you suggest a few bullets? I think they could go under a slightly reworded category of "Terrestrial/Vehicular Delay Tolerant Networks"?
There are different kind of IoT application ( http://iotcomicbook.org/special-edition/ ) for various  industry like  Smart  City,  Smart  Grid,  Smart  Water,  Smart Transportation, Smart Health,  etc. 

Each application class has its own requirements that can be grouped by factors such as :

	- Range : location (e.g. indoor, outdoor), coverage, distribution, density, degree of mobility: stationary, nomadic or continuously moving.
	- Bandwidth : bit rate, data volume, transmission duty cycle, software update requirements
	- QoS : security, criticality, sensitivity to delay or error, accessibility
	- Management : Energy/ power requirements, Setting in a stand-by mode, operation life,  
	- ....

Here there are some use case collection  http://www.onem2m.org/images/files/deliverables/oneM2M-TR-0001-UseCase-V0_0_5.doc

For example only in Intelligent transportation systems (ITS) applications  ( http://en.wikipedia.org/wiki/Intelligent_transportation_system ) there are different kind of use case  and communication service such as Vehicle to infrastructure, Vehicle to Vehicle.  The connection of vehicles to the Internet gives rise to a wealth of new possibilities and applications which bring new functionalities to the individuals and/or the making of transport easier and safer. In this context the concept of Internet of Vehicles (IoV) connected with the concept of Internet of Energy (IoE) represent future trends for smart transportation and mobility applications.

Thus, It is difficult to translate it in DTN requirement. This requires spending more time on it.

Patrick

-----Message d'origine-----
De : Templin, Fred L [mailto:[email-masked]] 
Envoyé : jeudi 12 février 2015 19:47
À : Gelard Patrick; [email-masked]
Objet : RE: [dtn] DTN use case update

Hi Patrick,

> An extension of theses uses cases to the small, low-cost satellites 
> LEO constellation (Like OneWeb project or SpaceX project with 4000 microsatellite), Flotille of balloon (like Google Loon project),  would It be relevant ?

> And in the context of IoT/M2M for Smart Industry (Smart Product 
> Management, Animal Tracking, ...), Smart Environment Monitoring 
> (Forest Fire Detection, Air Pollution, Landslide and Avalanche Prevention, Earthquake detection, Protecting wildlife, Meteorological Station Network, Marine and Coastal Surveillance,  Water Management, ...), in additional to Smart Transport (VDTN) ?

Could you suggest a few bullets? I think they could go under a slightly reworded category of "Terrestrial/Vehicular Delay Tolerant Networks"?

Thanks - Fred

> Envoyé : mercredi 11 février 2015 23:13 À : [email-masked] Objet : Re: 
> [dtn] DTN use case update
>

---

From: <[email-masked]>
Date: Wed, 18 Feb 2015 08:12:01 +0000

Hi Fred,

What I was envisioning is more about the exploitation of DTN features on the terrestrial subnetwork to cope with the intermittency of the gateways' feeder links. The scenario considers a GEO satellite that can be accessed by multiple gateways covering different geographical areas. Gateways can be interconnected by a dedicated backbone or reachable by "upstream" routers. In case one gateways goes off because of the aforementioned outage problems, an alternative gateway (or more than one, to achieve some load sharing) has to be selected and typical DTN store-forward features should be taken advantage of. Obviously, the applicability of DTN should be extended also to the space segment for additional optimization purposes. 

In any case, I think this scenario can be seen as extension or generalization of the GEO scenario already provided in the charter:

GEO satellite communications for long-delay; frequent disruptions (replaces traditional Peformance Enhancing Proxies (PEPs))

Perhaps the title could be slightly reworded in: High throughput GEO Satellite networks [...] 

Best Regards,

Tomaso
------------------------ 

> From: Templin, Fred L [mailto:[email-masked]]
> Sent: Thursday, February 12, 2015 19:55
> To: Cola, Tomaso de; [email-masked]
> Subject: RE: [dtn] DTN use case update
> 
> > suffer from link outage (in case of EHF frequency bands/optical feeder link)
> and data have to be stored and/or opportunistically forwarded/distributed to
> more favorable gateways.
> >
> > Best Regards,
> >
> > Tomaso
> >
> > ------------------------
> > Deutsches Zentrum für Luft- und Raumfahrt (DLR) German Aerospace
> > Center Institute of Communications and Navigation | Satellite Networks
> > | Oberpfaffenhofen | 82234 Wessling | Germany Tomaso de Cola, Ph.D.
> > Telefon +49 8153 28-2156 | Telefax  +49 8153 28-2844 |
> > [email-masked] http://www.dlr.de/kn/institut/abteilungen/san
> >