Subject: Re: [dtn] New Version Notification for draft-ietf-dtn-tcpclv4-08.txt

From: Brian Sipos <[email-masked]>
Date: Tue, 22 May 2018 01:46:23 +0000

All,

This draft is not complete, but after a long delay I wanted to get out an intermediate update from last feedback that contains a number of changes to the spec and the protocol:

  *   The contact negotiation is split into two phases (and the contact header is split into two) to make the contact header short and fixed-size, and to avoid the possibility of a trivial implementation to leak data over insecure channel. It's the same parameters in the same encoding, just all moved into post-TLS messaging. This still doesn't change the establishment high-level workflow, it just makes things simpler to reason about and provides more security guarantees.
  *   Added new Transfer Extension Items alongside earlier Session Extension Items, but no item types planned to be defined.
  *   Some nomenclature changes related to renaming "shutdown" to "terminate" regarding the TCPCL session.

New terminology is added to the front sections to attempt to distinguish some nuance about roles and directionality. A state machine describing the protocol is forthcoming but not yet in this draft. That should not change the workflow or messaging but should make it easier to understand the protocol, sequencing, and expected transitions.

________________________________
From: [email-masked] <[email-masked]>
Sent: Monday, May 21, 2018 21:39
To: Joerg Ott; Michael Demmer; Simon Perreault; [email-masked]; Brian Sipos; Brian Sipos
Subject: New Version Notification for draft-ietf-dtn-tcpclv4-08.txt

A new version of I-D, draft-ietf-dtn-tcpclv4-08.txt
has been successfully submitted by Brian Sipos and posted to the
IETF repository.

Name:           draft-ietf-dtn-tcpclv4
Revision:       08
Title:          Delay-Tolerant Networking TCP Convergence Layer Protocol Version 4
Document date:  2018-05-20
Group:          dtn
Pages:          46
URL:            https://www.ietf.org/internet-drafts/draft-ietf-dtn-tcpclv4-08.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-dtn-tcpclv4/
Htmlized:       https://tools.ietf.org/html/draft-ietf-dtn-tcpclv4-08
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-dtn-tcpclv4
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-dtn-tcpclv4-08

Abstract:
   This document describes a revised protocol for the TCP-based
   convergence layer (TCPCL) for Delay-Tolerant Networking (DTN).  The
   protocol revision is based on implementation issues in the original
   TCPCL Version 3 and updates to the Bundle Protocol contents,
   encodings, and convergence layer requirements in Bundle Protocol
   Version 7.  Specifically, the TCPCLv4 uses CBOR-encoded BPv7 bundles
   as its service data unit being transported and provides a reliable
   transport of such bundles.  Several new IANA registries are defined
   for TCPCLv4 which define some behaviors inherited from TCPCLv3 but
   with updated encodings and/or semantics.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Sheehe, Charles J. (GRC-LCA0)" <[email-masked]>
Date: Tue, 22 May 2018 11:34:20 +0000

Hi
I do not often comment.
The issue of selecting a proper CRC has multiple issues that should be considered prior to selection.

#1 message length: Min, Max, standard
#2 computational load
#3 collision resistance required

Thanks
Chuck 

Charles J. Sheehe III
Computer Engineer
Glenn Research Center
21000 Brookpark Rd
Cleveland, OH 44135
[email-masked]
Office: 216-433-5179

"Science is the belief in the ignorance of the experts" - Richard Feynman

"The purpose of life is to discover your gift; the work of life is to develop it; and the meaning of life is to give your gift away." - David Viscott

I wish you happiness and all the causes of happiness. 

The best you can do is be quiet in the face of the terrible contradictions, and try to figure out what the next right thing is.

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Brian Sipos
Sent: Monday, May 21, 2018 9:46 PM
To: [email-masked]
Subject: Re: [dtn] New Version Notification for draft-ietf-dtn-tcpclv4-08.txt

All,

	

A new version of I-D, draft-ietf-dtn-tcpclv4-08.txt has been successfully submitted by Brian Sipos and posted to the IETF repository.

Name:           draft-ietf-dtn-tcpclv4
Revision:       08
Title:          Delay-Tolerant Networking TCP Convergence Layer Protocol Version 4
Document date:  2018-05-20
Group:          dtn
Pages:          46
URL:            https://www.ietf.org/internet-drafts/draft-ietf-dtn-tcpclv4-08.txt <https://www.ietf.org/internet-drafts/draft-ietf-dtn-tcpclv4-08.txt> 
Status:         https://datatracker.ietf.org/doc/draft-ietf-dtn-tcpclv4/ <https://datatracker.ietf.org/doc/draft-ietf-dtn-tcpclv4/> 
Htmlized:       https://tools.ietf.org/html/draft-ietf-dtn-tcpclv4-08 <https://tools.ietf..org/html/draft-ietf-dtn-tcpclv4-08> 
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-dtn-tcpclv4 <https://datatracker.ietf.org/doc/html/draft-ietf-dtn-tcpclv4> 
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-dtn-tcpclv4-08 <https://www.ietf.org/rfcdiff?url2=draft-ietf-dtn-tcpclv4-08> 

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat