Subject: [dtn] WG Adoption of STCP

From: Rick Taylor <[email-masked]>
Date: Thu, 8 Nov 2018 03:18:52 +0000

Hi All,

As discussed in the WG session today, the room roughly agreed on the
adoption of Scott's STCP, possibly with a rename.

This is the formal notification to the list that adoption is being
considered.  Please respond with any comments by 12th November. 
Silence will be taken as assent.

Cheers,

Rick

---

From: "Marc Blanchet" <[email-masked]>
Date: Thu, 08 Nov 2018 10:20:31 +0700

to make sure this is unambiguous, the draft in question is: 
draft-burleigh-dtn-stcp

Marc.

On 8 Nov 2018, at 10:18, Rick Taylor wrote:

> _______________________________________________
> dtn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dtn

---

From: "Dr. Ronny L. Bull" <[email-masked]>
Date: Wed, 7 Nov 2018 23:15:27 -0500

I will repeat what I stated in the jabber channel during the working group
meeting:

It would be nice to have a STCP CL protocol that could be used for rapid
development on research projects and proof of concept work that could be
developed further using a full blown TCP CL implementation later.

Ronny

---

From: Lloyd Wood <[email-masked]>
Date: Thu, 8 Nov 2018 04:31:26 +0000 (UTC)

"It would be nice to have a STCP CL protocol that could be used
for rapid development on research projects and proof of concept
work that could be developed further using a full blown TCP CL
implementation later."

Well, there's always 
https://tools.ietf.org/html/rfc7242which was used for rapid development on research projects.
For about a decade.

The whole point of bundling over TCP is rapid development -
don't worry about convergence layers or fragmentation or
custody transfer, just leverage TCP's reliable bytestream paradigm.
Ignore the actual delay-tolerant problems or routing
problems, implement sending bundles to a TCP socket interface
that will rely on existing IP routing for delivery,

declare victory.

Lloyd Wood [email-masked] http://about.me/lloydwood

________________________________
From: Dr. Ronny L. Bull <[email-masked]>
To: [email-masked] 
Sent: Thursday, 8 November 2018, 15:15
Subject: Re: [dtn] WG Adoption of STCP

I will repeat what I stated in the jabber channel during the working group meeting:

It would be nice to have a STCP CL protocol that could be used for rapid development on research projects and proof of concept work that could be developed further using a full blown TCP CL implementation later.

Ronny

On Wed, Nov 7, 2018 at 10:20 PM Marc Blanchet <[email-masked]> wrote:

---

From: Rick Taylor <[email-masked]>
Date: Thu, 8 Nov 2018 05:01:08 +0000

Lloyd,

RFC7242 is TCP-CLv3, which is being updated to TCP-CLv4.  STCP is being
proposed as a minimal alternative to TCP-CL.

Cheers,

Rick 

On Thu, 2018-11-08 at 04:31 +0000, Lloyd Wood wrote:
> It would be nice to have a STCP CL protocol that could be used for
> rapid development on research projects and proof of concept work that
> could be developed further using a full blown TCP CL implementation
> later.
> 
> Ronny
> 
>

---

From: Lloyd Wood <[email-masked]>
Date: Thu, 8 Nov 2018 05:17:49 +0000 (UTC)

Rick

the v3/v4 differences do not matter for research
prototyping purposes.

(My assumption here is that 'how to carry stuff over
TCP' is not research; just enables research elsewhere.)

________________________________
From: Rick Taylor <[email-masked]>
To: "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]>; "[email-masked]" <[email-masked]> 
Sent: Thursday, 8 November 2018, 16:01
Subject: Re: [dtn] WG Adoption of STCP

Lloyd,

Cheers,

Rick

---

From: Rick Taylor <[email-masked]>
Date: Thu, 8 Nov 2018 06:46:22 +0000

Hi Lloyd,

The v3/v4 distinction was for the benefit of other readers.

A TCP-CL has applicability beyond research and experimentation.  There
is a need to move bundles via traditional fixed-line networks, such as
from ground-station to terrestrial endpoint for example.  Not all of
the end-to-end path of a DTN bundle needs to be via delayed or
disrupted links, and TCP-CL avoids the needs to add proxies to the path
that de-bundle prior to delivery to the payload destination.

I do however take your point that bundling over TCP only from end-to-
end has few use-cases beyond interoperability testing and research.

Cheers,

Rick

On Thu, 2018-11-08 at 05:17 +0000, Lloyd Wood wrote:
> To: "[email-masked]" <[email-masked]>; "
> [email-masked]" <[email-masked]>; "[email-masked]" <
> [email-masked]> 
> > I will repeat what I stated in the jabber channel during the
> > working
> > group meeting:
> > 
> > > > As discussed in the WG session today, the room roughly agreed
> > > > on
> > > > the

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Thu, 8 Nov 2018 16:51:04 +0000

I support adoption.

> -----Original Message-----
> From: dtn [mailto:[email-masked]] On Behalf Of Marc Blanchet
> Sent: Wednesday, November 07, 2018 7:21 PM
> To: [email-masked]

---

From: Carlo Caini <[email-masked]>
Date: Fri, 9 Nov 2018 16:17:33 +0000

I will support the adoption.
Yours,
      Carlo Caini