Subject: [dtn] New Custom vCORE VirtualBox Appliance With EMANE, Quagga OSPF-MANET, & NASA ION-DTN

From: "Dr. Ronny L. Bull" <[email-masked]>
Date: Tue, 15 Jan 2019 14:51:44 -0500

I have put together a fully updated vCORE VirtualBox appliance based on
Debian 9.6 that includes the latest versions of CORE, EMANE, Quagga
OSPF-MANET, and NASA’s ION.

This version of the virtual appliance includes the following releases:

CORE 5.2 (git)
EMANE 1.2.3 (git)
NRL Quagga mr_0.99.21mr2.2 (source)
NASA ION-DTN 3.6.2 (sourceforge)

All dependencies were installed via apt-get including all packages required
to build the above listed software from source. All source code for the
above listed packages is located in /usr/src/ for end user customization
and updates. The virtual machine was designed to be used for development
purposes, and can be fully customized by the end user.

username: core
password: eroc
The ‘core’ user has sudo privileges, and core-daemon is set to run on
startup. You may want to edit the VirtualBox network settings (ie. bridge,
NAT, host-only) for the VM to suit your environment.

Download the new vCORE VirtualBox appliance at:
http://cs.utica.edu/~rlbull/vcore/vCORE.ova
md5 hash: e5a80ee4dd5893ec3bfa63afa54b11b2 vCORE.ova

webpage:
http://ronnybull.com/2019/01/15/new-custom-vcore-virtualbox-appliance-with-emane-quagga-ospf-manet-nasa-ion-dtn/

Ronny

---

From: "Dr. Ronny L. Bull" <[email-masked]>
Date: Thu, 24 Jan 2019 15:14:22 -0500

There seemed to be a permissions issue on the file download after we made a
few security changes to the server.  I have fixed the issue and the
download link should be working correctly again.

Ronny

On Tue, Jan 15, 2019 at 2:51 PM Dr. Ronny L. Bull <[email-masked]>
wrote:

> All dependencies were installed via apt-get including all packages
> required to build the above listed software from source. All source code
> for the above listed packages is located in /usr/src/ for end user
> customization and updates. The virtual machine was designed to be used for
> development purposes, and can be fully customized by the end user.
>
> username: core
> password: eroc

---

From: Keith Scott <[email-masked]>
Date: Fri, 25 Jan 2019 14:47:23 -0500

Very cool.  I put together a similar capability using a bootable .iso image
a while back that contains ION and a number of exemplar ION scenarios; it's
downloadable from https://www.nasa.gov/content/dtn.  The current version is
based off an older Ubuntu because of the image transfer test application,
but the next version I'll be able to move to 18.04 and ION3.6.2

    v/r,

   --keith

On Tue, Jan 15, 2019 at 2:52 PM Dr. Ronny L. Bull <[email-masked]>
wrote:

> _______________________________________________
> dtn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dtn
>

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Fri, 25 Jan 2019 20:56:59 +0000

Hi, CORE comes from our group, and we showed a CORE DTN demo at IPNSIG 2015:

https://www.youtube.com/watch?v=QyqdyOM60bw

We like that others are finding value in applying CORE for DTN research, and we like
that the work is being discussed openly in the public domain. We look forward to
hearing about further developments and collaboration opportunities.

Thanks - Fred

From: dtn [mailto:[email-masked]] On Behalf Of Keith Scott
Sent: Friday, January 25, 2019 11:47 AM
To: Dr. Ronny L. Bull <[email-masked]>
Cc: [email-masked]
Subject: Re: [dtn] New Custom vCORE VirtualBox Appliance With EMANE, Quagga OSPF-MANET, & NASA ION-DTN

Very cool.  I put together a similar capability using a bootable .iso image a while back that contains ION and a number of exemplar ION scenarios; it's downloadable from https://www.nasa.gov/content/dtn.  The current version is based off an older Ubuntu because of the image transfer test application, but the next version I'll be able to move to 18.04 and ION3.6.2

    v/r,

   --keith

On Tue, Jan 15, 2019 at 2:52 PM Dr. Ronny L. Bull <[email-masked]<mailto:[email-masked]>> wrote:

I have put together a fully updated vCORE VirtualBox appliance based on Debian 9.6 that includes the latest versions of CORE, EMANE, Quagga OSPF-MANET, and NASA’s ION.

CORE 5.2 (git)
EMANE 1.2.3 (git)

All dependencies were installed via apt-get including all packages required to build the above listed software from source. All source code for the above listed packages is located in /usr/src/ for end user customization and updates. The virtual machine was designed to be used for development purposes, and can be fully customized by the end user.

username: core
password: eroc
The ‘core’ user has sudo privileges, and core-daemon is set to run on startup. You may want to edit the VirtualBox network settings (ie. bridge, NAT, host-only) for the VM to suit your environment.

Download the new vCORE VirtualBox appliance at:  http://cs.utica.edu/~rlbull/vcore/vCORE.ova
md5 hash: e5a80ee4dd5893ec3bfa63afa54b11b2 vCORE.ova

webpage: http://ronnybull.com/2019/01/15/new-custom-vcore-virtualbox-appliance-with-emane-quagga-ospf-manet-nasa-ion-dtn/

Ronny
_______________________________________________
dtn mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dtn

---

From: Carlo Caini <[email-masked]>
Date: Sat, 26 Jan 2019 09:12:39 +0000

Dear Fred, Keith and Ronny,
       I have used, or better studied, CORE for a year. I normally use a virtual testbed manager based on virtual machines for my test on DTN, but I was interested in knowing more on the approach used in CORE, based on Linux containers. I was particularly interested in comparing the two approaches, VMs vs containers, but also to study how DTN (ION) configuration files are organized and how tests are carried out in the NASA Development kit. In brief, I was interested in both the CORE network emulator and the NASA projects.
After having studied CORE (I devoted a thesis to that), I translated to CORE three pre-existing testbeds developed for the EO-DTN  (Earth Observation DTN) project supported by ESA and re-run the main tests. The aim was to push commonality as much as possible and to obtain in CORE the same results already achieved on VM based testbeds.
Results are positive on both sides:
1) the two approaches have theirs pros and cons, and are somewhat complementary
2) ION files can be organized in a way that the very same project "repository" (the folder of the project containing all ION files) con be used in both environments. The key is to use a folder for each DTN node (all ION files but the contact plan) and one for the common files (the contact plan).
3) Both platform use a control network, thus in both platform tests can be carried out by a "dotest" script file (with few differences).
4) results are equivalent.
In conclusions commonality is at 90%, which is really good. This means that a DTN project developed for CORE can be easily  translated into a VM based project and from it, in turns, on a real testbed (or real deployment), and vice versa. As said, the key is in the repository organization.
To describe the pros and cons here would be to long. Let me say that CORE is definitely faster when the same test should be repeated with different versions of ION, thus to test new features and fixes, because there is only one version of ION for all nodes, that installed in the host. To change ION version on all nodes it is enough to carry out a "make install" on the host, full stop. For the same reason VMs are better for inter-operability tests.
Let me congratulate with all CORE and NASA kit developers for the great job done!
Yours,
    Carlo

At 21:56 25/01/2019, Templin (US), Fred L wrote:
Content-Language: en-US
Content-Type: multipart/alternative;
 boundary="_000_181bd961c4d44443be4ba62ff5fecbc9boeingcom_"

Thanks - Fred

From: dtn [ mailto:[email-masked]] On Behalf Of Keith Scott
Sent: Friday, January 25, 2019 11:47 AM
To: Dr. Ronny L. Bull <[email-masked]>
Cc: [email-masked]
Subject: Re: [dtn] New Custom vCORE VirtualBox Appliance With EMANE, Quagga OSPF-MANET, & NASA ION-DTN

    v/r,

   --keith

CORE 5.2 (git)
EMANE 1.2.3 (git)

username: core
password: eroc

Ronny

---

From: <[email-masked]>
Date: Sat, 26 Jan 2019 09:31:14 +0000

Carlo, great work as usual. I want to add some non-technical points on the scenarios developed for the DTN-EO project, which was summarized on ESA's website: https://www.esa.int/Our_Activities/Preparing_for_the_Future/Discovery_and_Preparation/Space_internet_to_enhance_Earth_observation

The first scenario (A) is a generic Earth Observation mission, based on the ESA Copernicus Sentinel missions. This mission focused on high data throughput with pretty "normal" contact schedules. The next scenario (B) envisioned a convoy of satellites communicating via relay and/or DTE X-Band. Finally, in scenario C,  the convoy idea was extended to martian orbits, with the addition of orbiters and rovers. Each of the scenarios was intended to stress a different component of DTN, with a particular focus on ION, such as CGR and prioritization. Based on the DTN-EO results, the scenarios certainly did their job, in terms of stress testing.

Please let us know if you have any questions about the scenarios, or our stress-testing workflows.

Thanks,
Jeremy

________________________________
From: dtn [[email-masked]] on behalf of Carlo Caini [[email-masked]]
Sent: Saturday, January 26, 2019 10:12 AM
To: Templin (US), Fred L; Keith Scott; Dr. Ronny L. Bull
Cc: [email-masked]; [email-masked]
Subject: Re: [dtn] New Custom vCORE VirtualBox Appliance With EMANE, Quagga OSPF-MANET, & NASA ION-DTN

Thanks - Fred

    v/r,

   --keith

CORE 5.2 (git)
EMANE 1.2.3 (git)

username: core
password: eroc

Ronny

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Thu, 31 Jan 2019 17:48:56 +0000

Hi Carlo,

>> 2) ION files can be organized in a way that the very same project "repository" (the folder of the
>> project containing all ION files) con be used in both environments. The key is to use a folder
>> for each DTN node (all ION files but the contact plan) and one for the common files (the contact plan).

Yes, that is what we have been doing for DTN emulations for many years, and is
also the approach used for most other CORE emulation projects. Set up a little
folder based on the node name for each CORE vnode, with configuration files
that are read at startup time. Also as a place to drop per-node log files.

The trick with ION is that you need to honor the “ION_NODE_LIST_DIR” environment
variable. What also works well for ION is to harvest the configurations from the test
scripts in the “./tests” and “./demos” directories and use those to populate the per
node folders read by the CORE startup scripts.

Thanks - Fred

From: Carlo Caini [mailto:[email-masked]]
Sent: Saturday, January 26, 2019 1:13 AM
To: Templin (US), Fred L <[email-masked]>; Keith Scott <[email-masked]>; Dr. Ronny L. Bull <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [dtn] New Custom vCORE VirtualBox Appliance With EMANE, Quagga OSPF-MANET, & NASA ION-DTN

Content-Language: en-US

Thanks - Fred

From: dtn [ mailto:[email-masked]] On Behalf Of Keith Scott
Sent: Friday, January 25, 2019 11:47 AM
To: Dr. Ronny L. Bull <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [dtn] New Custom vCORE VirtualBox Appliance With EMANE, Quagga OSPF-MANET, & NASA ION-DTN

    v/r,

   --keith

On Tue, Jan 15, 2019 at 2:52 PM Dr. Ronny L. Bull <[email-masked]<mailto:[email-masked]>> wrote:
I have put together a fully updated vCORE VirtualBox appliance based on Debian 9.6 that includes the latest versions of CORE, EMANE, Quagga OSPF-MANET, and NASAâ€™s ION.

CORE 5.2 (git)
EMANE 1.2.3 (git)

username: core
password: eroc
The â€˜coreâ€™ user has sudo privileges, and core-daemon is set to run on startup. You may want to edit the VirtualBox network settings (ie. bridge, NAT, host-only) for the VM to suit your environment.

Ronny