Subject: [dtn] MTCP PDU Length Field

From: Felix Walter <[email-masked]>
Date: Tue, 26 Mar 2019 20:02:36 +0100

Hi,

Concerning draft-ietf-dtn-mtcpcl-00: As mentioned in the WG session
today I wondered whether the length of the serialized bundle is required
as a separate array item in the MPDU (see [1]). According to the CBOR
spec [2], the encoded byte string already contains a length.

From an implementation perspective, having an additional length field
should not be a problem: Both values encode the length of the
encapsulated (serialized) bundle and, by that, do not depend on each
other. (You may remember the discussion about the bundle block data
length field last year where this was the case. This was also the reason
why I stumbled upon this when reading the draft again.)

Thus, if I'm not mistaken, couldn't we reduce the MPDU to a single
definite-length CBOR byte string?

Felix

[1] https://tools.ietf.org/html/draft-ietf-dtn-mtcpcl-00#section-3.2
[2] https://tools.ietf.org/html/rfc7049#section-2.1

-- 
Dipl.-Ing. Felix Walter
Chief Technology Officer
D3TN GmbH
 
E-Mail: [email-masked]
Web: https://d3tn.com

Address:
D3TN GmbH
Leon-Pohle-Str. 2
01219 Dresden

Commercial Register: District Court Dresden
Register Number: HRB 34957
VAT ID Number: DE303348407
Managing Directors: Marius Feldmann, Paul Seidler

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Wed, 27 Mar 2019 05:45:25 +0000

Hi, Felix.  Yes, I agree.  Looking back at our discussion of this topic in mid-January in the context of BP blocks, I think I simply didn't take the consensus far enough: declaring the block-type-specific data to be a single definite-length CBOR byte string (no separate data length field needed) in BP was correct, but MTCPCL protocol data units should be formatted in the same way -- the separate data length field is not needed.  I'll make that change.

Scott

-----Original Message-----
From: dtn <[email-masked]> On Behalf Of Felix Walter
Sent: Tuesday, March 26, 2019 12:03 PM
To: [email-masked]
Subject: [EXTERNAL] [dtn] MTCP PDU Length Field

Hi,

Concerning draft-ietf-dtn-mtcpcl-00: As mentioned in the WG session today I wondered whether the length of the serialized bundle is required as a separate array item in the MPDU (see [1]). According to the CBOR spec [2], the encoded byte string already contains a length.

>From an implementation perspective, having an additional length field should not be a problem: Both values encode the length of the encapsulated (serialized) bundle and, by that, do not depend on each other. (You may remember the discussion about the bundle block data length field last year where this was the case. This was also the reason why I stumbled upon this when reading the draft again.)

Thus, if I'm not mistaken, couldn't we reduce the MPDU to a single definite-length CBOR byte string?

Felix

--
Dipl.-Ing. Felix Walter
Chief Technology Officer
D3TN GmbH

Address:
D3TN GmbH
Leon-Pohle-Str. 2
01219 Dresden

Commercial Register: District Court Dresden Register Number: HRB 34957 VAT ID Number: DE303348407 Managing Directors: Marius Feldmann, Paul Seidler

_______________________________________________
dtn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtn