Subject: [dtn] new charter items

From: "Marc Blanchet" <[email-masked]>
Date: Wed, 04 Sep 2019 14:01:09 -0400

starting a new thread on new charter items. Please reply this email with 
your proposal, in order to feed the discussion of our interim meeting.

Marc.

---

From: "Burleigh, Scott C (US 312B)" <[email-masked]>
Date: Wed, 4 Sep 2019 19:02:26 +0000

I think BIBE and MTCPCL can be viewed as fitting within the existing charter, as they are convergence-layer protocol specifications; in any case I certainly commit to working on them.  The one other item I would propose to add to the charter would be a quality-of-service extension block, and I will commit to working on that as well.

Scott

-----Original Message-----
From: dtn <[email-masked]> On Behalf Of Marc Blanchet
Sent: Wednesday, September 4, 2019 11:01 AM
To: DTN WG <[email-masked]>
Subject: [EXTERNAL] [dtn] new charter items

starting a new thread on new charter items. Please reply this email with your proposal, in order to feed the discussion of our interim meeting.

Marc.

_______________________________________________
dtn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtn

---

From: Rick Taylor <[email-masked]>
Date: Mon, 16 Sep 2019 14:05:24 +0000

One of the things I consider missing from the current DTN working group
documents is a logical architecture.

With the BPbis and TCP-CL documents we introduce some of the concepts
around 'convergence layers' and 'bundle processing', and although those
of us who are long-time followers of the WG understand what these
concepts mean, and how they are the building blocks of a layered
architecture, I believe there is merit in formally describing the
architecture we currently elude to.

As we start to look deeper into endpoint addressing, concepts such as
'convergence-layer-local endpoint addresses' start to become important,
particularly with routing, and without an architecture to reference,
formally defining such things is just harder.

So, is there any interest in defining a logical model?

Regards,

Rick

---

From: Mehmet Adalier <[email-masked]>
Date: Mon, 16 Sep 2019 10:16:03 -0700

Yes, and I'll volunteer to contribute to the best of my abilities

mehmet

On 9/16/19, 7:05 AM, "dtn on behalf of Rick Taylor" <[email-masked] on behalf of [email-masked]> wrote:

    

    Regards,
    
    Rick

---

From: Rick Taylor <[email-masked]>
Date: Mon, 16 Sep 2019 19:44:09 +0000

I've been reminded that RFC 4838 exists, and I've just mentioned wanting a DTN architecture...

As a clarification: My desire is for a (reasonably concise) document that defines the layering inside a single bundle processing agent, and the forwarding process followed inside that agent, rather than a reworking of the excellent RFC 4838.

My concern is that as WG members propose interesting endpoint addressing schemes, neighbour discovery mechanisms and routing protocols - a consistent logical view of the behaviour/logical layers within a node is required.

At an earlier IETF (I will have to look back through the minutes to find which one) I presented a short slide deck on a logical representation of a forwarding plane/routing table for a BPA, not because it was particularly novel, but simply to try to introduce a formal model that could capture implementer's and protocol designer's opinions of the inner workings of a BPA.

Regards,

Rick

> From: Mehmet Adalier [mailto:[email-masked]]
> Sent: 16 September 2019 18:16
> To: Rick Taylor; [email-masked]; [email-masked]
> Subject: Re: [dtn] new charter items
> 
> On 9/16/19, 7:05 AM, "dtn on behalf of Rick Taylor" <[email-masked]
> on behalf of [email-masked]> wrote:
>

---

From: "Birrane, Edward J." <[email-masked]>
Date: Tue, 17 Sep 2019 17:48:19 +0000

I would ask that in addition to the AMA, the broader topic of asynchronous management (ADM/AMP) be considered for adoption in the new charter.  

If adopted, I commit to working on them. 

-Ed

---
Edward J. Birrane, III, Ph.D.
Embedded Applications Group Supervisor
Space Exploration Sector
Johns Hopkins Applied Physics Laboratory
(W) 443-778-7423 / (F) 443-228-3839

> Sent: Wednesday, September 04, 2019 2:01 PM
> Subject: [dtn] new charter items
> 
> starting a new thread on new charter items. Please reply this email with your
> proposal, in order to feed the discussion of our interim meeting.
> 
> Marc.
>