Subject: Re: [dtn] Marking RFC5050 as Obsolete?

From: "Burleigh, Scott C (US 312B)" <[email-masked]>
Date: Tue, 1 Oct 2019 14:19:38 +0000

Maybe one additional consideration here is that IPv4 was (and remains) a standard, while BPv6 is not; RFC 5050 is an experimental RFC, not a standards-track RFC.  Is it reasonable to infer from this that IETF has no responsibility to sustain BPv6 in any event, that the clear intent of IETF is simply to establish and sustain BPv7 as a new standard?  In which case it is perhaps just unnecessary to mark RFC 5050 as obsolete?

Scott

-----Original Message-----
From: dtn <[email-masked]> On Behalf Of Templin (US), Fred L
Sent: Thursday, September 26, 2019 6:58 AM
To: Carsten Bormann <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: [EXTERNAL] Re: [dtn] Marking RFC5050 as Obsolete?

Actually, I like the IPv4 / IPv6 analogy but if you don't consider also that IPv4 did not "obsolete" OSI yet there are still small pockets of OSI deployment worldwide. (For that matter, I don't think anyone ever claimed to "obsolete" DECnet.) In this sense, by going out of our way to say "obsoletes" BPv7 would going against the precedence set by a number of significant earlier examples.

Fred

> -----Original Message-----
> From: Carsten Bormann [mailto:[email-masked]]
> Sent: Thursday, September 26, 2019 12:39 AM
> To: Templin (US), Fred L <[email-masked]>
> Cc: [email-masked]; [email-masked]
> Subject: Re: [dtn] Marking RFC5050 as Obsolete?
> 
> On Sep 25, 2019, at 21:52, Templin (US), Fred L <[email-masked]> wrote:
> >
> > It is the same with BPv6 and BPv7 - there is a non-negligible 
> > deployment of BPv6 that will still continue after BPv7 is published whether we say "obsoletes" or not.
> > There is operational experience with BPv6 that will continue onwards 
> > the same as happened with IPv4, and that is not a bad thing.
> 
> There will always be protocols in real world use that have been replaced by newer ones.
> 
> The question here is one of expressing intent.  Is BPv7 intended to supersede BPv6 or not?
> 
> I’m not talking about “deployment realities” here (heck, I still have 
> some Python v2 on my system), I’m talking about intent going forward.  
> Either the intent is to sustain both versions indefinitely (with bug 
> fixes and extensions still going into BPv6), or the intent is to move 
> to BPv7.  Like with Python v3, which ultimately needed a strong statement (and even a deadline) that it is now time to stop using Python v2 (and even then, the Python v2 is not going to vanish from my systems magically, and there will likely be some people hacking v2 and keeping it alive even beyond 2020-01-01).
> (We don’t need a deadline here, but we need to be clear about the 
> intent.)
> 
> I don’t think IPv4 vs. IPv6 is a good analogy here, but if you have a 
> massive infrastructure processing BPv6 bundles, it may seem to be that way to you.
> 
> Grüße, Carsten

_______________________________________________
dtn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtn

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Tue, 1 Oct 2019 15:49:59 +0000

Scott, yes BPv6 per RFC5050 is an experiment that is still very much in progress and
publication of BPv7 as a standard will not in itself signal an end to the experiment.

Fred

> From: Burleigh, Scott C (US 312B) [mailto:[email-masked]]
> Sent: Tuesday, October 01, 2019 7:20 AM
> To: Templin (US), Fred L <[email-masked]>; Carsten Bormann <[email-masked]>
> Subject: RE: [dtn] Marking RFC5050 as Obsolete?
> 
> Maybe one additional consideration here is that IPv4 was (and remains) a standard, while BPv6 is not; RFC 5050 is an experimental
> RFC, not a standards-track RFC.  Is it reasonable to infer from this that IETF has no responsibility to sustain BPv6 in any event, that the
> clear intent of IETF is simply to establish and sustain BPv7 as a new standard?  In which case it is perhaps just unnecessary to mark RFC
> 5050 as obsolete?
> 
> Scott
> 
> Actually, I like the IPv4 / IPv6 analogy but if you don't consider also that IPv4 did not "obsolete" OSI yet there are still small pockets of
> OSI deployment worldwide. (For that matter, I don't think anyone ever claimed to "obsolete" DECnet.) In this sense, by going out of
> our way to say "obsoletes" BPv7 would going against the precedence set by a number of significant earlier examples.
> 
> Fred
> 
> > to BPv7.  Like with Python v3, which ultimately needed a strong statement (and even a deadline) that it is now time to stop using
> Python v2 (and even then, the Python v2 is not going to vanish from my systems magically, and there will likely be some people
> hacking v2 and keeping it alive even beyond 2020-01-01).

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 1 Oct 2019 22:55:57 +0200

On Oct 1, 2019, at 16:19, Burleigh, Scott C (US 312B) <[email-masked]> wrote:
> 
> In which case it is perhaps just unnecessary to mark RFC 5050 as obsolete?

There are always other ways to obtain or infer some information, but the “obsoletes” relationship was specifically created to express this.  We should use it.  Not using it sends a confused signal.

Grüße, Carsten

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Tue, 1 Oct 2019 21:31:03 +0000

Carsten, are you worried that people will keep using SDNV and not start using CBOR? I don't
think you need to be concerned about that - migration to BPv7/CBOR will happen. BTW, it
was I who first suggested bringing CBOR in to replace SDNV as the coding scheme for BPv7.

Thanks - Fred

> Sent: Tuesday, October 01, 2019 1:56 PM
> To: Burleigh, Scott C (US 312B) <[email-masked]>
> Cc: Templin (US), Fred L <[email-masked]>; [email-masked]; [email-masked]
> There are always other ways to obtain or infer some information, but the “obsoletes” relationship was specifically created to express
> this.  We should use it.  Not using it sends a confused signal.
> 
> Grüße, Carsten