Subject: Re: [dtn] CRC discussion

From: "Marc Blanchet" <[email-masked]>
Date: Fri, 04 Oct 2019 16:14:19 -0400

Scott, seeing no comments on the list, so let’s proceed then.

Marc.

On 18 Sep 2019, at 17:06, Burleigh, Scott C (US 312B) wrote:

> Hi.  During today's Interim meeting of the DTN WG we spent some time 
> discussing the need for CRCs covering the primary blocks of bundles.  
> My understanding of the position we reached in the meeting is as 
> follows:
>
> 1.  The source of a bundle MUST include a CRC in the bundle's primary 
> block unless the bundle includes a Block Integrity Block whose target 
> is the primary block, in which case it still MAY include a CRC in the 
> bundle's primary block.
>
> 2.  CRCs MAY be included in all other blocks, i.e., the payload block 
> and all extension blocks.
>
> 3.  A node that receives a bundle SHOULD validate all CRCs that are 
> present in all blocks of the bundle.
>
> Scott

---

From: "Burleigh, Scott C (US 312B)" <[email-masked]>
Date: Fri, 4 Oct 2019 21:47:29 +0000

Okay.  Do we have a final determination on the question of obsoleting RFC 5050?  That will affect the text I post.

Scott

-----Original Message-----
From: Marc Blanchet <[email-masked]> 
Sent: Friday, October 4, 2019 1:14 PM
To: Burleigh, Scott C (US 312B) <[email-masked]>
Cc: DTN WG <[email-masked]>
Subject: [EXTERNAL] Re: [dtn] CRC discussion

Marc.