Subject: [dtn] Alissa Cooper's No Objection on draft-ietf-dtn-bpsec-18: (with COMMENT)

From: Alissa Cooper via Datatracker <[email-masked]>
Date: Thu, 06 Feb 2020 05:33:54 -0800

Alissa Cooper has entered the following ballot position for
draft-ietf-dtn-bpsec-18: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-dtn-bpsec/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I support Mirja's and Benjamin's DISCUSSes.

In Section 3.8:

"o  It is RECOMMENDED that designers carefully consider the effect of
      setting flags that either discard the block or delete the bundle
      in the event that this block cannot be processed.

   o  The BCB block processing control flags can be set independently
      from the processing control flags of the security target(s).  The
      setting of such flags SHOULD be an implementation/policy decision
      for the encrypting node."

Both of these uses of normative language seem inappropriate.

---

From: "Birrane, Edward J." <[email-masked]>
Date: Sat, 8 Feb 2020 00:25:23 +0000

Alissa,

  Thank you for the review. I have updated a new version of BPSEC  (BPSEC20) which I believe addresses your COMENTS. 

  Specific comments are in-line below.  I have enumerated the comment items as **C# to aid in referencing these points going forward.

-Ed

Edward J. Birrane, III, Ph.D.
Embedded Applications Group Supervisor
Principal Staff, Space Exploration Sector
Johns Hopkins Applied Physics Laboratory
(W) 443-778-7423 / (F) 443-228-3839

-----Original Message-----
From: Alissa Cooper via Datatracker <[email-masked]> 
Sent: Thursday, February 6, 2020 8:34 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; Scott Burleigh <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: [EXT] Alissa Cooper's No Objection on draft-ietf-dtn-bpsec-18: (with COMMENT)

APL external email warning: Verify sender [email-masked] before clicking links or attachments 

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

In Section 3.8:

**C1: Agreed. This has been corrected in BPSEC20.

**C2: Agreed. This has been corrected in BPSEC20.