Subject: [dtn] Various IESG "DISCUSS" positions on draft-ietf-dtn-*

From: "R. Atkinson" <[email-masked]>
Date: Sat, 8 Feb 2020 14:05:07 -0500

All,

It is great to see such rapid email list responses answering various questions and seeking to address concerns on various topics — from various IESG members.

I am concerned that we all keep in mind that implementers will be working from the final RFCs — and in many cases will NOT be reading these email responses.

If something is unclear or unexplained in an I-D and an explanation was needed to resolve one of the IESG member’s concerns, then IMHO that should result in the I-D editors/authors editing the relevant I-Ds to embed those clarifications inside the final RFC which WILL be referenced by implementers.

Purely as an example, if there is existing practice of using static routes or using some external specification, the practice ought to be documented and any applicable external specification ought to be both mentioned in the I-D (at least briefly) and also cited.  That way the reader won’t be left wondering how BP possibly could be deployed to the ISS or elsewhere.

Just 2 cents from the peanut gallery. :-)

Cheers,

Ran

---

From: "Taylor, Rick" <[email-masked]>
Date: Mon, 10 Feb 2020 10:29:07 +0000

Hi Ran,

You make a very valid point.  Can I reach out to the authors in advance of Vancouver, to request that they perhaps present a short piece on what last minute changes have gone in.

Of course, any summaries to the list would be great as well, but I understand it is still a little bit of a moving target.

Cheers,

Rick Taylor

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of R. Atkinson
Sent: Saturday, February 8, 2020 7:05 PM
To: [email-masked]
Cc: [email-masked]
Subject: [dtn] Various IESG "DISCUSS" positions on draft-ietf-dtn-*

All,

Cheers,

Ran

_______________________________________________
dtn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtn
This email and its attachments may contain confidential and/or privileged information.  If you have received them in error you must not use, copy or disclose their content to any person.  Please notify the sender immediately and then delete this email from your system.  This e-mail has been scanned for viruses, but it is the responsibility of the recipient to conduct their own security measures. Airbus Operations Limited is not liable for any loss or damage arising from the receipt or use of this e-mail.

Airbus Operations Limited, a company registered in England and Wales, registration number, 3468788.  Registered office:  Pegasus House, Aerospace Avenue, Filton, Bristol, BS34 7PA, UK.

---

From: "Burleigh, Scott C (US 312B)" <[email-masked]>
Date: Mon, 10 Feb 2020 16:15:34 +0000

Sure, I can certainly do that.

Scott

-----Original Message-----
From: dtn <[email-masked]> On Behalf Of Taylor, Rick
Sent: Monday, February 10, 2020 2:29 AM
To: R. Atkinson <[email-masked]>; [email-masked]
Cc: [email-masked]
Subject: [EXTERNAL] Re: [dtn] Various IESG "DISCUSS" positions on draft-ietf-dtn-*

Hi Ran,

Cheers,

Rick Taylor

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of R. Atkinson
Sent: Saturday, February 8, 2020 7:05 PM
To: [email-masked]
Cc: [email-masked]
Subject: [dtn] Various IESG "DISCUSS" positions on draft-ietf-dtn-*

All,

Cheers,

Ran

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 12 Feb 2020 08:25:53 +0000

Hi,

I think Ran's request is reasonable in general. I also noted in another email
that maybe the fact that the WG is continuing to build components that can be
used to build a system is being developed and that going from some core
functionalities the set of defined components and functions will continue to be
expanded on. And  although at the point of publication of these initial core
documents these parts are not done, more can be found. I think naming,
addressing and routing is one such area where more work will happen. 

Cheers

Magnus Westerlund
TSV AD

On Mon, 2020-02-10 at 16:15 +0000, Burleigh, Scott C (US 312B) wrote:
> You make a very valid point.  Can I reach out to the authors in advance of
> Vancouver, to request that they perhaps present a short piece on what last
> minute changes have gone in.
> 
> Of course, any summaries to the list would be great as well, but I understand
> it is still a little bit of a moving target.
> 
> Cheers,
> 
> Rick Taylor
> 
> It is great to see such rapid email list responses answering various questions
> and seeking to address concerns on various topics — from various IESG members.
> 
> I am concerned that we all keep in mind that implementers will be working from
> the final RFCs — and in many cases will NOT be reading these email responses.
> 
> If something is unclear or unexplained in an I-D and an explanation was needed
> to resolve one of the IESG member’s concerns, then IMHO that should result in
> the I-D editors/authors editing the relevant I-Ds to embed those
> clarifications inside the final RFC which WILL be referenced by implementers.
> 
> Purely as an example, if there is existing practice of using static routes or
> using some external specification, the practice ought to be documented and any
> applicable external specification ought to be both mentioned in the I-D (at
> least briefly) and also cited.  That way the reader won’t be left wondering
> how BP possibly could be deployed to the ISS or elsewhere.
> 
> This email and its attachments may contain confidential and/or privileged
> information.  If you have received them in error you must not use, copy or
> disclose their content to any person.  Please notify the sender immediately
> and then delete this email from your system.  This e-mail has been scanned for
> viruses, but it is the responsibility of the recipient to conduct their own
> security measures. Airbus Operations Limited is not liable for any loss or
> damage arising from the receipt or use of this e-mail.
> 
> Airbus Operations Limited, a company registered in England and Wales,
> registration number, 3468788.  Registered office:  Pegasus House, Aerospace
> Avenue, Filton, Bristol, BS34 7PA, UK.
-- 
Cheers

Magnus Westerlund 

----------------------------------------------------------------------
Networks, Ericsson Research
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Torshamnsgatan 23           | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: "Taylor, Rick" <[email-masked]>
Date: Wed, 12 Feb 2020 10:45:08 +0000

+1 Magnus,

We have mentioned routing, naming and addressing as part of the recharter.

Rick

-----Original Message-----
From: dtn [mailto:[email-masked]] On Behalf Of Magnus Westerlund
Sent: Wednesday, February 12, 2020 8:26 AM
To: scott.c.burleigh=[email-masked]; [email-masked]; [email-masked]; Taylor, Rick <[email-masked]>
Cc: [email-masked]
Subject: Re: [dtn] Various IESG "DISCUSS" positions on draft-ietf-dtn-*

Hi,

I think Ran's request is reasonable in general. I also noted in another email that maybe the fact that the WG is continuing to build components that can be used to build a system is being developed and that going from some core functionalities the set of defined components and functions will continue to be expanded on. And  although at the point of publication of these initial core documents these parts are not done, more can be found. I think naming, addressing and routing is one such area where more work will happen. 

Cheers

Magnus Westerlund
TSV AD

On Mon, 2020-02-10 at 16:15 +0000, Burleigh, Scott C (US 312B) wrote:
> Subject: [EXTERNAL] Re: [dtn] Various IESG "DISCUSS" positions on 
> draft-ietf-
> dtn-*
> 
> 
> Hi Ran,
> 
> You make a very valid point.  Can I reach out to the authors in 
> advance of Vancouver, to request that they perhaps present a short 
> piece on what last minute changes have gone in.
> 
> Of course, any summaries to the list would be great as well, but I 
> understand it is still a little bit of a moving target.
> 
> Cheers,
> 
> Rick Taylor
> 
> It is great to see such rapid email list responses answering various 
> questions and seeking to address concerns on various topics — from various IESG members.
> 
> I am concerned that we all keep in mind that implementers will be 
> working from the final RFCs — and in many cases will NOT be reading these email responses.
> 
> If something is unclear or unexplained in an I-D and an explanation 
> was needed to resolve one of the IESG member’s concerns, then IMHO 
> that should result in the I-D editors/authors editing the relevant 
> I-Ds to embed those clarifications inside the final RFC which WILL be referenced by implementers.
> 
> Purely as an example, if there is existing practice of using static 
> routes or using some external specification, the practice ought to be 
> documented and any applicable external specification ought to be both 
> mentioned in the I-D (at least briefly) and also cited.  That way the 
> reader won’t be left wondering how BP possibly could be deployed to the ISS or elsewhere.
> 
> This email and its attachments may contain confidential and/or 
> privileged information.  If you have received them in error you must 
> not use, copy or disclose their content to any person.  Please notify 
> the sender immediately and then delete this email from your system.  
> This e-mail has been scanned for viruses, but it is the responsibility 
> of the recipient to conduct their own security measures. Airbus 
> Operations Limited is not liable for any loss or damage arising from the receipt or use of this e-mail.
> 
> registration number, 3468788.  Registered office:  Pegasus House, 
> Aerospace Avenue, Filton, Bristol, BS34 7PA, UK.
--
Cheers

Magnus Westerlund