Subject: [dtn] IESG feedback for draft-ietf-dtn-tcpclv4

From: Brian Sipos <[email-masked]>
Date: Mon, 24 Feb 2020 22:53:56 +0000

All,
I'm in progress of reviewing comments from [1]. Many of these are phrasing or spelling (and I will try to run the text version through a spell checker to catch more typos). Some are typos from the split of Contact Header from SESS_INIT message, with no change in specified behavior.

Several substantial comments are around the use of TLS or specific version of TLS required that will need some change in specifications. A few comments were questioning the optional use of TLS, for which I am going to stick with the earlier WG decision to keep TLS mandatory-to-implement but not mandatory-to-use. There are also comments of whether supporting TLS 1.2 is necessary now that TLS 1.3 is approved and in many implementations. Are there any WG objections to making TLS 1.3 the specified baseline version? This would not preventing an implementation to negotiate down to 1.2, or some earlier version allowed by local policy for that matter.

[1] https://datatracker.ietf.org/doc/draft-ietf-dtn-tcpclv4/ballot/

---

From: "Marc Blanchet" <[email-masked]>
Date: Mon, 24 Feb 2020 19:14:32 -0500

On 24 Feb 2020, at 17:53, Brian Sipos wrote:

> All,
> I'm in progress of reviewing comments from [1]. Many of these are 
> phrasing or spelling (and I will try to run the text version through a 
> spell checker to catch more typos). Some are typos from the split of 
> Contact Header from SESS_INIT message, with no change in specified 
> behavior.
>
> Several substantial comments are around the use of TLS or specific 
> version of TLS required that will need some change in specifications. 
> A few comments were questioning the optional use of TLS, for which I 
> am going to stick with the earlier WG decision to keep TLS 
> mandatory-to-implement but not mandatory-to-use. There are also 
> comments of whether supporting TLS 1.2 is necessary now that TLS 1.3 
> is approved and in many implementations. Are there any WG objections 
> to making TLS 1.3 the specified baseline version?

as individual, TLS1.3 has key advantages and given its very spread use 
and availability in libraries, I think we should use 1.3 as base.

Marc.

> This would not preventing an implementation to negotiate down to 1.2, 
> or some earlier version allowed by local policy for that matter.
>

> _______________________________________________
> dtn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dtn