Subject: [dtn] BPbis registry values

From: Brian Sipos <[email-masked]>
Date: Tue, 23 Jun 2020 22:24:58 +0000

Scott,
Similar to an earlier DTN mailing list comment about the "dtn" scheme definition not including the "dtn:none" SSP value in the ABNF of [1], does it make sense to allocate an IANA registry of other well-known and integer-encoded SSPs for the dtn scheme? The initial registry would have the value 0 for "none" but it could be helpful to have integer-encoded values for other well-known (fixed-value) SSPs. This is in line with how other protocols use CBOR to have 'tstr' values be more free-form while 'uint' values map from a registry of well-known values.
I was looking into a similar well-known value for neighbor broadcast addressing ("dtn:neighbor" or similar concept).

Also, although the Administrative Record Type sub-registry has not changed for BBv7, would there be value in reserving a block of the higher code points (not available in BPv6, due to its fixed-length encoding) for private or experimental uses? This would be similar to the reservation of block type codes 192-255. I was doing some drafting for a new administrative record type and not having a specific range of code points to experiment within makes it more likely to cause interoperability troubles.

[1] https://datatracker.ietf.org/doc/html/draft-ietf-dtn-bpbis-25#section-4.1.5.1.1
[2] https://www.iana.org/assignments/bundle/bundle.xhtml#admin-record-types

---

From: "Burleigh, Scott C (US 312B)" <[email-masked]>
Date: Tue, 23 Jun 2020 22:49:05 +0000

Hi, Brian.  I believe these ideas merit some WG discussion, and I am skeptical that the progress of the BPv7 protocol specification document ought to be suspended while that discussion is in progress.  My understanding is that IANA has well-established procedures for adding useful registries and adding new entries to existing registries.  I really would like to see the WG and the IESG agree on the technical content of the BPv7 specification and move ahead with finally publishing it, five years after taking up the challenge.

Scott

From: Brian Sipos <[email-masked]>
Sent: Tuesday, June 23, 2020 3:25 PM
To: [email-masked]; Burleigh, Scott C (US 312B) <[email-masked]>
Subject: [EXTERNAL] BPbis registry values

Scott,

---

From: Brian Sipos <[email-masked]>
Date: Tue, 23 Jun 2020 22:59:41 +0000

Scott, I agree. These ideas are "in addition to the BPbis as written" with no change to or effect on the existing text or behavior.
________________________________
From: Burleigh, Scott C (US 312B) <[email-masked]>
Sent: Tuesday, June 23, 2020 18:49
To: Brian Sipos <[email-masked]>; [email-masked] <[email-masked]>
Subject: RE: BPbis registry values

Scott

Scott,