Subject: [dtn] DTN URI structure and patterns

From: Brian Sipos <[email-masked]>
Date: Tue, 9 Jun 2020 21:19:32 +0000

All,
In RFC4838 [1] there is mention of the potential to "provision for wildcarding some portion of an EID" but none of the DTN-scheme URIs that I've come across or the structure in BPbis [2] really indicate what wildcarding would look like or how it would operate.
Is wildcarding currently in use for DTN-scheme URIs?
What exactly would the wildcard cover; a portion of the "node-name" or "demux" part, or both, or something else?

It's also not clear what the expected "node-name" structure of a DTN-scheme URI is supposed to look like or behave like. I've seen some examples with pseduo-domain-names used for node names, but are these actually structured names or just opaque "1*VHCAR" as [2] indicates?
Are node names "one.net" and "two.net" in any way related? Do existing tools use some relationships like these?

These questions are coming up as a result of looking at what PKIX on a DTN would look like and trying to head off some struggles which have already caused lots of pain in PKIX for DNS names [3].

[1] https://tools.ietf.org/html/rfc4838#section-3.3
[2] https://tools.ietf.org/html/draft-ietf-dtn-bpbis-24#section-10.7
[3] https://tools.ietf.org/html/rfc6125#section-7.2

---

From: Loiseau lucien <[email-masked]>
Date: Wed, 10 Jun 2020 09:46:46 +0800

Hi,

I authored a draft last year to start the discussion on the topic of
DTN-URI:

https://tools.ietf.org/id/draft-loiseau-dtn-cla-eid-00.html

Afaik wildcarding and other DTN-scheme specifics are all implementation
dependant and that is why I thought that at the very least, each
convergence layer adapter (cla) should be mapped to a specific EID scheme
"cla".
By doing so, we would at least have a way to reliably identify link-local
nodes over which we can later build more complicated routing scheme.

I have also made an implementation of BPBIs called Terra:

https://github.com/Marlinski/Terra

In this implementation, a bundle node can have multiple EIDs and each
application would simply register the path portion of the URI.
For instance let's assume that a node has a "simple tcp" convergence layer
adapter on two IP interfaces (10.0.0.1 and 192.168.0.12) and an application
layer echo service.
In that case in Terra:

   - this bundle node would be identified over iface1 with the EID cla:stcp:
   10.0.0.1:1234
   - and over iface2 with the EID cla:stcp:192.168.0.12:1234
   - the echo service would register the path /echo/

and so you could send bundle to the echo service either through iface1
using the full dtn uri cla:stcp:10.0.0.1:1234/echo/ or through iface2 with
cla:stcp:192.168.0.12:1234/echo/
Of course this is only valid for the cla scheme. Any other dtn-scheme would
have its own semantic.

There is also an old document written by Keith Scott from 2008 that dig a
little bit more in DTN naming but I think it is mostly informational
(I joined the document to this email because the original link has become
401
https://cwe.ccsds.org/sis/docs/SIS-DTN/Other%20Documents/DTN%20Naming%20and%20Addressing3.docx
)

On Wed, Jun 10, 2020 at 5:20 AM Brian Sipos <[email-masked]> wrote:

> All,
> In RFC4838 [1] there is mention of the potential to "provision for
> wildcarding some portion of an EID" but none of the DTN-scheme URIs that
> I've come across or the structure in BPbis [2] really indicate what
> wildcarding would look like or how it would operate.
> What exactly would the wildcard cover; a portion of the "node-name" or
> "demux" part, or both, or something else?
>
> It's also not clear what the expected "node-name" structure of a
> DTN-scheme URI is supposed to look like or behave like. I've seen some
> examples with pseduo-domain-names used for node names, but are these
> actually structured names or just opaque "1*VHCAR" as [2] indicates?
> These questions are coming up as a result of looking at what PKIX on a DTN
> would look like and trying to head off some struggles which have already
> caused lots of pain in PKIX for DNS names [3].
>
> _______________________________________________
> dtn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dtn
>

-- 
--
Lucien Loiseau

---

From: "Burleigh, Scott C (US 312B)" <[email-masked]>
Date: Wed, 10 Jun 2020 14:14:09 +0000

Hi, Brian.  I think the intent was to acknowledge that one or more BP EID URI schemes could be defined in the future with scheme-specific part syntax that included wild-carding, but no such scheme definitions have been standardized yet as far as I know.  The definitions of those new schemes would be where we would answer your questions.

Scott

From: dtn <[email-masked]> On Behalf Of Brian Sipos
Sent: Tuesday, June 9, 2020 2:20 PM
To: [email-masked]
Subject: [EXTERNAL] [dtn] DTN URI structure and patterns

All,