Subject: Re: [dtn] BPbis - BPSec requirement

From: Mehmet Adalier <[email-masked]>
Date: Tue, 28 Jul 2020 15:25:31 -0700

I agree with Brian’s assessment.

From: dtn <[email-masked]> on behalf of Brian Sipos <[email-masked]>
Date: Tuesday, July 28, 2020 at 4:52 AM
To: Rick Taylor <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [dtn] BPbis - BPSec requirement

All,

My opinion is that BPSec should be required in the sense of: When bundle-level security is needed, you must use BPSec instead of some other mechanism with the same or similar scope.

This is the same type of qualified requirement used for TLS in TCPCLv4.

This requirement steers implementations away from private encodings/behaviors, which is desirable as Rick mentioned in the Monday meeting.

From: dtn <[email-masked]> on behalf of Rick Taylor <[email-masked]>
Sent: Monday, July 27, 2020 09:05
To: [email-masked] <[email-masked]>
Subject: [dtn] BPbis - BPSec requirement 

All,

At IETF-108 there was discussion on whether BPbis should require BPSec, and the chairs are interested in discovering the WG consensus on this matter.

Please use this thread for your comments.

Cheers,

Rick & Marc

_______________________________________________ dtn mailing list [email-masked] https://www.ietf.org/mailman/listinfo/dtn

---

From: "Birrane, Edward J." <[email-masked]>
Date: Wed, 29 Jul 2020 00:55:34 +0000

I agree that BPSec should be required when using in-bundle security services.

I agree that a BPA which does not source, verify, or accept security blocks does not need to implement BPSec.

I also note that implementing BPSec is different than implementing every possible security context and/or ciphersuite.

I think Section 9.0 of BPbis-26 captures this very well.

-Ed

Edward J. Birrane, III, Ph.D.
Embedded Applications Group Supervisor
Principal Staff, Space Exploration Sector
Johns Hopkins Applied Physics Laboratory
(W) 443-778-7423<tel:(443)%20778-7423> / (F) 443-228-3839<tel:(443)%20228-3839>

From: dtn <[email-masked]> On Behalf Of Mehmet Adalier
Sent: Tuesday, July 28, 2020 6:26 PM
To: [email-masked]
Subject: [EXT] Re: [dtn] BPbis - BPSec requirement

APL external email warning: Verify sender [email-masked]<mailto:[email-masked]> before clicking links or attachments

From: dtn <[email-masked]<mailto:[email-masked]>> on behalf of Brian Sipos <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 28, 2020 at 4:52 AM
To: Rick Taylor <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [dtn] BPbis - BPSec requirement

All,

________________________________
From: dtn <[email-masked]<mailto:[email-masked]>> on behalf of Rick Taylor <[email-masked]<mailto:[email-masked]>>
Sent: Monday, July 27, 2020 09:05
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: [dtn] BPbis - BPSec requirement

All,

Cheers,

Rick & Marc
_______________________________________________ dtn mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/dtn