Subject: [dtn] BPbis - BPSec requirement

From: Rick Taylor <[email-masked]>
Date: Mon, 27 Jul 2020 13:05:34 +0000

All,

At IETF-108 there was discussion on whether BPbis should require BPSec, and the chairs are interested in discovering the WG consensus on this matter.

Please use this thread for your comments.

Cheers,

Rick & Marc

---

From: "Marc Blanchet" <[email-masked]>
Date: Mon, 27 Jul 2020 09:30:24 -0400

On 27 Jul 2020, at 9:05, Rick Taylor wrote:

> All,
>
> At IETF-108 there was discussion on whether BPbis should require 
> BPSec,

<as wg participant>
I strongly disagree. BPsec must not be mandatory to implement. Security 
services can be implemented at other layers, i.e. inside the payload. We 
tried to make IPsec mandatory for IPv6 and failed. However, most 
Internet trafic nowadays is fully encrypted, using security services 
inside the basic IP payload (eg TLS).  BPsec is a significant piece of 
work to implement, therefore will then discourage developers to 
implement BP because of this high bar. We shall not make BPsec mandatory 
to implement.

Marc.
</as wg participant>

> and the chairs are interested in discovering the WG consensus on this 
> matter.
>

> _______________________________________________
> dtn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dtn

---

From: Brian Sipos <[email-masked]>
Date: Tue, 28 Jul 2020 11:52:33 +0000

All,
My opinion is that BPSec should be required in the sense of: When bundle-level security is needed, you must use BPSec instead of some other mechanism with the same or similar scope.
This is the same type of qualified requirement used for TLS in TCPCLv4.
This requirement steers implementations away from private encodings/behaviors, which is desirable as Rick mentioned in the Monday meeting.

________________________________
From: dtn <[email-masked]> on behalf of Rick Taylor <[email-masked]>
Sent: Monday, July 27, 2020 09:05
To: [email-masked] <[email-masked]>
Subject: [dtn] BPbis - BPSec requirement

All,

Cheers,

Rick & Marc

---

From: "Burleigh, Scott C (US 312B)" <[email-masked]>
Date: Tue, 28 Jul 2020 12:54:47 +0000

This makes sense to me.

From: dtn <[email-masked]> On Behalf Of Brian Sipos
Sent: Tuesday, July 28, 2020 4:53 AM
To: Rick Taylor <[email-masked]>; [email-masked]
Subject: [EXTERNAL] Re: [dtn] BPbis - BPSec requirement

All,

________________________________
From: dtn <[email-masked]<mailto:[email-masked]>> on behalf of Rick Taylor <[email-masked]<mailto:[email-masked]>>
Sent: Monday, July 27, 2020 09:05
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: [dtn] BPbis - BPSec requirement

All,

Cheers,

Rick & Marc

---

From: [email-masked]
Date: Tue, 28 Jul 2020 18:15:33 -0400

I agree 100% with Brian.  BPSec should be the "standard" for bundle-
level encryption. 

Ronny

On Tue, 2020-07-28 at 11:52 +0000, Brian Sipos wrote:
> All,
> My opinion is that BPSec should be required in the sense of: When
> bundle-level security is needed, you must use BPSec instead of some
> other mechanism with the same or similar scope.
> This requirement steers implementations away from private
> encodings/behaviors, which is desirable as Rick mentioned in the
> Monday meeting.
> 
> BPSec, and the chairs are interested in discovering the WG consensus
> on this matter.
>