Subject: [dtn] Interoperability context and/or COSE

From: Rick Taylor <[email-masked]>
Date: Mon, 27 Jul 2020 13:08:54 +0000

Hi All,

At IETF-108 a question was raised as whether the existing BPSec interoperability security context should be useable in environments beyond interoperability-testing.

A second question was raised: whether the COSE security context would actually make a good replacement for the BPSec interoperability security context draft.

The chairs are interested in discovering WG consensus on the following topics:

1.       Should BPsec-interop be updated to be 'production grade'?

2.       Should the COSE security context be adopted as a WG document?

3.       Should the COSE security context replace the BPSec-interop document?

Cheers,

Rick & Marc

---

From: Brian Sipos <[email-masked]>
Date: Wed, 29 Jul 2020 01:52:09 +0000

All,
One thing that I forgot to mention during discussion of the proposed COSE Contexts is that COSE already provides for multiple signatures/MACs and countersignatures in a way which is compatible with the "one target-and-operation" rule of BPSec.
There had been some discussion earlier in the meeting during BPSec topic about security contexts and how/why to support these kinds of complex situations. The current I-D doesn't cover these topics, but if it's to become a WG document I would add examples including those kinds of situations. COSE itself includes such examples.

________________________________
From: dtn <[email-masked]> on behalf of Rick Taylor <[email-masked]>
Sent: Monday, July 27, 2020 09:08
To: [email-masked] <[email-masked]>
Subject: [dtn] Interoperability context and/or COSE

Hi All,

1.       Should BPsec-interop be updated to be ‘production grade’?

Cheers,

Rick & Marc