Subject: [dtn] BPbis - Time and General Relativity

From: Alexandre Waeles <[email-masked]>
Date: Thu, 6 Aug 2020 10:26:03 +0200

Hi.

As many knows General Relativity makes time flowing different depending 
on the position in space.

I'm concerned about how this will be handled in or around Bundle Protocol.

Best regards,

-- 
Alexandre Waeles

Rue bois des fosses 42
1350 Enines
Belgium

Phone: +32 (0) 495 75 49 94

---

From: "Burleigh, Scott C (US 312B)" <[email-masked]>
Date: Thu, 6 Aug 2020 14:57:13 +0000

Hi, Alexandre.  It think two considerations mitigate this concern.

First, none of the nodes of the network are likely to be moving fast enough any time soon for velocity time dilation to be significant.  The maximum relative velocity of Mars from Earth, for example, is something like 54 km/s; the fastest spacecraft flown to date, the Parker Solar Probe, reached a speed of a little over 71 km/s.  At those rates, velocity time dilation per day is measured in microseconds.  (The same is true of gravitational time dilation in locations that network nodes are likely to occupy.)

Second, none of the functions of the Bundle Protocol itself rely on the exact alignment of the clocks consulted by BP nodes throughout the solar system.  The only time-sensitive aspect of the protocol is the deletion of bundles whose lifetime is determined to have expired, and adding a few seconds of margin to bundles' asserted lifetimes has negligible effect on the efficiency of the network.

It may very well be the case that some of the applications running over BP will need to account for both gravitational and velocity time dilation, as the GPS system (for example) does.  But BP itself can readily tolerate relativistic time effects.

Scott

-----Original Message-----
From: dtn <[email-masked]> On Behalf Of Alexandre Waeles
Sent: Thursday, August 6, 2020 1:26 AM
To: [email-masked]
Subject: [EXTERNAL] [dtn] BPbis - Time and General Relativity

Hi.

As many knows General Relativity makes time flowing different depending on the position in space.

Best regards,

--
Alexandre Waeles

Rue bois des fosses 42
1350 Enines
Belgium

_______________________________________________
dtn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtn