Subject: [dtn] I-D Action: draft-ietf-dtn-bpbis-28.txt

From: [email-masked]
Date: Fri, 30 Oct 2020 20:44:54 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Delay/Disruption Tolerant Networking WG of the IETF.

        Title           : Bundle Protocol Version 7
        Authors         : Scott Burleigh
                          Kevin Fall
                          Edward J. Birrane
	Filename        : draft-ietf-dtn-bpbis-28.txt
	Pages           : 67
	Date            : 2020-10-30

Abstract:
   This Internet Draft presents a specification for the Bundle
   Protocol, adapted from the experimental Bundle Protocol
   specification developed by the Delay-Tolerant Networking Research
   group of the Internet Research Task Force and documented in RFC
   5050.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dtn-bpbis/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-dtn-bpbis-28
https://datatracker.ietf.org/doc/html/draft-ietf-dtn-bpbis-28

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dtn-bpbis-28

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Burleigh, Scott C (US 312B)" <[email-masked]>
Date: Sat, 31 Oct 2020 03:55:29 +0000

Hi.  Version 28 of the bpbis I-D has now been posted, addressing some points raised over the past couple of days.  One change (actually already present in version 27) that may be controversial is that, in order to ensure that bundles are always in the same (canonical) form at all points on the end-to-end path for BPsec purposes, all CBOR integer representations are required to be of minimal length.  That is, bytes containing nothing but leading zeroes are prohibited.  This constraint is simple and economical, but it may need discussion; suggestions for similarly simple alternatives are welcome.

Scott

-----Original Message-----
From: dtn <[email-masked]> On Behalf Of [email-masked]
Sent: Friday, October 30, 2020 8:45 PM
To: [email-masked]
Cc: [email-masked]
Subject: [EXTERNAL] [dtn] I-D Action: draft-ietf-dtn-bpbis-28.txt

Abstract:

The IETF datatracker status page for this draft is:
https://urldefense.us/v3/__https://datatracker.ietf.org/doc/draft-ietf-dtn-bpbis/__;!!PvBDto6Hs4WbVuu7!aydvYRWvaxixFBA3MGw4yIjpmyQfVzlc-b8PzMALuGW0wiZ9L9gJ2jcOe9klnxAWCcCqTdpkyNM$ 

There are also htmlized versions available at:
https://urldefense.us/v3/__https://tools.ietf.org/html/draft-ietf-dtn-bpbis-28__;!!PvBDto6Hs4WbVuu7!aydvYRWvaxixFBA3MGw4yIjpmyQfVzlc-b8PzMALuGW0wiZ9L9gJ2jcOe9klnxAWCcCqBAr-WWs$
https://urldefense.us/v3/__https://datatracker.ietf.org/doc/html/draft-ietf-dtn-bpbis-28__;!!PvBDto6Hs4WbVuu7!aydvYRWvaxixFBA3MGw4yIjpmyQfVzlc-b8PzMALuGW0wiZ9L9gJ2jcOe9klnxAWCcCqJm-o2qQ$ 

A diff from the previous version is available at:
https://urldefense.us/v3/__https://www.ietf.org/rfcdiff?url2=draft-ietf-dtn-bpbis-28__;!!PvBDto6Hs4WbVuu7!aydvYRWvaxixFBA3MGw4yIjpmyQfVzlc-b8PzMALuGW0wiZ9L9gJ2jcOe9klnxAWCcCqQXBZQcg$ 

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
https://urldefense.us/v3/__ftp://ftp.ietf.org/internet-drafts/__;!!PvBDto6Hs4WbVuu7!aydvYRWvaxixFBA3MGw4yIjpmyQfVzlc-b8PzMALuGW0wiZ9L9gJ2jcOe9klnxAWCcCqPlGw3sE$ 

_______________________________________________
dtn mailing list
[email-masked]
https://urldefense.us/v3/__https://www.ietf.org/mailman/listinfo/dtn__;!!PvBDto6Hs4WbVuu7!aydvYRWvaxixFBA3MGw4yIjpmyQfVzlc-b8PzMALuGW0wiZ9L9gJ2jcOe9klnxAWCcCqnroKHak$