Subject: [dtn] Bundle multicasting

From: Alexandre Waeles <[email-masked]>
Date: Sat, 7 Nov 2020 15:07:04 +0100

Hi,

I'm wondering about how a bundle could be sent to multiple nodes and to 
make sure that every node received the bundle.

I guess it could be made through announcing another "multicast" endpoint 
ID at many different nodes. But I'm not sure on how that could be 
handled in a routing protocol like PRoPHET, would it rather be some 
anycast ?

Thanks,

Alexandre Waeles

-- 
Signature

*Alexandre Waeles* (HE2B: #54023)

Academic contact: [email-masked] <mailto:[email-masked]>
Personal contact: [email-masked] 
<mailto:[email-masked]>
Personal phone: +32 495 75 49 94 <tel:+32495754994>

Rue Bois des Fosses 42
1350 Enines
Belgium

This message as well as all its attachements are /strictly confidential/ 
and /sent to the attention of its recipients only/ if not stated otherwise.

If this message was sent to you in error, please delete it and notify 
the sender immediately!

*Sharing or copying the content of this message is forbidden!*

------------------------------------------------------------------------

Ce message ainsi que toutes ses pièces-jointes sont /strictement 
confidentiels/ et /envoyées à l'attention de ses destinataires 
uniquement/ si ce n'est pas précisé autrement.

Si ce message vous a été envoyé par erreur, veuillez le supprimer et 
notifier l'expéditeur immédiatement !

*Il est interdit de diffuser ou reproduire le contenu de ce message !*

---

From: "Burleigh, Scott C (US 312B)" <[email-masked]>
Date: Sat, 7 Nov 2020 15:01:58 +0000

Hello, Alexandre.  In the ION implementation of Bundle Protocol we have got a prototype implementation of bundle multicast.  The version in the current ION distribution is quite clumsy, but a much better (I think) realization will be provided in the next ION release later this month.

The new bundle multicast prototype is integrated with, and in fact relies on, the “contact graph routing” mechanism for route computation.  From the user perspective it is simple: the node simply registers as a member of the endpoint that identifies the multicast group and begins receiving bundles at that endpoint.

But the effectiveness of CGR for opportunistic forwarding – hence for opportunistic multicast – remains to be demonstrated; some other mechanism may well be needed.  I think this remains an open research area.

Scott

From: dtn <[email-masked]> On Behalf Of Alexandre Waeles
Sent: Saturday, November 7, 2020 6:07 AM
To: [email-masked]
Subject: [EXTERNAL] [dtn] Bundle multicasting

Hi,

I'm wondering about how a bundle could be sent to multiple nodes and to make sure that every node received the bundle.

I guess it could be made through announcing another "multicast" endpoint ID at many different nodes. But I'm not sure on how that could be handled in a routing protocol like PRoPHET, would it rather be some anycast ?

Thanks,

Alexandre Waeles
--

Alexandre Waeles (HE2B: #54023)

Academic contact: [email-masked]<mailto:[email-masked]>
Personal contact: [email-masked]<mailto:[email-masked]>
Personal phone: +32 495 75 49 94<tel:+32495754994>

Rue Bois des Fosses 42
1350 Enines
Belgium

This message as well as all its attachements are strictly confidential and sent to the attention of its recipients only if not stated otherwise.

If this message was sent to you in error, please delete it and notify the sender immediately!

Sharing or copying the content of this message is forbidden!

________________________________

Ce message ainsi que toutes ses pièces-jointes sont strictement confidentiels et envoyées à l'attention de ses destinataires uniquement si ce n'est pas précisé autrement.

Si ce message vous a été envoyé par erreur, veuillez le supprimer et notifier l'expéditeur immédiatement !

Il est interdit de diffuser ou reproduire le contenu de ce message !