Subject: [dtn] BPSec Last Call

From: "Birrane, Edward J." <[email-masked]>
Date: Fri, 8 Jan 2021 21:53:59 +0000

DTNWG,

  As was the case with BPBis, BPSec underwent some changes to address review comments.  Rick and I would like to double-check that BPsec still has the consensus of the working group by issuing a last call on the draft, ending 22 January 2021.

  Thank you to those who have already been reviewing this document and providing comments. The latest draft should include responses to those comments.

  Please find time in this new year to review this specification. As with BpBis, silence will be taken as approval.

  The latest draft, -26, can be found at: https://datatracker.ietf.org/doc/draft-ietf-dtn-bpsec/

Rick & Ed,
Co-chairs

---
Edward J. Birrane, III, Ph.D.
Embedded Applications Group Supervisor
Space Exploration Sector
Johns Hopkins Applied Physics Laboratory
(W) 443-778-7423 / (F) 443-228-3839

---

From: Brian Sipos <[email-masked]>
Date: Tue, 12 Jan 2021 04:51:15 +0000

Ed,
In support of the encoding and logic of BPSec, I split off the demo BP agent [2] and the wireshark plugins [3] and updated them to source and validate BIBs and to dissect ASBs respectively. These are only up to the -25 draft [1] but should quickly be able to include the last -26 changes. The current BP agent is able to send and validate COSE-signed bundles (yay!) as proof-of-concept.

I also defined a simple BPSec CDDL representation at [4] (again for the -25 draft) that you're welcome to steal if you like for BPSec itself. This CDDL has to choose concrete block type codes, so I chose (experimental range) numbers 192 and 193 to work with.

Related to one of the changes in -26 to remove the optional Security Source, if the Parameters Present Flag was also removed (so that the parameters array is always there) it would actually save one byte and simplify the encoding (the ASB would always be exactly 5 items long). If the Parameters array is required to be present then an empty array would be allowed.

[1] https://tools.ietf.org/html/draft-ietf-dtn-bpsec-25
[2] https://github.com/BSipos-RKF/dtn-demo-agent
[3] https://github.com/BSipos-RKF/dtn-wireshark
[4] https://github.com/BSipos-RKF/dtn-bpsec-cose/blob/master/bpsec.cddl

________________________________
From: dtn <[email-masked]> on behalf of Birrane, Edward J. <[email-masked]>
Sent: Friday, January 8, 2021 16:53
To: [email-masked] <[email-masked]>
Subject: [dtn] BPSec Last Call

DTNWG,

  The latest draft, -26, can be found at: https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-dtn-bpsec%2F&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C33d50fa53beb40fbd58008d8b41fedfd%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637457396540468289%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=B%2BKzE1STV9gVEDLSBtKY%2FM%2FIO3Duxw9Is0b0F3t4Zhk%3D&amp;reserved=0

Rick & Ed,
Co-chairs

---

_______________________________________________
dtn mailing list
[email-masked]
https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdtn&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C33d50fa53beb40fbd58008d8b41fedfd%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637457396540468289%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=Vl7QEGVcQLh%2FT47sTJ1pbpdNfqmrTnDW%2BclKoKi5jy8%3D&amp;reserved=0