Subject: Re: [dtn] New Version Notification for draft-sipos-dtn-udpcl-00.txt

From: Brian Sipos <[email-masked]>
Date: Wed, 10 Feb 2021 05:19:05 +0000

All,
I submitted the referenced draft as a first go at a UDP convergence layer which:

  1.  Has backward compatibility with RFC7122 to "just transmit a bundle" in a UDP datagram as well as Keepalive packets.
  2.  Provides a basic CL fragmentation capability without retransmit or acknowledgement. This purpose is really for dealing with small PMTUs relative to not-that-large bundles (1-2 KiB). Some additional requirements can be added that the number of fragments should be few (under 10) for reliability.
  3.  Defines how to use DTLS as CL-layer security mechanism, with same profile as TCPCLv4. Also making this optional and negotiated.
  4.  Defines how to use UDPCL with IP multicast addressing.

The scope leaves any notion of direct congestion control to the BP agent. I don't know if this is exactly accurate, but I did state that:

   When nodes have bidirectional transfer capability, the bundle
   deletion reason code "traffic pared" can be used by a receiving agent
   to signal to the bundle source application that throttling of bundles
   along that path SHOULD occur.

>From existing BPv7 implementations, is this a correct interpretation of how to use that reason code for congestion control back pressure?

________________________________
From: [email-masked] <[email-masked]>
Sent: Sunday, February 7, 2021 23:57
To: Brian Sipos <[email-masked]>; Brian Sipos <[email-masked]>
Subject: New Version Notification for draft-sipos-dtn-udpcl-00.txt

A new version of I-D, draft-sipos-dtn-udpcl-00.txt
has been successfully submitted by Brian Sipos and posted to the
IETF repository.

Name:           draft-sipos-dtn-udpcl
Revision:       00
Title:          Delay-Tolerant Networking UDP Convergence Layer Protocol
Document date:  2021-02-07
Group:          Individual Submission
Pages:          26
URL:            https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-sipos-dtn-udpcl-00.txt&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C8371ca006fdf4a31489d08d8cbedfc28%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637483570298723798%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=LXX1knkFQzeUJ293ANEEpGsubQkBGqBQcSYQh82f3bI%3D&amp;reserved=0
Status:         https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-sipos-dtn-udpcl%2F&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C8371ca006fdf4a31489d08d8cbedfc28%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637483570298723798%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=KCvCdWTS3MQG4cS0Tl4lifRdYnWavZkSCcwshwaY4zU%3D&amp;reserved=0
Html:           https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-sipos-dtn-udpcl-00.html&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C8371ca006fdf4a31489d08d8cbedfc28%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637483570298733796%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=V%2Fpa%2FEUwJKkp5k6AsCSRv0U04YWrGzlikeKZtNZQNZo%3D&amp;reserved=0
Htmlized:       https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-sipos-dtn-udpcl-00&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C8371ca006fdf4a31489d08d8cbedfc28%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637483570298733796%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=YgN1kzMZDUEwWu8aBPBOfw6H8lEPwg94Lhyv0FWC0as%3D&amp;reserved=0

Abstract:
   This document describes a UDP-based convergence layer (UDPCL) for
   Delay-Tolerant Networking (DTN).  This version of the UDPCL protocol
   clarifies requirements of RFC7122, adds discussion of multicast
   addressing, and updates to the Bundle Protocol (BP) contents,
   encodings, and convergence layer requirements in BP Version 7.
   Specifically, the UDPCL uses CBOR-encoded BPv7 bundles as its service
   data unit being transported and provides a reliable transport of such
   bundles.  This version of UDPCL also includes security and
   extensibility mechanisms.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Burleigh, Scott C (US 312B)" <[email-masked]>
Date: Thu, 11 Feb 2021 00:02:55 +0000

Back pressure per se is not real viable in a delay-tolerant network, in the general case; if there's a 30-minute delay before the signal (a status report) arrives, it's probably moot.  Mainly we want to authorize the bundle protocol agent to discard bundles in order to avert congestion locally.  The reason code is provided as a means of explaining these bundle losses in the event that status reports were requested; it functions as a network management tool, i.e., back pressure in a sort of open-loop sense.

From: dtn <[email-masked]> On Behalf Of Brian Sipos
Sent: Tuesday, February 9, 2021 9:19 PM
To: [email-masked]
Subject: [EXTERNAL] Re: [dtn] New Version Notification for draft-sipos-dtn-udpcl-00.txt

All,

________________________________
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, February 7, 2021 23:57
To: Brian Sipos <[email-masked]<mailto:[email-masked]>>; Brian Sipos <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-sipos-dtn-udpcl-00.txt

Name:           draft-sipos-dtn-udpcl
Revision:       00
Title:          Delay-Tolerant Networking UDP Convergence Layer Protocol
Document date:  2021-02-07
Group:          Individual Submission
Pages:          26
URL:            https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-sipos-dtn-udpcl-00.txt&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C8371ca006fdf4a31489d08d8cbedfc28%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637483570298723798%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=LXX1knkFQzeUJ293ANEEpGsubQkBGqBQcSYQh82f3bI%3D&amp;reserved=0<https://urldefense.us/v3/__https:/nam10.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Farchive*2Fid*2Fdraft-sipos-dtn-udpcl-00.txt&amp;data=04*7C01*7CBSipos*40rkf-eng.com*7C8371ca006fdf4a31489d08d8cbedfc28*7C4ed8b15b911f42bc8524d89148858535*7C1*7C0*7C637483570298723798*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&amp;sdata=LXX1knkFQzeUJ293ANEEpGsubQkBGqBQcSYQh82f3bI*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!PvBDto6Hs4WbVuu7!ehKLcjG_N3RmS1CAql_wJedfAeBtyvl8QaTYF2DRDnEqt5uBv2cxz5I8RJDiWj5gkc-fRIyhSIE$>
Status:         https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-sipos-dtn-udpcl%2F&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C8371ca006fdf4a31489d08d8cbedfc28%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637483570298723798%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=KCvCdWTS3MQG4cS0Tl4lifRdYnWavZkSCcwshwaY4zU%3D&amp;reserved=0<https://urldefense.us/v3/__https:/nam10.safelinks.protection.outlook.com/?url=https*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-sipos-dtn-udpcl*2F&amp;data=04*7C01*7CBSipos*40rkf-eng.com*7C8371ca006fdf4a31489d08d8cbedfc28*7C4ed8b15b911f42bc8524d89148858535*7C1*7C0*7C637483570298723798*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&amp;sdata=KCvCdWTS3MQG4cS0Tl4lifRdYnWavZkSCcwshwaY4zU*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJQ!!PvBDto6Hs4WbVuu7!ehKLcjG_N3RmS1CAql_wJedfAeBtyvl8QaTYF2DRDnEqt5uBv2cxz5I8RJDiWj5gkc-fAlU7otQ$>
Html:           https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-sipos-dtn-udpcl-00.html&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C8371ca006fdf4a31489d08d8cbedfc28%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637483570298733796%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=V%2Fpa%2FEUwJKkp5k6AsCSRv0U04YWrGzlikeKZtNZQNZo%3D&amp;reserved=0<https://urldefense.us/v3/__https:/nam10.safelinks.protection.outlook.com/?url=https*3A*2F*2Fwww.ietf.org*2Farchive*2Fid*2Fdraft-sipos-dtn-udpcl-00.html&amp;data=04*7C01*7CBSipos*40rkf-eng.com*7C8371ca006fdf4a31489d08d8cbedfc28*7C4ed8b15b911f42bc8524d89148858535*7C1*7C0*7C637483570298733796*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&amp;sdata=V*2Fpa*2FEUwJKkp5k6AsCSRv0U04YWrGzlikeKZtNZQNZo*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUl!!PvBDto6Hs4WbVuu7!ehKLcjG_N3RmS1CAql_wJedfAeBtyvl8QaTYF2DRDnEqt5uBv2cxz5I8RJDiWj5gkc-fpB2GnuE$>
Htmlized:       https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-sipos-dtn-udpcl-00&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C8371ca006fdf4a31489d08d8cbedfc28%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637483570298733796%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=YgN1kzMZDUEwWu8aBPBOfw6H8lEPwg94Lhyv0FWC0as%3D&amp;reserved=0<https://urldefense.us/v3/__https:/nam10.safelinks.protection.outlook.com/?url=https*3A*2F*2Ftools.ietf.org*2Fhtml*2Fdraft-sipos-dtn-udpcl-00&amp;data=04*7C01*7CBSipos*40rkf-eng.com*7C8371ca006fdf4a31489d08d8cbedfc28*7C4ed8b15b911f42bc8524d89148858535*7C1*7C0*7C637483570298733796*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&amp;sdata=YgN1kzMZDUEwWu8aBPBOfw6H8lEPwg94Lhyv0FWC0as*3D&amp;reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUl!!PvBDto6Hs4WbVuu7!ehKLcjG_N3RmS1CAql_wJedfAeBtyvl8QaTYF2DRDnEqt5uBv2cxz5I8RJDiWj5gkc-fHLV1pYg$>

Abstract:

The IETF Secretariat

---

From: Brian Sipos <[email-masked]>
Date: Thu, 11 Feb 2021 04:48:30 +0000

Scott,
Thanks for that explanation. This use case is exactly as you describe, a single node being overwhelmed and dropping certain traffic along with a status to the source node that the bundle was deleted. You are correct that for large bandwidth-delay products this will have a slow reaction time. My main concern was to cite at least some standard mechanism (for terrestrial use at least).
________________________________
From: Burleigh, Scott C (US 312B) <[email-masked]>
Sent: Wednesday, February 10, 2021 19:02
To: Brian Sipos <[email-masked]>; [email-masked] <[email-masked]>
Subject: RE: New Version Notification for draft-sipos-dtn-udpcl-00.txt

Back pressure per se is not real viable in a delay-tolerant network, in the general case; if there’s a 30-minute delay before the signal (a status report) arrives, it’s probably moot.  Mainly we want to authorize the bundle protocol agent to discard bundles in order to avert congestion locally.  The reason code is provided as a means of explaining these bundle losses in the event that status reports were requested; it functions as a network management tool, i.e., back pressure in a sort of open-loop sense.

All,

Name:           draft-sipos-dtn-udpcl
Revision:       00
Title:          Delay-Tolerant Networking UDP Convergence Layer Protocol
Document date:  2021-02-07
Group:          Individual Submission
Pages:          26
URL:            https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-sipos-dtn-udpcl-00.txt&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C8371ca006fdf4a31489d08d8cbedfc28%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637483570298723798%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=LXX1knkFQzeUJ293ANEEpGsubQkBGqBQcSYQh82f3bI%3D&amp;reserved=0<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.us%2Fv3%2F__https%3A%2Fnam10.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Fwww.ietf.org*2Farchive*2Fid*2Fdraft-sipos-dtn-udpcl-00.txt%26data%3D04*7C01*7CBSipos*40rkf-eng.com*7C8371ca006fdf4a31489d08d8cbedfc28*7C4ed8b15b911f42bc8524d89148858535*7C1*7C0*7C637483570298723798*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26sdata%3DLXX1knkFQzeUJ293ANEEpGsubQkBGqBQcSYQh82f3bI*3D%26reserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!PvBDto6Hs4WbVuu7!ehKLcjG_N3RmS1CAql_wJedfAeBtyvl8QaTYF2DRDnEqt5uBv2cxz5I8RJDiWj5gkc-fRIyhSIE%24&data=04%7C01%7CBSipos%40rkf-eng.com%7Cd3c80f18ce7842792e6a08d8ce2064b6%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637485985854715432%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=Ku5xvhCjdRQxSUAgbZhfwXkTUAGASUukCuiYU%2Ftvnac%3D&reserved=0>
Status:         https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-sipos-dtn-udpcl%2F&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C8371ca006fdf4a31489d08d8cbedfc28%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637483570298723798%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=KCvCdWTS3MQG4cS0Tl4lifRdYnWavZkSCcwshwaY4zU%3D&amp;reserved=0<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.us%2Fv3%2F__https%3A%2Fnam10.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Fdatatracker.ietf.org*2Fdoc*2Fdraft-sipos-dtn-udpcl*2F%26data%3D04*7C01*7CBSipos*40rkf-eng.com*7C8371ca006fdf4a31489d08d8cbedfc28*7C4ed8b15b911f42bc8524d89148858535*7C1*7C0*7C637483570298723798*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26sdata%3DKCvCdWTS3MQG4cS0Tl4lifRdYnWavZkSCcwshwaY4zU*3D%26reserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJQ!!PvBDto6Hs4WbVuu7!ehKLcjG_N3RmS1CAql_wJedfAeBtyvl8QaTYF2DRDnEqt5uBv2cxz5I8RJDiWj5gkc-fAlU7otQ%24&data=04%7C01%7CBSipos%40rkf-eng.com%7Cd3c80f18ce7842792e6a08d8ce2064b6%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637485985854725428%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=wYSJEcT%2BI1otsrHE5cSidH%2B5%2BrrbYwSz3dDcDt3KJIY%3D&reserved=0>
Html:           https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-sipos-dtn-udpcl-00.html&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C8371ca006fdf4a31489d08d8cbedfc28%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637483570298733796%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=V%2Fpa%2FEUwJKkp5k6AsCSRv0U04YWrGzlikeKZtNZQNZo%3D&amp;reserved=0<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.us%2Fv3%2F__https%3A%2Fnam10.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Fwww.ietf.org*2Farchive*2Fid*2Fdraft-sipos-dtn-udpcl-00.html%26data%3D04*7C01*7CBSipos*40rkf-eng.com*7C8371ca006fdf4a31489d08d8cbedfc28*7C4ed8b15b911f42bc8524d89148858535*7C1*7C0*7C637483570298733796*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26sdata%3DV*2Fpa*2FEUwJKkp5k6AsCSRv0U04YWrGzlikeKZtNZQNZo*3D%26reserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUlJSUl!!PvBDto6Hs4WbVuu7!ehKLcjG_N3RmS1CAql_wJedfAeBtyvl8QaTYF2DRDnEqt5uBv2cxz5I8RJDiWj5gkc-fpB2GnuE%24&data=04%7C01%7CBSipos%40rkf-eng.com%7Cd3c80f18ce7842792e6a08d8ce2064b6%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637485985854725428%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=oVyLBBUQ1F9GnyPvddA3bGGqQtuKXMrF2Br5UUxa03U%3D&reserved=0>
Htmlized:       https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-sipos-dtn-udpcl-00&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C8371ca006fdf4a31489d08d8cbedfc28%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637483570298733796%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=YgN1kzMZDUEwWu8aBPBOfw6H8lEPwg94Lhyv0FWC0as%3D&amp;reserved=0<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.us%2Fv3%2F__https%3A%2Fnam10.safelinks.protection.outlook.com%2F%3Furl%3Dhttps*3A*2F*2Ftools.ietf.org*2Fhtml*2Fdraft-sipos-dtn-udpcl-00%26data%3D04*7C01*7CBSipos*40rkf-eng.com*7C8371ca006fdf4a31489d08d8cbedfc28*7C4ed8b15b911f42bc8524d89148858535*7C1*7C0*7C637483570298733796*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000%26sdata%3DYgN1kzMZDUEwWu8aBPBOfw6H8lEPwg94Lhyv0FWC0as*3D%26reserved%3D0__%3BJSUlJSUlJSUlJSUlJSUlJSUl!!PvBDto6Hs4WbVuu7!ehKLcjG_N3RmS1CAql_wJedfAeBtyvl8QaTYF2DRDnEqt5uBv2cxz5I8RJDiWj5gkc-fHLV1pYg%24&data=04%7C01%7CBSipos%40rkf-eng.com%7Cd3c80f18ce7842792e6a08d8ce2064b6%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637485985854735422%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=cqCAbJWd9Hs0o1n90b5kmX5B9meTTH58w2PfS%2F369Us%3D&reserved=0>

Abstract:

The IETF Secretariat