Subject: [dtn] I-D Action: draft-ietf-dtn-tcpclv4-25.txt

From: [email-masked]
Date: Mon, 01 Feb 2021 21:17:21 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Delay/Disruption Tolerant Networking WG of the IETF.

        Title           : Delay-Tolerant Networking TCP Convergence Layer Protocol Version 4
        Authors         : Brian Sipos
                          Michael Demmer
                          Joerg Ott
                          Simon Perreault
	Filename        : draft-ietf-dtn-tcpclv4-25.txt
	Pages           : 76
	Date            : 2021-02-01

Abstract:
   This document describes a TCP-based convergence layer (TCPCL) for
   Delay-Tolerant Networking (DTN).  This version of the TCPCL protocol
   resolves implementation issues in the earlier TCPCL Version 3 of
   RFC7242 and updates to the Bundle Protocol (BP) contents, encodings,
   and convergence layer requirements in BP Version 7.  Specifically,
   the TCPCLv4 uses CBOR-encoded BPv7 bundles as its service data unit
   being transported and provides a reliable transport of such bundles.
   This version of TCPCL also includes security and extensibility
   mechanisms.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-dtn-tcpclv4/

There is also an HTML version available at:
https://www.ietf.org/archive/id/draft-ietf-dtn-tcpclv4-25.html

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-dtn-tcpclv4-25

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Brian Sipos <[email-masked]>
Date: Fri, 5 Feb 2021 04:04:49 +0000

All,
This latest revision of the TCPCLv4 draft addresses one comment from IANA about citing the X.680 specification, last minor comments from Ben Kaduk regarding TLS/PKIX details, and corrects several typos.

I just noticed that my last edit itself has a minor typo. Where it says:
Earlier versions of TCPCL can mandate use of the bits keyEncipherment or keyAgreement.
should instead say:
Earlier versions of TLS can mandate use of the bits keyEncipherment or keyAgreement.
but this is not a normative statement and can be corrected during IESG editing if desired.

Other than that, the document should be ready for final edit.
________________________________
From: dtn <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Tuesday, February 2, 2021 00:17
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: [dtn] I-D Action: draft-ietf-dtn-tcpclv4-25.txt

Abstract:

The IETF datatracker status page for this draft is:
https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-dtn-tcpclv4%2F&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C082c199dc4594682375008d8c739d790%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637478398545395747%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=a07ia9DqDEx4tDkURDQ6WR8VtSp4n6dEuLI%2B0pRoHvw%3D&amp;reserved=0

There is also an HTML version available at:
https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-ietf-dtn-tcpclv4-25.html&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C082c199dc4594682375008d8c739d790%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637478398545395747%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=clrMUbmcITCyDEWXE5SMoFBlMdgVGpKqsYDqKwf8Ldc%3D&amp;reserved=0

A diff from the previous version is available at:
https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Frfcdiff%3Furl2%3Ddraft-ietf-dtn-tcpclv4-25&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C082c199dc4594682375008d8c739d790%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637478398545405739%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=dkE%2FfJ9VrxpUoG6%2B8fKTDTZT5udEBWf3TDfgxzw3JjE%3D&amp;reserved=0

Internet-Drafts are also available by anonymous FTP at:
https://nam10.safelinks.protection.outlook.com/?url=ftp%3A%2F%2Fftp.ietf.org%2Finternet-drafts%2F&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C082c199dc4594682375008d8c739d790%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637478398545405739%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=5nVfCUD8EkYzKP2zoaNbX71zQCkI5l8FDC2QL%2FrWpGk%3D&amp;reserved=0

_______________________________________________
dtn mailing list
[email-masked]
https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fdtn&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C082c199dc4594682375008d8c739d790%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637478398545405739%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=qCLFJyz385JGNlnSwPQbjslkl36AnuF24948iYLuaxA%3D&amp;reserved=0

---

From: "R. Atkinson" <[email-masked]>
Date: Sun, 7 Feb 2021 13:48:24 -0500

Hi,

This simple typo really needs to be fixed.  Otherwise someone trying to implement who hasn’t been on the mailing list will be greatly confused.

I agree this can be fixed easily either during IESG edits or maybe even during AUTH48.

Thanks,

Ran

> On Feb 4, 2021, at 23:04, Brian Sipos <[email-masked]> wrote:
> 
> All,
> https://www.ietf.org/mailman/listinfo/dtn

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 15 Feb 2021 15:38:39 +0000

Hi,

If the author don't want to do one more revision can you give me one 

OLD:

NEW: 

Style change that I can include in the approval announcement. 

Cheers

Magnus Westerlund

> -----Original Message-----
> From: dtn <[email-masked]> On Behalf Of R. Atkinson
> Sent: den 7 februari 2021 19:48
> To: Brian Sipos <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [dtn] I-D Action: draft-ietf-dtn-tcpclv4-25.txt
> 
> Hi,
> 
> This simple typo really needs to be fixed.  Otherwise someone trying to
> implement who hasn’t been on the mailing list will be greatly confused.
> 
> > This latest revision of the TCPCLv4 draft addresses one comment from
> IANA about citing the X.680 specification, last minor comments from Ben
> Kaduk regarding TLS/PKIX details, and corrects several typos.
> >
> > https://protect2.fireeye.com/v1/url?k=2fc84cb1-705375b7-2fc80c2a-86ee8
> > 6bd5107-c52b7ee67ee3fcb0&q=1&e=576b6607-d3c6-4fb2-946f-
> ee3bef02ef22&u=
> >
> https%3A%2F%2Fnam10.safelinks.protection.outlook.com%2F%3Furl%3Dhtt
> ps%
> > 253A%252F%252Fdatatracker.ietf.org%252Fdoc%252Fdraft-ietf-dtn-
> tcpclv4%
> > 252F%26amp%3Bdata%3D04%257C01%257CBSipos%2540rkf-
> eng.com%257C082c199dc
> >
> 4594682375008d8c739d790%257C4ed8b15b911f42bc8524d89148858535%257C
> 1%257
> >
> C0%257C637478398545395747%257CUnknown%257CTWFpbGZsb3d8eyJWIjoi
> MC4wLjAw
> >
> MDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%253D%257C1000%26a
> mp%3B
> >
> sdata%3Da07ia9DqDEx4tDkURDQ6WR8VtSp4n6dEuLI%252B0pRoHvw%253D
> %26amp%3Br
> > eserved%3D0
> >
> > https://protect2.fireeye.com/v1/url?k=cb302daa-94ab14ac-cb306d31-
> 86ee8
> > 6bd5107-d71715e58ed63c60&q=1&e=576b6607-d3c6-4fb2-946f-
> ee3bef02ef22&u=
> >
> https%3A%2F%2Fnam10.safelinks.protection.outlook.com%2F%3Furl%3Dhtt
> ps%
> > 253A%252F%252Fwww.ietf.org%252Farchive%252Fid%252Fdraft-ietf-dtn-
> tcpcl
> > v4-25.html%26amp%3Bdata%3D04%257C01%257CBSipos%2540rkf-
> eng.com%257C082
> >
> c199dc4594682375008d8c739d790%257C4ed8b15b911f42bc8524d89148858535
> %257
> >
> C1%257C0%257C637478398545395747%257CUnknown%257CTWFpbGZsb3d8
> eyJWIjoiMC
> >
> 4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%253D%257C10
> 00%26
> >
> amp%3Bsdata%3DclrMUbmcITCyDEWXE5SMoFBlMdgVGpKqsYDqKwf8Ldc%2
> 53D%26amp%3
> > Breserved%3D0
> >
> > https://protect2.fireeye.com/v1/url?k=ac319809-f3aaa10f-ac31d892-86ee8
> > 6bd5107-3df3b32c41271b1d&q=1&e=576b6607-d3c6-4fb2-946f-
> ee3bef02ef22&u=
> >
> https%3A%2F%2Fnam10.safelinks.protection.outlook.com%2F%3Furl%3Dhtt
> ps%
> > 253A%252F%252Fwww.ietf.org%252Frfcdiff%253Furl2%253Ddraft-ietf-dtn-
> tcp
> > clv4-25%26amp%3Bdata%3D04%257C01%257CBSipos%2540rkf-
> eng.com%257C082c19
> >
> 9dc4594682375008d8c739d790%257C4ed8b15b911f42bc8524d89148858535%2
> 57C1%
> >
> 257C0%257C637478398545405739%257CUnknown%257CTWFpbGZsb3d8eyJ
> WIjoiMC4wL
> >
> jAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%253D%257C1000%
> 26amp
> >
> %3Bsdata%3DdkE%252FfJ9VrxpUoG6%252B8fKTDTZT5udEBWf3TDfgxzw3JjE
> %253D%26
> > amp%3Breserved%3D0
> >
> >
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >
> > https://protect2.fireeye.com/v1/url?k=cd415fcc-92da66ca-cd411f57-86ee8
> > 6bd5107-1b3c9aaf18eab246&q=1&e=576b6607-d3c6-4fb2-946f-
> ee3bef02ef22&u=
> >
> https%3A%2F%2Fnam10.safelinks.protection.outlook.com%2F%3Furl%3Dftp
> %25
> > 3A%252F%252Fftp.ietf.org%252Finternet-
> drafts%252F%26amp%3Bdata%3D04%25
> > 7C01%257CBSipos%2540rkf-
> eng.com%257C082c199dc4594682375008d8c739d790%2
> >
> 57C4ed8b15b911f42bc8524d89148858535%257C1%257C0%257C637478398545
> 405739
> >
> %257CUnknown%257CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2lu
> MzIiLCJBT
> >
> iI6Ik1haWwiLCJXVCI6Mn0%253D%257C1000%26amp%3Bsdata%3D5nVfCUD8
> EkYzKP2zo
> > aNbX71zQCkI5l8FDC2QL%252FrWpGk%253D%26amp%3Breserved%3D0
> >
> >
> > https://protect2.fireeye.com/v1/url?k=558b4543-0a107c45-558b05d8-
> 86ee8
> > 6bd5107-60c0b0fb3a2082dc&q=1&e=576b6607-d3c6-4fb2-946f-
> ee3bef02ef22&u=
> >
> https%3A%2F%2Fnam10.safelinks.protection.outlook.com%2F%3Furl%3Dhtt
> ps%
> >
> 253A%252F%252Fwww.ietf.org%252Fmailman%252Flistinfo%252Fdtn%26am
> p%3Bda
> > ta%3D04%257C01%257CBSipos%2540rkf-
> eng.com%257C082c199dc4594682375008d8
> >
> c739d790%257C4ed8b15b911f42bc8524d89148858535%257C1%257C0%257C6
> 3747839
> >
> 8545405739%257CUnknown%257CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiL
> CJQIjoiV2l
> >
> uMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%253D%257C1000%26amp%3Bsdata%3
> DqCLFJyz
> >
> 385JGNlnSwPQbjslkl36AnuF24948iYLuaxA%253D%26amp%3Breserved%3D0