Subject: [dtn] Default Security Context: default scope for BIB-HMAC-SHA2 and BCB-AES-GCM.

From: "Birrane, Edward J." <[email-masked]>
Date: Tue, 2 Feb 2021 14:40:46 +0000

DTNWG,

  The Integrity Scope Flags for the BIB-HMAC-SHA2 security context currently default to 0 instead of 0x7 (all items included).
  The AAD Scope Flags for the BCB-AES-GCM security context currently default to 0 instead of 0x7 (all items included)

  It was proposed that the default should be something other than 0 and likely 0x7. 

  Currently the document defaults scope to 0.

  As part of WG last call, are there any other thoughts on the setting of this value?

-Ed

---
Edward J. Birrane, III, Ph.D.
Embedded Applications Group Supervisor
Space Exploration Sector
Johns Hopkins Applied Physics Laboratory
(W) 443-778-7423 / (F) 443-228-3839

---

From: "Burleigh, Scott C (US 312B)" <[email-masked]>
Date: Tue, 2 Feb 2021 16:35:51 +0000

My intuition is that the cost of expanding these Scopes to 0x7 would be a small, perhaps negligible, increase in computation time.  That would seem to be outweighed by the advantages noted in the spec, so I would be fine with changing the default from 0 to 0x7.

Scott

-----Original Message-----
From: dtn <[email-masked]> On Behalf Of Birrane, Edward J.
Sent: Tuesday, February 2, 2021 6:41 AM
To: [email-masked]
Subject: [EXTERNAL] [dtn] Default Security Context: default scope for BIB-HMAC-SHA2 and BCB-AES-GCM.

DTNWG,

-Ed

---

_______________________________________________
dtn mailing list
[email-masked]
https://urldefense.us/v3/__https://www.ietf.org/mailman/listinfo/dtn__;!!PvBDto6Hs4WbVuu7!ZQABZaLEmm-ciwwlag6SiWb8jd4rtWnjGnV9v4tPXDQL8d88oxOQ91E8gG2WNtxfBo0u-9DB6_8$