Subject: [dtn] DTN neighbor messaging and neighborhood discovery

From: Brian Sipos <[email-masked]>
Date: Fri, 12 Mar 2021 03:45:20 +0000

All,
While looking at UDPCL and DTN-IPND [1] in the context of MANET NHDP [2], I put some working notes in the form of an RFC draft document [3] and a generated HTML [4]. The core of this notion is that there is a new well-known EID "dtn:~neighbor" which is used for next-hop messaging, ideally over UDP/IP (or some other) multicast transport.

The benefit of doing neighbor messaging and neighborhood discovery at/above the BP layer is that it isolates a potential DTN NHDP from the specific CL used to multicast the bundles. This would allow discovering 2-hop neighborhood which spans a non-IP DTN-capable link. Also, some of the messaging and bookkeeping required by MANET NHDP is already solved by BP (hop counting, limited bundle lifetime, BPSec integrity).

If this seems worth digging into (either neighbor messaging and/or a NHDP) I can submit this as an individual I-D. It's not yet fully baked but does cover the same ground as IPND in a way that avoids custom encoding and avoids duplication of BP-provided behavior.

[1] https://tools.ietf.org/html/draft-irtf-dtnrg-ipnd-03
[2] https://tools.ietf.org/html/rfc6130
[3] https://github.com/BSipos-RKF/dtn-neighbor-msg/blob/main/spec/draft-sipos-dtn-neighbor-msg.xml
[4] https://github.com/BSipos-RKF/dtn-neighbor-msg/suites/2226807647/artifacts/46129908

---

From: Carlo Caini <[email-masked]>
Date: Fri, 12 Mar 2021 09:08:17 +0000

Dear Brian,
     It seems to me an intersting idea, well worth investigating. I have not read the draft yet, however, as link 4 seems broken (err: 404). Could you fix it? 
Thank you!

    Carlo
 
________________________________________
Da: dtn [[email-masked]] per conto di Brian Sipos [[email-masked]]
Inviato: venerdì 12 marzo 2021 04:45
A: [email-masked]
Oggetto: [dtn] DTN neighbor messaging and neighborhood discovery

All,

---

From: Brian Sipos <[email-masked]>
Date: Fri, 12 Mar 2021 20:26:11 +0000

Carlo,
It looks like github build artifacts are now access controlled, but if you have an account and are logged-in you should be able to access it as the whole project is "public".

I actually just set up a Pages config for built artifacts, so the HTML is now available at <https://bsipos-rkf.github.io/dtn-neighbor-msg/draft-sipos-dtn-neighbor-msg.html>.
________________________________
From: Carlo Caini <[email-masked]>
Sent: Friday, March 12, 2021 04:08
To: Brian Sipos <[email-masked]>; [email-masked] <[email-masked]>
Subject: RE: DTN neighbor messaging and neighborhood discovery

Dear Brian,

    Carlo

All,

[1] https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-irtf-dtnrg-ipnd-03&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C407c6349882b4932e2ae08d8e53661f7%7C4ed8b15b911f42bc8524d89148858535%7C1%7C1%7C637511369048385222%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=rYYhKEPZEHW6mFWVY7eAoh8gkd6uS9svVuZs1SdWG6E%3D&amp;reserved=0
[2] https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Frfc6130&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C407c6349882b4932e2ae08d8e53661f7%7C4ed8b15b911f42bc8524d89148858535%7C1%7C1%7C637511369048395220%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=TSY1Kup8lyWgKdyTcZ87%2FY5GOsPq1HOPCBu1ux%2FVyP8%3D&amp;reserved=0
[3] https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2FBSipos-RKF%2Fdtn-neighbor-msg%2Fblob%2Fmain%2Fspec%2Fdraft-sipos-dtn-neighbor-msg.xml&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C407c6349882b4932e2ae08d8e53661f7%7C4ed8b15b911f42bc8524d89148858535%7C1%7C1%7C637511369048395220%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=qiAC2dSb1op1navy2HUQNFlny1CtGPgPJTAeIrIJZvg%3D&amp;reserved=0
[4] https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2FBSipos-RKF%2Fdtn-neighbor-msg%2Fsuites%2F2226807647%2Fartifacts%2F46129908&amp;data=04%7C01%7CBSipos%40rkf-eng.com%7C407c6349882b4932e2ae08d8e53661f7%7C4ed8b15b911f42bc8524d89148858535%7C1%7C1%7C637511369048395220%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=2NMqO%2B8NkhgGZOsXEeat0ayrXHpb1sj32w%2BUmepf3DA%3D&amp;reserved=0