Subject: Re: [dtn] [Acme] WGLC for ACME DTN Node ID

From: Brian Sipos <[email-masked]>
Date: Mon, 3 May 2021 19:00:46 +0000

Yoav,
This draft has also received a DTN WG review, and I have a new revision in progress. This new revision will also address a difference in behavior from the email S/MIME document that was brought up by Ryan Sleevi and explained by Ben Kaduk. That change does affect the data content by adding the challenge-unique token into the bundles with an explanation about its use.

Once that new revision is posted I believe all comments to-date have been addressed.

Thanks to Russ Housley and Ryan Sleevi for the reviews. Thanks to the authors for the revised version.

This is not a great showing in terms of quantity of review, but the quality is sufficient. I will write the shepherd write-up and submit.

Yoav

---

From: Brian Sipos <[email-masked]>
Date: Mon, 31 May 2021 15:07:31 +0000

All,
The ACME validation draft is progressing to the point of IESG review, and one remaining known issue is the mechanism of allocating new BPv7 administrative record types. The BPbis document does not reference the pre-existing IANA registry the same way it does for block types and flags. This is not an ACME-related issue but would apply to any other new administrative record type allocation (e.g., BIBE).

I have added text to pre-submission ACME document [1] in Section 6 requirements and Section 9.3 IANA considerations: updating BPbis to use the IANA registry explicitly and for the registry to indicate BP version for each allocation.
This update also allocates values ">= 65536" as Reserved for Private or Experimental Use; similar to how other registries have high-value allocations for P/E use. This change would have no effect on BPv6 as the type codes for v6 are limited to 4-bit values.

Any objections to the ACME document to including this text or to reserve admin. record types for P/E use? It could just as well go into a separate document, since BPbis is already in the editor queue, but that would require a whole other review process for this small update.

[1] https://briansipos.github.io/acme-dtnnodeid/draft-ietf-acme-dtnnodeid.html