Subject: Re: [dtn] [Acme] WGLC for ACME DTN Node ID

From: "Burleigh, Scott C (US 312B)" <[email-masked]>
Date: Mon, 7 Jun 2021 15:47:06 +0000

Good catch, Brian.  Just to clarify in my mind: are you proposing that IANA Considerations section of the BPv7 specification should be updated, or are you proposing that the new language in the ACME document would be sufficient to establish the mechanism for allocating new BPv7 administrative record types?  If the latter would pass muster with IESG then I am certainly for it.

Scott

From: dtn <[email-masked]> On Behalf Of Brian Sipos
Sent: Monday, May 31, 2021 8:08 AM
To: [email-masked]
Subject: [EXTERNAL] Re: [dtn] [Acme] WGLC for ACME DTN Node ID

All,
The ACME validation draft is progressing to the point of IESG review, and one remaining known issue is the mechanism of allocating new BPv7 administrative record types. The BPbis document does not reference the pre-existing IANA registry the same way it does for block types and flags. This is not an ACME-related issue but would apply to any other new administrative record type allocation (e.g., BIBE).

I have added text to pre-submission ACME document [1] in Section 6 requirements and Section 9.3 IANA considerations: updating BPbis to use the IANA registry explicitly and for the registry to indicate BP version for each allocation.
This update also allocates values ">= 65536" as Reserved for Private or Experimental Use; similar to how other registries have high-value allocations for P/E use. This change would have no effect on BPv6 as the type codes for v6 are limited to 4-bit values.

Any objections to the ACME document to including this text or to reserve admin. record types for P/E use? It could just as well go into a separate document, since BPbis is already in the editor queue, but that would require a whole other review process for this small update.

[1] https://briansipos.github.io/acme-dtnnodeid/draft-ietf-acme-dtnnodeid.html<https://urldefense.us/v3/__https:/briansipos.github.io/acme-dtnnodeid/draft-ietf-acme-dtnnodeid.html__;!!PvBDto6Hs4WbVuu7!caqfTIZ1vzi2GY3Ov0ZNYjErjaGPW2Jj6s6W0G-rCaIflgtV2lKfvyoKqOQ6CdtW5FNsXU1BFvQ$>

---

From: Brian Sipos <[email-masked]>
Date: Mon, 7 Jun 2021 21:10:03 +0000

Scott,
I'm treating the BPbis document as finished and published, and its requirements are self-consistent so it's not really a modification of existing requirements in that document. Really, it's just informing BP implementations to "look here for type codes also". You can see this in the new Section 6 text in the ACME draft [1]. This can be word-smithed however is needed.

[1] https://www.ietf.org/rfcdiff?url2=draft-ietf-acme-dtnnodeid-04

________________________________
From: Burleigh, Scott C (US 312B) <[email-masked]>
Sent: Monday, June 7, 2021 11:47
To: Brian Sipos <[email-masked]>; [email-masked] <[email-masked]>
Subject: RE: [Acme] WGLC for ACME DTN Node ID

Scott

All,

[1] https://briansipos.github.io/acme-dtnnodeid/draft-ietf-acme-dtnnodeid.html<https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.us%2Fv3%2F__https%3A%2Fbriansipos.github.io%2Facme-dtnnodeid%2Fdraft-ietf-acme-dtnnodeid.html__%3B!!PvBDto6Hs4WbVuu7!caqfTIZ1vzi2GY3Ov0ZNYjErjaGPW2Jj6s6W0G-rCaIflgtV2lKfvyoKqOQ6CdtW5FNsXU1BFvQ%24&data=04%7C01%7CBSipos%40rkf-eng.com%7Cb434c97c7bf64ce9f0d908d929cb8396%7C4ed8b15b911f42bc8524d89148858535%7C1%7C0%7C637586776340399093%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=2lOVGbHMfEaCHTiuqNPLe6Gf%2Fng1gHDh3lUWqQiSMmk%3D&reserved=0>

---

From: "Burleigh, Scott C (US 312B)" <[email-masked]>
Date: Mon, 7 Jun 2021 21:58:50 +0000

Looks good to me.

Scott

From: Brian Sipos <[email-masked]>
Sent: Monday, June 7, 2021 2:10 PM
To: Burleigh, Scott C (US 312B) <[email-masked]>; [email-masked]
Subject: [EXTERNAL] Re: [Acme] WGLC for ACME DTN Node ID

Scott,

[1] https://www.ietf.org/rfcdiff?url2=draft-ietf-acme-dtnnodeid-04<https://urldefense.us/v3/__https:/www.ietf.org/rfcdiff?url2=draft-ietf-acme-dtnnodeid-04__;!!PvBDto6Hs4WbVuu7!fQktqGE71cs-fDoCE4XPI3meB-NErg6ZabiB9pYcEdhreH8Ui1awcC4z5gTSVJw7IHSCPkvKt1A$>

________________________________
From: Burleigh, Scott C (US 312B) <[email-masked]<mailto:[email-masked]>>
Sent: Monday, June 7, 2021 11:47
To: Brian Sipos <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Acme] WGLC for ACME DTN Node ID

Scott

From: dtn <[email-masked]<mailto:[email-masked]>> On Behalf Of Brian Sipos
Sent: Monday, May 31, 2021 8:08 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [EXTERNAL] Re: [dtn] [Acme] WGLC for ACME DTN Node ID

All,

[1] https://briansipos.github.io/acme-dtnnodeid/draft-ietf-acme-dtnnodeid.html<https://urldefense.us/v3/__https:/nam10.safelinks.protection.outlook.com/?url=https*3A*2F*2Furldefense.us*2Fv3*2F__https*3A*2Fbriansipos.github.io*2Facme-dtnnodeid*2Fdraft-ietf-acme-dtnnodeid.html__*3B!!PvBDto6Hs4WbVuu7!caqfTIZ1vzi2GY3Ov0ZNYjErjaGPW2Jj6s6W0G-rCaIflgtV2lKfvyoKqOQ6CdtW5FNsXU1BFvQ*24&data=04*7C01*7CBSipos*40rkf-eng.com*7Cb434c97c7bf64ce9f0d908d929cb8396*7C4ed8b15b911f42bc8524d89148858535*7C1*7C0*7C637586776340399093*7CUnknown*7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0*3D*7C1000&sdata=2lOVGbHMfEaCHTiuqNPLe6Gf*2Fng1gHDh3lUWqQiSMmk*3D&reserved=0__;JSUlJSUlJSUlJSUlJSUlJSUlJSUlJSUlJQ!!PvBDto6Hs4WbVuu7!fQktqGE71cs-fDoCE4XPI3meB-NErg6ZabiB9pYcEdhreH8Ui1awcC4z5gTSVJw7IHSCO2NqnzI$>