Subject: [dtn] Draft DTNWG Charter Text

From: "Birrane, Edward J." <[email-masked]>
Date: Fri, 23 Jul 2021 13:50:06 +0000

DTNWG,

  Below is the draft revision of the DTNWG charter that we will be discussing at our meeting at IETF111.  Please review prior to the meeting and come with questions and comments. 

---

The Delay/Disruption Tolerant Network Working Group (DTNWG) specifies mechanisms for data communications in the presence of long delays and/or intermittent connectivity. The Working Group has submitted the Bundle Protocol v7 (BPv7), corresponding Bundle Protocol Security Protocol (BPSec) and corresponding Default Security Contexts, and the TCP Convergence Layer documents to the IESG for publication as standards track RFCs.
 
The purpose of this Working Group now turns to further work relevant to the area of Delay/Disruption Tolerant Networking, divided into 3 broad categories:

 * Revision of protocols and capabilities that were defined in DTN IRTF documents, but excluded from the current output of the Working Group.

* The definition of protocols and best practice in the areas of Naming, Addressing and Forwarding, Key Management, and Operations, Administration, and Management (OAM).

* Extensions to existing protocols, including Extension Blocks to add additional capabilities to Bundle Protocol, additional Security Context definitions for BPSec, and new convergence layer adaptors.

Work Items are:

* An update to the Licklider Transmission Protocol (RFC5326)
* Bundle-in-Bundle Encapsulation
* Quality of Service indication in Bundles
* Custody Transfer for reliable bundle delivery
* Asynchronous Management Protocol and Data Model
* Naming and Addressing Architecture
* Neighbor Discovery
* Service Identifiers
* A COSE BPSec Security Context

---

- Ed and Rick, co-chairs.

---
Edward J. Birrane, III, Ph.D. (he/him/his)
Embedded Applications Group Supervisor
Space Exploration Sector
Johns Hopkins Applied Physics Laboratory
(W) 443-778-7423 / (F) 443-228-3839

---

From: [email-masked]
Date: Mon, 26 Jul 2021 11:56:33 +0200

All,

sorry for the very short notice. I cannot attend today but would like to 
propose an additional work item:

* Efficient Bundle Status Reporting

I have had some background discussions on this with Scott and it is 
something ESA might like to use for High Data Rate Space-to-Earth Downlink 
where it could be used as an (better) alternative to custody transfer.
I plan to present the initial ideas later this week in the CCSDS DTN WG 
but I thought it would not harm to have it in the IETF charter as well 
(maybe even replacing the custody transfer for reliable bundle delivery).

Regards,
Felix
-- 
Dr. Felix Flentge
Software Engineer, OPS-GSB
Ground Systems Engineering Department
Directorate of Operations
ESA - ESOC
Robert-Bosch-Str.5, D-64293 Darmstadt, Germany
Phone: +49 6151 90 4075 | Email: [email-masked]

"dtn" <[email-masked]> wrote on 23/07/2021 15:50:06:

> From: "Birrane, Edward J." <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Date: 23/07/2021 15:53
> Subject: [dtn] Draft DTNWG Charter Text
> Sent by: "dtn" <[email-masked]>
> 
> DTNWG,
> 
>   Below is the draft revision of the DTNWG charter that we will be 
> discussing at our meeting at IETF111.  Please review prior to the 
> meeting and come with questions and comments. 
> 
> ---
> 
> The Delay/Disruption Tolerant Network Working Group (DTNWG) 
> specifies mechanisms for data communications in the presence of long
> delays and/or intermittent connectivity. The Working Group has 
> submitted the Bundle Protocol v7 (BPv7), corresponding Bundle 
> Protocol Security Protocol (BPSec) and corresponding Default 
> Security Contexts, and the TCP Convergence Layer documents to the 
> IESG for publication as standards track RFCs.
> 
> The purpose of this Working Group now turns to further work relevant
> to the area of Delay/Disruption Tolerant Networking, divided into 3 
> broad categories:
> 
>  * Revision of protocols and capabilities that were defined in DTN 
> IRTF documents, but excluded from the current output of the Working 
Group.
> 
> * The definition of protocols and best practice in the areas of 
> Naming, Addressing and Forwarding, Key Management, and Operations, 
> Administration, and Management (OAM).
> 
> * Extensions to existing protocols, including Extension Blocks to 
> add additional capabilities to Bundle Protocol, additional Security 
> Context definitions for BPSec, and new convergence layer adaptors.
> 
> Work Items are:
> 
> _______________________________________________
> dtn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dtn

---

From: Rick Taylor <[email-masked]>
Date: Mon, 26 Jul 2021 14:59:59 +0000

Hi Felix,

A pity you can't make it, but I think we all understand a busy schedule.

Perhaps an option might be to have a more generic charter item around "reliable bundle delivery" rather than explicitly naming custody transfer as the only solution?

Or does that result in a completely generic work item that we can never achieve in a reasonable time?

Cheers,

Rick

From: dtn [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 26 July 2021 10:57
To: Birrane, Edward J.
Cc: [email-masked]
Subject: Re: [dtn] Draft DTNWG Charter Text

All,

sorry for the very short notice. I cannot attend today but would like to propose an additional work item:

I have had some background discussions on this with Scott and it is something ESA might like to use for High Data Rate Space-to-Earth Downlink where it could be used as an (better) alternative to custody transfer.
I plan to present the initial ideas later this week in the CCSDS DTN WG but I thought it would not harm to have it in the IETF charter as well (maybe even replacing the custody transfer for reliable bundle delivery).

Regards,
Felix

"dtn" <[email-masked]> wrote on 23/07/2021 15:50:06:

> IRTF documents, but excluded from the current output of the Working Group.
>

---

From: <[email-masked]>
Date: Mon, 26 Jul 2021 08:18:04 -0700

Hi, Rick.  My understanding of the mechanism Felix and I have been
discussing (Felix, please correct anything I get wrong!) is that it's not
necessarily about reliable bundle delivery, but more about giving the source
node information on which it could decide about the disposition of source
data.  The intent is to be very lightweight, with minimal state information
retained at the source; it's aggregate bundle status reporting, functionally
similar to the aggregate custody signaling that was developed for BPv6 on
the Space Station.  I can say a little more about it during the meeting if
that would be helpful.

Scott

From: dtn <[email-masked]> On Behalf Of Rick Taylor
Sent: Monday, July 26, 2021 8:00 AM
To: [email-masked]; Birrane, Edward J. <[email-masked]>
Cc: [email-masked]
Subject: Re: [dtn] Draft DTNWG Charter Text

Hi Felix,

Perhaps an option might be to have a more generic charter item around
"reliable bundle delivery" rather than explicitly naming custody transfer as
the only solution?

Or does that result in a completely generic work item that we can never
achieve in a reasonable time?

Cheers,

Rick

From: dtn [mailto:[email-masked]] On Behalf Of [email-masked]
<mailto:[email-masked]> 
Sent: 26 July 2021 10:57
To: Birrane, Edward J.
Cc: [email-masked] <mailto:[email-masked]> 
Subject: Re: [dtn] Draft DTNWG Charter Text

All, 

I have had some background discussions on this with Scott and it is
something ESA might like to use for High Data Rate Space-to-Earth Downlink
where it could be used as an (better) alternative to custody transfer. 
I plan to present the initial ideas later this week in the CCSDS DTN WG but
I thought it would not harm to have it in the IETF charter as well (maybe
even replacing the custody transfer for reliable bundle delivery). 

Regards, 
Felix 
<mailto:[email-masked]>  

"dtn" <[email-masked] <mailto:[email-masked]> > wrote on
23/07/2021 15:50:06:

> From: "Birrane, Edward J." <[email-masked]
<mailto:[email-masked]> > 
> To: "[email-masked] <mailto:[email-masked]> " <[email-masked]
<mailto:[email-masked]> > 
> Sent by: "dtn" <[email-masked] <mailto:[email-masked]> > 
> 
> DTNWG,
> 
> [email-masked] <mailto:[email-masked]> 
>  <https://www.ietf.org/mailman/listinfo/dtn>