Subject: [dtn] Working Group re-charter text

From: Rick Taylor <[email-masked]>
Date: Tue, 10 Aug 2021 14:45:43 +0000

Hi All,

After some further editing, the AD and chair have what we believe to be the final text for the re-chartering of the working group.  I will append it to this email.

Can you please make some time to read and comment before the 24th August please?

Cheers,

Rick & Ed

------------------------------------------------------------------------------------------------------

The Delay/Disruption Tolerant Network Working Group (DTNWG) specifies mechanisms for data communications in the presence of long delays and/or intermittent connectivity.  The Working Group has submitted the Bundle Protocol v7 (BPv7), corresponding Bundle Protocol Security protocol (BPSec) and an interoperable Security Context, and the TCP Convergence Layer specifications for publication as standards track RFCs.  Multiple independent implementations exist for these technologies and multiple deployments in space and terrestrial environments, and the technology is now used in production by government and commercial organizations world-wide.
 
This Working Group now focuses on the further work relevant to the area of Delay/Disruption Tolerant Networking (DTN), dividing future work items into 3 broad categories:

 * An architecture for Naming, Addressing and Forwarding

    The Bundle Protocol v7 defines an encoding of Names for use in DTN, but the detailed semantics have not been specified.  The Working Group will define a common architecture for the delay/disruption tolerant assignment of names, and the late-binding of such names during bundle forwarding to end-points within a DTN.

 * The definition of protocols and best practices in the areas of Operations, Administration and Management (OAM), and Key Management

    Existing IETF protocols for OAM and Key Management generally rely on a bi-directional end-to-end path between devices, and in a Delay/Disruption Tolerant Network such paths rarely exist.  To enable OAM and Key Management in such cases, there is a need to standardize alternative methods and their supporting protocols and data models.

 * Extensions to existing protocols

    Extensions to the Bundle Protocol to enable reliability signalling, tunnelling and Quality of Service indication are needed for the operational deployment of Delay/Disruption Tolerant Networks, and these capabilities will be standardized by the Working Group.

    Additional extensions to the Bundle Protocol, additional Security Context definitions for BPSec, and new Convergence Layer adaptors will be considered on a case-by-case basis by the working group.

Intentionally excluded from the current Working Group charter is Routing in DTN, as the topic is considered too open, and candidate protocols suitable for standardization do not yet exist.  This does not preclude discussion of potential approaches to the problem of Routing in DTNs within the Working Group, but personal drafts on the topic will not be adopted under this charter.

Work Items include:

 * Naming and Addressing Architecture document
 * Neighbor Discovery protocol specification

 * Asynchronous Management Protocol specification
 * Asynchronous Data Model specification
 * Key Management protocol specification

 * Bundle delivery signalling extension to Bundle Protocol specification
 * Bundle-in-Bundle Encapsulation extension to Bundle Protocol specification
 * Quality of Service indication extension to Bundle Protocol specification
--------------------------------------------------------------------------------------------------

---

From: <[email-masked]>
Date: Tue, 10 Aug 2021 08:55:20 -0700

This looks good to me.

Scott

-----Original Message-----
From: dtn <[email-masked]> On Behalf Of Rick Taylor
Sent: Tuesday, August 10, 2021 7:46 AM
To: [email-masked]
Subject: [dtn] Working Group re-charter text

Hi All,

After some further editing, the AD and chair have what we believe to be the
final text for the re-chartering of the working group.  I will append it to
this email.

Can you please make some time to read and comment before the 24th August
please?

Cheers,

Rick & Ed

----------------------------------------------------------------------------
--------------------------

The Delay/Disruption Tolerant Network Working Group (DTNWG) specifies
mechanisms for data communications in the presence of long delays and/or
intermittent connectivity.  The Working Group has submitted the Bundle
Protocol v7 (BPv7), corresponding Bundle Protocol Security protocol (BPSec)
and an interoperable Security Context, and the TCP Convergence Layer
specifications for publication as standards track RFCs.  Multiple
independent implementations exist for these technologies and multiple
deployments in space and terrestrial environments, and the technology is now
used in production by government and commercial organizations world-wide.
 
This Working Group now focuses on the further work relevant to the area of
Delay/Disruption Tolerant Networking (DTN), dividing future work items into
3 broad categories:

    The Bundle Protocol v7 defines an encoding of Names for use in DTN, but
the detailed semantics have not been specified.  The Working Group will
define a common architecture for the delay/disruption tolerant assignment of
names, and the late-binding of such names during bundle forwarding to
end-points within a DTN.

 * The definition of protocols and best practices in the areas of
Operations, Administration and Management (OAM), and Key Management

    Existing IETF protocols for OAM and Key Management generally rely on a
bi-directional end-to-end path between devices, and in a Delay/Disruption
Tolerant Network such paths rarely exist.  To enable OAM and Key Management
in such cases, there is a need to standardize alternative methods and their
supporting protocols and data models.

    Extensions to the Bundle Protocol to enable reliability signalling,
tunnelling and Quality of Service indication are needed for the operational
deployment of Delay/Disruption Tolerant Networks, and these capabilities
will be standardized by the Working Group.

    Additional extensions to the Bundle Protocol, additional Security
Context definitions for BPSec, and new Convergence Layer adaptors will be
considered on a case-by-case basis by the working group.

Intentionally excluded from the current Working Group charter is Routing in
DTN, as the topic is considered too open, and candidate protocols suitable
for standardization do not yet exist.  This does not preclude discussion of
potential approaches to the problem of Routing in DTNs within the Working
Group, but personal drafts on the topic will not be adopted under this
charter.

Work Items include:

 * Bundle delivery signalling extension to Bundle Protocol specification
 * Bundle-in-Bundle Encapsulation extension to Bundle Protocol specification
 * Quality of Service indication extension to Bundle Protocol specification
----------------------------------------------------------------------------
----------------------

_______________________________________________
dtn mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/dtn

---

From: "Dr. Ronny L. Bull" <[email-masked]>
Date: Tue, 10 Aug 2021 13:03:22 -0400

+1

Ronny

On Tue, Aug 10, 2021 at 10:45 AM Rick Taylor <[email-masked]>
wrote:

> Hi All,
>
> After some further editing, the AD and chair have what we believe to be
> the final text for the re-chartering of the working group.  I will append
> it to this email.
>
> deployments in space and terrestrial environments, and the technology is
> now used in production by government and commercial organizations
> world-wide.
>
>     The Bundle Protocol v7 defines an encoding of Names for use in DTN,
> but the detailed semantics have not been specified.  The Working Group will
> define a common architecture for the delay/disruption tolerant assignment
> of names, and the late-binding of such names during bundle forwarding to
> end-points within a DTN.
>
> Intentionally excluded from the current Working Group charter is Routing
> in DTN, as the topic is considered too open, and candidate protocols
> suitable for standardization do not yet exist.  This does not preclude
> discussion of potential approaches to the problem of Routing in DTNs within
> the Working Group, but personal drafts on the topic will not be adopted
> under this charter.
>
> Work Items include:
>

---

From: Marc Blanchet <[email-masked]>
Date: Tue, 10 Aug 2021 20:47:03 -0400

Support. I understand that the service registry will be part of Naming and Addressing work.

Marc.

> Le 10 août 2021 à 10:45, Rick Taylor <[email-masked]> a écrit :
> 
> Hi All,
>

---

From: Adam Wiethuechter <[email-masked]>
Date: Wed, 11 Aug 2021 15:15:21 +0000

I will join the chorus of +1's and support this charter.

--------
73,
Adam T. Wiethuechter
Software Engineer; AX Enterprize, LLC
________________________________
From: dtn <[email-masked]> on behalf of Rick Taylor <[email-masked]>
Sent: Tuesday, August 10, 2021 10:45 AM
To: [email-masked] <[email-masked]>
Subject: [dtn] Working Group re-charter text

Hi All,

Cheers,

Rick & Ed

Work Items include:

---

From: [email-masked]
Date: Tue, 24 Aug 2021 07:37:30 +0200

I would propose to replace 

by

* Bundle progress signalling extension to Bundle Protocol specification

We may also be interested in signalling reception / forwarding / deletion 
of bundles and not just delivery.

Regards,
Felix

"dtn" <[email-masked]> wrote on 10/08/2021 16:45:43:

> From: "Rick Taylor" <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Date: 10/08/2021 16:54
> Sent by: "dtn" <[email-masked]>
> 
> Hi All,
> 
> After some further editing, the AD and chair have what we believe to
> be the final text for the re-chartering of the working group.  I 
> will append it to this email.
> 
> 
> The Delay/Disruption Tolerant Network Working Group (DTNWG) 
> specifies mechanisms for data communications in the presence of long
> delays and/or intermittent connectivity.  The Working Group has 
> submitted the Bundle Protocol v7 (BPv7), corresponding Bundle 
> Protocol Security protocol (BPSec) and an interoperable Security 
> Context, and the TCP Convergence Layer specifications for 
> publication as standards track RFCs.  Multiple independent 
> implementations exist for these technologies and multiple 
> deployments in space and terrestrial environments, and the 
> technology is now used in production by government and commercial 
> organizations world-wide.
> 
> This Working Group now focuses on the further work relevant to the 
> area of Delay/Disruption Tolerant Networking (DTN), dividing future 
> work items into 3 broad categories:
> 
>     The Bundle Protocol v7 defines an encoding of Names for use in 
> DTN, but the detailed semantics have not been specified.  The 
> Working Group will define a common architecture for the delay/
> disruption tolerant assignment of names, and the late-binding of 
> such names during bundle forwarding to end-points within a DTN.
> 
>     Existing IETF protocols for OAM and Key Management generally 
> rely on a bi-directional end-to-end path between devices, and in a 
> Delay/Disruption Tolerant Network such paths rarely exist.  To 
> enable OAM and Key Management in such cases, there is a need to 
> standardize alternative methods and their supporting protocols and 
> data models.
> 
>     Extensions to the Bundle Protocol to enable reliability 
> signalling, tunnelling and Quality of Service indication are needed 
> for the operational deployment of Delay/Disruption Tolerant 
> Networks, and these capabilities will be standardized by the Working 
Group.
> 
>     Additional extensions to the Bundle Protocol, additional 
> Security Context definitions for BPSec, and new Convergence Layer 
> adaptors will be considered on a case-by-case basis by the working 
group.
> 
> Intentionally excluded from the current Working Group charter is 
> Routing in DTN, as the topic is considered too open, and candidate 
> protocols suitable for standardization do not yet exist.  This does 
> not preclude discussion of potential approaches to the problem of 
> Routing in DTNs within the Working Group, but personal drafts on the
> topic will not be adopted under this charter.
> 
> Work Items include:
>