Subject: Re: [dtn] New Version Notification - draft-ietf-dtn-tcpclv4-27.txt

From: Rick Taylor <[email-masked]>
Date: Fri, 1 Oct 2021 08:12:26 +0000

Hi Brian,

I’m assuming this is related to the DTN NodeID certificate entry OID?  I suppose the question is really for the OID registry expert reviewers – do they require a ‘full spec’, or just a normative fragment?

I might have missed the original request from the Sec Area – was it direct to you?

Cheers,

Rick

From: Zaheduzzaman Sarker [mailto:[email-masked]]
Sent: 01 October 2021 03:07
To: Brian Sipos
Cc: Lynne Bartholomew; [email-masked]; [email-masked]; Edward Birrane; [email-masked]; [email-masked]; RFC System
Subject: Re: [dtn] New Version Notification - draft-ietf-dtn-tcpclv4-27.txt

Hi Brian,

Not sure, I understand the scope of the changes here and why this would help. Could you please elaborate on those?

BR
Zahed

On 2021-09-30, 21:01, "Brian Sipos" <[email-masked]<mailto:[email-masked]>> wrote:

Zahed,
I have received one more late request from sec area to include a proper ASN.1 module as an informative appendix of the TCPCLv4 document, rather than the informal ASN.1 notation fragments in the IANA Considerations section. Is this something that you support, or prefer not to touch this document any further?

This would not be a change to the specification, only to the form taken by the ASN.1 notation. It would request a new IANA OID allocation for the ASN.1 module itself however. Other existing Other Name Form registrations do provide a full module.

Thank you,
Brian S.

On Mon, Sep 27, 2021 at 10:09 AM Zaheduzzaman Sarker <zaheduzzaman.sarker=[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Based on the discussion and consensus in https://mailarchive.ietf.org/arch/msg/dtn/Clxh1445YjAu-k6QcZ2JP6hViv4/

I approve the changes made in the version -27 on this document.

Thanks to all involved in this process.

BR
Zahed

On 2021-09-23, 19:51, "dtn on behalf of Lynne Bartholomew" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

    Hi, Zahed.  Apologies -- sending to you as the current AD.  Please let us know if you approve the changes made in the new version -27.

    Thank you!

    RFC Editor/lb

    > On Sep 23, 2021, at 9:57 AM, Lynne Bartholomew <[email-masked]<mailto:[email-masked]>> wrote:
    >
    > Hi, Magnus.
    >
    > We are currently editing this document.  Would you please review <https://www.ietf.org/rfcdiff?url2=draft-ietf-dtn-tcpclv4-27> and let us know if you approve these updates?
    >
    > Some items in this latest version (e.g., "III, E. J. B.") have already been fixed during editing, so, after we get your approval, we will implement the additional updates (e.g., new IANA Considerations subsection, new Appendix B) manually.
    >
    > Thank you!
    >
    > RFC Editor/lb
    >
    >
    >> On Sep 22, 2021, at 9:15 PM, [email-masked]<mailto:[email-masked]> wrote:
    >>
    >>
    >> A new version (-27) has been submitted for draft-ietf-dtn-tcpclv4:
    >> https://www.ietf.org/archive/id/draft-ietf-dtn-tcpclv4-27.txt
    >> https://www.ietf.org/archive/id/draft-ietf-dtn-tcpclv4-27.html
    >>
    >>
    >> The IETF datatracker page for this Internet-Draft is:
    >> https://datatracker.ietf.org/doc/draft-ietf-dtn-tcpclv4/
    >>
    >> Diff from previous version:
    >> https://www.ietf.org/rfcdiff?url2=draft-ietf-dtn-tcpclv4-27
    >>
    >> IETF Secretariat.
    >>
    >>
    >

    _______________________________________________
    dtn mailing list
    [email-masked]<mailto:[email-masked]>
    https://www.ietf.org/mailman/listinfo/dtn

_______________________________________________
dtn mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/dtn

---

From: Brian Sipos <[email-masked]>
Date: Fri, 1 Oct 2021 07:18:25 -0400

Rick,
Yes this was sent just to me, it actually originated from the IANA
designated expert for those PKIX registries. I think this was missed in
review of the first registration request, and now there are two regs.

What they prefer is similar to Appendix A of RFC 8398 [2], and they
provided full example so its clear what is wanted. Ultimately they say it's
ADs decision on how to proceed because its late the document flow.

[2] https://www.rfc-editor.org/rfc/rfc8398.html#appendix-A

On Fri, Oct 1, 2021, 04:12 Rick Taylor <[email-masked]>
wrote:

> Hi Brian,
>
>
>
> I’m assuming this is related to the DTN NodeID certificate entry OID?  I
> suppose the question is really for the OID registry expert reviewers – do
> they require a ‘full spec’, or just a normative fragment?
>
>
>
> *From:* Zaheduzzaman Sarker [mailto:[email-masked]]
> *Sent:* 01 October 2021 03:07
> *To:* Brian Sipos
> *Cc:* Lynne Bartholomew; [email-masked]; [email-masked];
> Edward Birrane; [email-masked]; [email-masked]; RFC System
> *Subject:* Re: [dtn] New Version Notification -
> draft-ietf-dtn-tcpclv4-27.txt
>
>
>
> Hi Brian,
>
>
>
> Not sure, I understand the scope of the changes here and why this would
> help. Could you please elaborate on those?
>
>
>
> BR
>
> Zahed
>
>
>
> On 2021-09-30, 21:01, "Brian Sipos" <[email-masked]> wrote:
>
>
>
> Zahed,
>
> I have received one more late request from sec area to include a proper
> ASN.1 module as an informative appendix of the TCPCLv4 document, rather
> than the informal ASN.1 notation fragments in the IANA Considerations
> section. Is this something that you support, or prefer not to touch this
> document any further?
>
>
>
> This would not be a change to the specification, only to the form taken by
> the ASN.1 notation. It would request a new IANA OID allocation for the
> ASN.1 module itself however. Other existing Other Name Form registrations
> do provide a full module.
>
>
>
> Thank you,
>
> Brian S.
>
>
>
> On Mon, Sep 27, 2021 at 10:09 AM Zaheduzzaman Sarker <zaheduzzaman.sarker=
> [email-masked]> wrote:
>
> Hi,
>
> Based on the discussion and consensus in
> https://mailarchive.ietf.org/arch/msg/dtn/Clxh1445YjAu-k6QcZ2JP6hViv4/
>
> On 2021-09-23, 19:51, "dtn on behalf of Lynne Bartholomew" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>     Hi, Zahed.  Apologies -- sending to you as the current AD.  Please let
> us know if you approve the changes made in the new version -27.
>
>     Thank you!
>
>     RFC Editor/lb
>
>     > On Sep 23, 2021, at 9:57 AM, Lynne Bartholomew <
> [email-masked]> wrote:
>     >
>     > Hi, Magnus.
>     >
>     > We are currently editing this document.  Would you please review <
> https://www.ietf.org/rfcdiff?url2=draft-ietf-dtn-tcpclv4-27> and let us
> know if you approve these updates?
>     >
>     > Some items in this latest version (e.g., "III, E. J. B.") have
> already been fixed during editing, so, after we get your approval, we will
> implement the additional updates (e.g., new IANA Considerations subsection,
> new Appendix B) manually.
>     >
>     > Thank you!
>     >
>     > RFC Editor/lb
>     >
>     >
>     >> On Sep 22, 2021, at 9:15 PM, [email-masked] wrote:
>     >>
>     >>
>     [email-masked]
> [email-masked]

---

From: Brian Sipos <[email-masked]>
Date: Mon, 4 Oct 2021 17:09:15 -0400

All,
I'm leaving off the extra IESG addresses for now. The proposed changes are
visible as a difference [3]. There are a number of "false positive" changes
due to xml2rfc <tt> quoting behavior differences [4] from the datatracker
version (xml2rfc no longer double-quotes <tt> in the text output format).
These changes won't be in any eventual datatracker diff.

[3]
https://tools.ietf.org/rfcdiff?url1=https://www.ietf.org/archive/id/draft-ietf-dtn-tcpclv4-27.txt&url2=https://briansipos.github.io/dtn-bpbis-tcpcl/draft-ietf-dtn-tcpclv4.txt
[4] https://trac.ietf.org/trac/xml2rfc/ticket/600

On Fri, Oct 1, 2021 at 7:18 AM Brian Sipos <[email-masked]> wrote:

>> This would not be a change to the specification, only to the form taken
>> by the ASN.1 notation. It would request a new IANA OID allocation for the
>>     Hi, Zahed.  Apologies -- sending to you as the current AD.  Please
>> let us know if you approve the changes made in the new version -27.
>>
>>     Thank you!
>>
>>     RFC Editor/lb
>>

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Wed, 6 Oct 2021 03:01:38 +0000

Hi Brian,

Thanks for the update. I now am aware of the fact that there is a preference to ASN.1 module over code fragments as a module can be checked by an ASN.1 compiler hence have more protection against syntactical invalidity and provides reusability. Hence the changes makes sense.

However, does RFC5912 need to be a normative reference? I don’t think so, it should be informative reference.

BR
Zahed

On 2021-10-04, 23:09, "Brian Sipos" <[email-masked]<mailto:[email-masked]>> wrote:

All,
I'm leaving off the extra IESG addresses for now. The proposed changes are visible as a difference [3]. There are a number of "false positive" changes due to xml2rfc <tt> quoting behavior differences [4] from the datatracker version (xml2rfc no longer double-quotes <tt> in the text output format). These changes won't be in any eventual datatracker diff.

[3] https://tools.ietf.org/rfcdiff?url1=https://www.ietf.org/archive/id/draft-ietf-dtn-tcpclv4-27.txt&url2=https://briansipos.github.io/dtn-bpbis-tcpcl/draft-ietf-dtn-tcpclv4.txt
[4] https://trac.ietf.org/trac/xml2rfc/ticket/600

On Fri, Oct 1, 2021 at 7:18 AM Brian Sipos <[email-masked]<mailto:[email-masked]>> wrote:
Rick,
Yes this was sent just to me, it actually originated from the IANA designated expert for those PKIX registries. I think this was missed in review of the first registration request, and now there are two regs.

What they prefer is similar to Appendix A of RFC 8398 [2], and they provided full example so its clear what is wanted. Ultimately they say it's ADs decision on how to proceed because its late the document flow.

[2] https://www.rfc-editor.org/rfc/rfc8398.html#appendix-A<https://protect2.fireeye.com/v1/url?k=9007ee20-cf9cd725-9007aebb-86959e472243-4295d59cd8f7bff0&q=1&e=df4b36aa-5c3a-463c-9ef1-f67dc037c21e&u=https%3A%2F%2Fwww.rfc-editor.org%2Frfc%2Frfc8398.html%23appendix-A>

On Fri, Oct 1, 2021, 04:12 Rick Taylor <[email-masked]<mailto:[email-masked]>> wrote:
Hi Brian,

Cheers,

Rick

From: Zaheduzzaman Sarker [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 01 October 2021 03:07
To: Brian Sipos
Cc: Lynne Bartholomew; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Edward Birrane; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; RFC System
Subject: Re: [dtn] New Version Notification - draft-ietf-dtn-tcpclv4-27.txt

Hi Brian,

BR
Zahed

Zahed,

Thank you,
Brian S.

BR
Zahed

    Thank you!

    RFC Editor/lb

---

From: Brian Sipos <[email-masked]>
Date: Wed, 6 Oct 2021 08:32:40 -0400

Zahed,
Russ's advice was as an informative reference. This document as a
specification doesn't actually use anything from RFC 5912; the ASN.1 module
defined in this document uses the ASN.1 modules defined in RFC 5912.

If you agree, I will submit this change as a new (final) draft of TCPCLv4.
I will also update my email in the draft to this current address so I stay
on the document distro list.

Thank you for helping sort this all out,
Brian S.

On Tue, Oct 5, 2021 at 11:01 PM Zaheduzzaman Sarker <
[email-masked]> wrote:

> Hi Brian,
>
>
>
> Thanks for the update. I now am aware of the fact that there is a
> preference to ASN.1 module over code fragments as a module can be checked
> by an ASN.1 compiler hence have more protection against syntactical
> invalidity and provides reusability. Hence the changes makes sense.
>
>
>
> On 2021-10-04, 23:09, "Brian Sipos" <[email-masked]> wrote:
>
>
>
> All,
>
> <https://protect2.fireeye.com/v1/url?k=9007ee20-cf9cd725-9007aebb-86959e472243-4295d59cd8f7bff0&q=1&e=df4b36aa-5c3a-463c-9ef1-f67dc037c21e&u=https%3A%2F%2Fwww.rfc-editor.org%2Frfc%2Frfc8398.html%23appendix-A>
>
>
>

---

From: Zaheduzzaman Sarker <[email-masked]>
Date: Wed, 6 Oct 2021 13:17:13 +0000

Hi Brian,

I am also suggesting an informative ref, but as I see in the diff it is listed as normative ref. In that is the case they you need to update the ref list.

Other than that you can submit the changes.

BR
Zahed

On 2021-10-06, 14:33, "Brian Sipos" <[email-masked]<mailto:[email-masked]>> wrote:

Zahed,
Russ's advice was as an informative reference. This document as a specification doesn't actually use anything from RFC 5912; the ASN.1 module defined in this document uses the ASN.1 modules defined in RFC 5912.

If you agree, I will submit this change as a new (final) draft of TCPCLv4. I will also update my email in the draft to this current address so I stay on the document distro list.

On Tue, Oct 5, 2021 at 11:01 PM Zaheduzzaman Sarker <[email-masked]<mailto:[email-masked]>> wrote:
Hi Brian,

BR
Zahed

All,

Cheers,

Rick

Hi Brian,

BR
Zahed

Zahed,

Thank you,
Brian S.

BR
Zahed

    Thank you!

    RFC Editor/lb

---

From: Brian Sipos <[email-masked]>
Date: Wed, 6 Oct 2021 13:48:06 -0400

Zahed,
Oh I think that's just an unfortunate visual side effect of the diff engine
"skipping to change ..." break; the citation was in the informative
section. As you may have seen, a -28 revision has been posted with these
changes. Apparently, the datatracker xml2rfc tool has now been updated to
remove the <tt> quotations as well.

On Wed, Oct 6, 2021 at 9:17 AM Zaheduzzaman Sarker <
[email-masked]> wrote:

> Hi Brian,
>
>
>
> I am also suggesting an informative ref, but as I see in the diff it is
> listed as normative ref. In that is the case they you need to update the
> ref list.
>
>
>
> On 2021-10-06, 14:33, "Brian Sipos" <[email-masked]> wrote:
>
>
>
> Zahed,
>