Subject: [eap] question about AT_MAC text

From: Michael Richardson <[email-masked]>
Date: Wed, 17 Sep 2003 13:35:02 -0400

-----BEGIN PGP SIGNED MESSAGE-----

A25)    Section 12 is said to be authoritative by section 8.1
	Section 8.1 says the contents are message specific.
	How much of the EAP packet is HMAC'ed? All of it, or just
	the EAP-SIM portion?

]      Out and about in Ottawa.    hmmm... beer.                |  firewalls  [
]   Michael Richardson, Sandelman Software Works, Ottawa, ON    |net architect[
] [email-masked] http://www.sandelman.ottawa.on.ca/ |device driver[
] panic("Just another Debian/notebook using, kernel hacking, security guy");  [

_______________________________________________
eap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/eap

---

From: "Joseph Salowey" <[email-masked]>
Date: Wed, 17 Sep 2003 12:25:01 -0700

All of the EAP packet should be HMAC'ed.  Additional data is appended to
the EAP packet and included in the MAC.  The value of this additional
data depends upon the EAP-SIM message type.  

Joe

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Michael Richardson
> Sent: Wednesday, September 17, 2003 10:35 AM
> To: eap
> Subject: [eap] question about AT_MAC text
> 
> 
> ] [email-masked] 
> http://www.sandelman.ottawa.on.ca/ |device > driver[ ] 
> panic("Just another Debian/notebook using, kernel hacking, 
> security guy");  [
> 
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.2.2 (GNU/Linux)
> Comment: Finger me for keys - custom hacks make this fully PGP2 compat
> 
> iQCVAwUBP2hoAYqHRg3pndX9AQEj0AQAlwY6O8sPPutwcx7UbTBRrIwb/+xcqkvI
> uvTQOBlhI/T1kckJSZIyWwnaF2SrH3uqPLtP/gPXcGpc+Kx4T1fF74N/sLAqrpt4
> hU5T9hMTw6tc7T1OMacCUp2L1TVeK52RBJSusDAo4fe2K6DbdnWSKTNBin6e3ZK6
> rlCLlePch7s=
> =1Y6Y
> -----END PGP SIGNATURE-----