Subject: [Atoca] I-D Action:draft-ietf-atoca-cap-00.txt

From: [email-masked]
Date: Mon, 18 Oct 2010 05:30:02 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Authority-to-Citizen Alert Working Group of the IETF.

	Title           : Session Initiation Protocol (SIP) Event Package for the Common Alerting Protocol (CAP)
	Author(s)       : B. Rosen, et al.
	Filename        : draft-ietf-atoca-cap-00.txt
	Pages           : 22
	Date            : 2010-10-18

The Common Alerting Protocol (CAP) is an XML document format for
exchanging emergency alerts and public warnings.  This document
allows CAP documents to be distributed via the event notification
mechanism available with the Session Initiation Protocol (SIP).

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-atoca-cap-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Art Botterell <[email-masked]>
Date: Mon, 18 Oct 2010 07:19:10 -0700

Looks good.

Maybe I should point out, for whatever it may be worth, that CAP is not only an XML specification.  There is also an ASN.1 serialization specified in versions 1.1 and 1.2 as part of the harmonization effort by which the ITU-T co-designated it as x.1303.  A detail, but thought I'd mention it for precision's sake.

Also, I'd suggest that a subscription filter might be added for alert source (<cap:sender>).  In addition to restricting sourcing to identified authoritative sources, which some consumers will wish to do, that might facilitate some sorts of proxy arrangements.

- Art

On Oct 18, 2010, at 10/18/10 5:30 AM, [email-masked] wrote:

> <Mail Attachment>_______________________________________________
> earlywarning mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/earlywarning

---

From: "Thomson, Martin" <[email-masked]>
Date: Tue, 19 Oct 2010 05:49:49 +0800

Hi Art,

The ASN.1 definition (BER serialization? PER?) was something that I was unaware of.  That being the case, we should probably make a statement about it.  Support/don't support?  Mandatory to implement/optional/prohibited?  

If it is possible to carry such a serialization at all, it would seem that we'd need a new media type.

Regarding filtering, that might be a good idea, but the general pattern we've adopted in other groups is to advance filter work as a separate draft.

--Martin (Individual)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Art Botterell
Sent: Tuesday, 19 October 2010 1:19 AM
To: [email-masked]
Subject: Re: [Atoca] I-D Action:draft-ietf-atoca-cap-00.txt

Looks good.

- Art

> https://www.ietf.org/mailman/listinfo/earlywarning

_______________________________________________
earlywarning mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/earlywarning