Subject: [Ecn-in-quic] Volunteers for design team

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 23 Nov 2017 08:40:45 +0000

Hi

The resign team staff is now
Me
Koen De Schepper
Bob Briscoe (not confirmed)
So I believe that we have sufficient critical mass for the ECN usage/encoding aspects.

What is needed is one or two QUIC protocol geek who can look at this from a QUIC protocol/wireline format angle.

Please drop me (or this group) an email if you are interested to join the fun.

With that said.. I see that the spin bit discussion seems to spin out of control, my impression but perhaps I am a pessimist ?.
It is real important that we come up with a clear statement and proposal in this group to avoid the same fate.

/Ingemar
==================================
Ingemar Johansson  M.Sc.
Master Researcher

Ericsson Research
Network Protocols & E2E Performance
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]<mailto:[email-masked]>
www.ericsson.com

The world is full of magical things patiently
    waiting for our wits to grow sharper
               Bertrand Russell
==================================

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 23 Nov 2017 09:08:29 +0000

> So I believe that we have sufficient critical mass for the ECN 
So is this a private group? - I think it shouldn't be, it would be 
foolish for some small subset of the group to propose something on their 
own (see 2 below).
>
> What is needed is one or two QUIC protocol geek who can look at this 
> from a QUIC protocol/wireline format angle.
>
> With that said.. I see that the spin bit discussion seems to spin out 
> of control, my impression but perhaps I am a pessimist ?.
>
> It is real important that we come up with a clear statement and 
> proposal in this group to avoid the same fate.
>
(1) This may be not wishing to have a public readbale header. If we do 
ECN the way we spoke about, the feedback is encrypted, and that doesn't 
have that specific problem.

(2) One snag was that the DT from QUIC "spin" worked in a way did not 
bring all people directly to a document that they supported. We can 
avoid that.

> [email-masked] <mailto:[email-masked]>
>
> www.ericsson.com
>
> _______________________________________________
> Ecn-in-quic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ecn-in-quic
Gorry

---

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 23 Nov 2017 09:15:44 +0000

Hi

No it does not need to be a private group within a group. What I want is however that we have a team that can commit some minimal amount time to get things running, besides the usual chores that they are commited to. 
15 people on a mailing list does not usually mean 15 people working 24/7 on the topic :-) 

You are probably right that we may not end up in the same problem as the spin bit design team, the case for ECN is also better documented than the spin bit.

/Ingemar

> -----Original Message-----
> From: Ecn-in-quic [mailto:[email-masked]] On Behalf Of Gorry
> Fairhurst
> Sent: den 23 november 2017 10:08
> To: [email-masked]
> Subject: Re: [Ecn-in-quic] Volunteers for design team
> 
> So is this a private group? - I think it shouldn't be, it would be foolish for some
> small subset of the group to propose something on their own (see 2 below).
> >
> (1) This may be not wishing to have a public readbale header. If we do ECN
> the way we spoke about, the feedback is encrypted, and that doesn't have
> that specific problem.
> 
> (2) One snag was that the DT from QUIC "spin" worked in a way did not bring
> all people directly to a document that they supported. We can avoid that.
> 
> > /Ingemar
> >
> > [email-masked]
> > <mailto:[email-masked]>
> >
> > www.ericsson.com
> >

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 23 Nov 2017 09:47:11 +0000

> You are probably right that we may not end up in the same problem as the spin bit design team, the case for ECN is also better documented than the spin bit.
Yes I thought that was the case... but we need to be sure.

(i) May be a small writing team is a good way to start
(ii) Maybe a set of committed reviewers to promptly check what we have 
written would also be good.

I'd volunteer for (i), but if I am not needed at the moment as (i), then 
I definitely would like to be (ii)!!!

Gorry
>>> Network Protocols&  E2E Performance
>>>
>>> Labratoriegränd 11
>>>
>>> 971 28, Luleå, Sweden
>>>
>>> Phone +46-1071 43042
>>>
>>> SMS/MMS +46-73 078 3289
>>>

---

From: Bob Briscoe <[email-masked]>
Date: Thu, 23 Nov 2017 12:38:50 +0000

Ingemar,

I can confirm I am available for (i).

Bob

On 23/11/17 09:47, Gorry Fairhurst wrote:
>> No it does not need to be a private group within a group. What I want 
>> is however that we have a team that can commit some minimal amount 
>> time to get things running, besides the usual chores that they are 
>> commited to.
>> You are probably right that we may not end up in the same problem as 
>> the spin bit design team, the case for ECN is also better documented 
>> than the spin bit.
>>
>> /Ingemar
> I'd volunteer for (i), but if I am not needed at the moment as (i), 
> then I definitely would like to be (ii)!!!
>
> Gorry
>>> foolish for some

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 24 Nov 2017 09:57:42 +0100

Hi,

I am happy to do (ii).

/Magnus

-- 

Magnus Westerlund

----------------------------------------------------------------------
Media Technologies, Ericsson Research
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Torshamnsgatan 23           | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------

---

From: Leif Hedstrom <[email-masked]>
Date: Fri, 24 Nov 2017 10:40:38 +0100

> On Nov 23, 2017, at 9:40 AM, Ingemar Johansson S <[email-masked]> wrote:
> 
> Hi
>  

I’m willing to help out here as necessary, just let me know. I do plan on going to Melbourne as well.

— Leif