Subject: [Ecn-in-quic] ECN in QUIC update and questions

From: Ingemar Johansson S <[email-masked]>
Date: Mon, 8 Jan 2018 09:52:54 +0000

Hi

Hope that you have started the new year with lots of new energy.
We (me and Koen) have updated https://github.com/quicwg/base-drafts/wiki/ECN-in-QUIC . The main changes are that a lot of superfluous text is removed, for instance there is now only 1 alternative for the ACK+ECN frame. In addition all the extra text that discussed the timestamps is now gone. The ECN capability check is also clarified. Furthermore it is made possible to set ECT also after the ECN capability check.

There are some questions

  1.  I have added some text that outlines how the overhead can be reduced, this text is somewhat speculative and needs more details to qualify as specification text. Should we have this text in the first draft version or do you prefer that it is removed ?.
  2.  Given that this work is presented at the interim, is it necessary to write up a draft or is it sufficient to present the wiki ?

/Ingemar

==================================
Ingemar Johansson  M.Sc.
Master Researcher

Ericsson Research
Network Protocols & E2E Performance
Labratoriegränd 11
971 28, Luleå, Sweden
Phone +46-1071 43042
SMS/MMS +46-73 078 3289
[email-masked]<mailto:[email-masked]>
www.ericsson.com

The world is full of magical things patiently
    waiting for our wits to grow sharper
               Bertrand Russell
==================================

---

From: "Roni Even (A)" <[email-masked]>
Date: Mon, 8 Jan 2018 11:22:48 +0000

Hi,

I noticed that there are still places where bytes are used instead of packets "sufficient with a report of accumulated number of bytes " and "number of ECT marked bytes(or packets) ".

Are you going to say something about when to use ECT(0) and when ECT(1). Is this a sender decision and how is it made?

I understand that the document will not talk about congestion handling, so is a different congestion handling for ECT(0) and ECT(1) will be discussed in the QUIC recovery draft or do we need another document?

Roni Even

From: Ecn-in-quic [mailto:[email-masked]] On Behalf Of Ingemar Johansson S
Sent: Monday, January 08, 2018 11:53 AM
To: [email-masked]
Cc: Ingemar Johansson S; De Schepper, Koen (Nokia - BE/Antwerp)
Subject: [Ecn-in-quic] ECN in QUIC update and questions

Hi

There are some questions

/Ingemar

Ericsson Research

---

From: Ingemar Johansson S <[email-masked]>
Date: Mon, 8 Jan 2018 11:29:42 +0000

Hi

Thanks, I corrected the bytes-packet error. The document will not talk about congestion handling in this version, this is left was a later exercise and the intention is that ECT(0) and ECT(1) should be handled as per the recommendations in the  ECN experiments draft (soon RFC). The use of ECT(0) or ECT(1) will be a sender decision as the congestion control is on the sender side.

/Ingemar

From: Roni Even (A) [mailto:[email-masked]]
Sent: den 8 januari 2018 12:23
To: Ingemar Johansson S <[email-masked]>; [email-masked]
Cc: De Schepper, Koen (Nokia - BE/Antwerp) <[email-masked]>
Subject: RE: ECN in QUIC update and questions

Hi,

Roni Even

To: [email-masked]<mailto:[email-masked]>

Hi

There are some questions

/Ingemar

Ericsson Research

---

From: "Roni Even (A)" <[email-masked]>
Date: Mon, 8 Jan 2018 12:21:21 +0000

Hi,

My understanding from ECN experiments draft  "It is essential that any such change in ECN congestion marking behavior be counterbalanced by use of a different IETF-approved congestion response to CE marks at the sender"

is that there must be different congestion response for ECT(0) and ECT(1) and it is not specified in ECN experiments draft.

So currently we will not have consistent congestion handling for the two ECT until we specify the congestion handling in QUIC or have some reference.

Roni

From: Ingemar Johansson S [mailto:[email-masked]]
Sent: Monday, January 08, 2018 1:30 PM
To: Roni Even (A); [email-masked]
Cc: De Schepper, Koen (Nokia - BE/Antwerp)
Subject: RE: ECN in QUIC update and questions

Hi

/Ingemar

From: Roni Even (A) [mailto:[email-masked]]
Sent: den 8 januari 2018 12:23
To: Ingemar Johansson S <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: De Schepper, Koen (Nokia - BE/Antwerp) <[email-masked]<mailto:[email-masked]>>
Subject: RE: ECN in QUIC update and questions

Hi,

Roni Even

Hi

There are some questions

/Ingemar

Ericsson Research

---

From: Ingemar Johansson S <[email-masked]>
Date: Mon, 8 Jan 2018 12:32:29 +0000

Hi

As regards to the handling of ECT(0) I would say that https://tools.ietf.org/html/draft-ietf-tcpm-alternativebackoff-ecn-05 provides input.
We can probably specify the response for ECT(0) based CE marking (classic) in the recovery draft as a new section
4.7.7 On CE

ECT(1) handling is still a bit open, it should be scalable, similar to DCTCP but it does not exclude other congestion control algorithms, this is work in progress. I believe though that it is still a bit too early to specify the congestion control algorithm for ECT(1).

/Ingemar

Sent: den 8 januari 2018 13:21

Hi,

Roni

To: Roni Even (A); [email-masked]<mailto:[email-masked]>

Hi

/Ingemar

Hi,

Roni Even

Hi

There are some questions

/Ingemar

Ericsson Research

---

From: "Roni Even (A)" <[email-masked]>
Date: Mon, 8 Jan 2018 12:40:15 +0000

Hi Ingemar,
This is also my understanding and we should clarify this in the document and have some text in the recovery draft referenced by the ECN draft.
I assume that we can recommend at the moment ECT(0) and make ECT(1) optional  saying that it will require a different congestion algorithm (referencing the ECN experiment section 4.2)
Roni

From: Ecn-in-quic [mailto:[email-masked]] On Behalf Of Ingemar Johansson S
Sent: Monday, January 08, 2018 2:32 PM
To: Roni Even (A); [email-masked]
Cc: De Schepper, Koen (Nokia - BE/Antwerp)
Subject: Re: [Ecn-in-quic] ECN in QUIC update and questions

Hi

/Ingemar

Hi,

Roni

Hi

/Ingemar

Hi,

Roni Even

Hi

There are some questions

/Ingemar

Ericsson Research

---

From: "De Schepper, Koen (Nokia - BE/Antwerp)" <[email-masked]>
Date: Mon, 8 Jan 2018 12:44:56 +0000

Hi Roni,

As appropriate ECN congestion response is not only related to QUIC, it should be defined according to your second option: "have some reference".

I think it is important that the ECN-Echo feedback protocol is in place. For now the sender can use ECT(0) with a reno compatible congestion response according to the standards. Additionally, the QUIC ECN-Echo mechanism should support experiments with ECT(1), which I think is the case in the current proposal. It is in line with the Accurate ECN feedback draft, which also supports ECN experimentation. Any experiments that will be defined for ECT(1) (and also ECT(0)) are applicable.

I saw some of your mails too in the meantime. I agree that we should clarify this.

Related to the question of a draft or wiki, this is also my question. Will this finally become a separate draft, or should we organize the wiki as a chapter of an existing QUIC draft that we target? I think it will be the second option here, right? Which draft and chapter should this be?

Koen.

Sent: Monday, January 8, 2018 1:21 PM

Hi,

Roni

Hi

/Ingemar

Hi,

Roni Even

Hi

There are some questions

/Ingemar

Ericsson Research

---

From: "Roni Even (A)" <[email-masked]>
Date: Mon, 8 Jan 2018 12:54:10 +0000

Hi Koen,
I have no preference but I agree that it can be in the current drafts, this is something to discuss with the WG chairs. Drafts, because the frame format should be in the transport  (if with ack then in section 8.16) for the receiver report on ECN. The procedures should be in the  recovery but I am not so sure about the part about ECN capability negotiation where it belongs.
At the moment we can have the proposed solution in the wiki and add there some text about ECT(1)

Roni

From: De Schepper, Koen (Nokia - BE/Antwerp) [mailto:[email-masked]]
Sent: Monday, January 08, 2018 2:45 PM
To: Roni Even (A); Ingemar Johansson S; [email-masked]
Subject: RE: ECN in QUIC update and questions

Hi Roni,

Koen.

Hi,

Roni

Hi

/Ingemar

Hi,

Roni Even

Hi

There are some questions

/Ingemar

Ericsson Research

---

From: "De Schepper, Koen (Nokia - BE/Antwerp)" <[email-masked]>
Date: Mon, 8 Jan 2018 13:40:30 +0000

Ah yes, you are right. It will be spread over different sections and even drafts... We must make sure that the ECN spec does not become too fragmented, either.

Indeed the Chairs have to decide, but it would be good if we would have a proposal or an initial idea. I don't have a good view on the QUIC drafts structure, but I think some other people in our design team have.
Agreed that the frame format could go in the transport draft ACK section 8.16. As for ACK-Blocks the section has (next to the format spec) also some semantics and usage (procedural) explanations, so we could have similar sections there. It could give an overview how and under which conditions ECN is used. The relevant detailed functionality can be collocated near topics that are related. I'll give it a go:

  *   I think the ECN capability check should be collocated with where is described how new connections are set-up.
  *   We might need some description of receiver ECN counters located with text that describe where packets are received per connection (and probable where already ACK sequence counters/state is handled).
  *   Also how these counters are used to fill in the ECN fields in the ACK packet, near where ACK packets are send per connection.
  *   How the counters are used (for congestion control) when the sender receives ACKs is probably what you mentioned for the recovery draft? And where the ECT(0)/ECT(1) text should end up? I guess this is where QUIC congestion window and control is handled (currently only reno?), right?

Anyone who has an idea which drafts/sections these would be? Some of these topics might even end up close to each other, after all?

Koen.

From: Roni Even (A) [mailto:[email-masked]]
Sent: Monday, January 8, 2018 1:54 PM
To: De Schepper, Koen (Nokia - BE/Antwerp) <[email-masked]>; Ingemar Johansson S <[email-masked]>; [email-masked]
Subject: RE: ECN in QUIC update and questions

Hi Koen,

Roni

From: De Schepper, Koen (Nokia - BE/Antwerp) [mailto:[email-masked]]
Sent: Monday, January 08, 2018 2:45 PM
To: Roni Even (A); Ingemar Johansson S; [email-masked]<mailto:[email-masked]>
Subject: RE: ECN in QUIC update and questions

Hi Roni,

Koen.

Hi,

Roni

Hi

/Ingemar

Hi,

Roni Even

Hi

There are some questions

/Ingemar

Ericsson Research

---

From: Ingemar Johansson S <[email-masked]>
Date: Wed, 10 Jan 2018 09:17:57 +0000

Hi

My thoughts...
Frame format:
As I understand things from earlier discussion, the idea is that we create a new frame type, that we can call "ACK_ECN". This frame will contain all the possible elements of the ACK frame, with the ECN block appended at the end.
    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                     Largest Acknowledged (i)                ...
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                          ACK Delay (i)                      ...
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                       ACK Block Count (i)                   ...
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                          ACK Blocks (*)                     ...
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                           ECN Block                         ...
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

                        Figure 7: ACK_ECN Frame Format
This would mean that we create a new section "8.16++" for this in the transport draft
The ECN block is then presented in section "8.16++.1"

  0                   1                   2                   3
  0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|# ECT(0) marked packets (i)                                 ...
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|# ECT(1) marked packets (i)                                 ...
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|# ECN-CE marked packets (i)                                 ...
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Description of ECN capability check:
I believe that this should go into section 7.6 in the transport draft.

ECN counters and how the ECN Block data is filled in:
I don't seem to find any section that describes the reception of packets in the transport and recovery drafts. For lack of better alternatives I then think that a description of this should be in a section "8.16++.2" in the transport draft.

Response to ECN-CE:
This should go into the recovery draft, preferably a new section "4.7.6++" On Packets Marked with appropriate pseudo code. It is for now sufficient that it describes the "classic" behavior (ECT(0)). L4S behavior can be left to later, with a reference to the ECN experiment draft.

/Ingemar

From: De Schepper, Koen (Nokia - BE/Antwerp) [mailto:[email-masked]]
Sent: den 8 januari 2018 14:41
To: Roni Even (A) <[email-masked]>; Ingemar Johansson S <[email-masked]>; [email-masked]
Subject: RE: ECN in QUIC update and questions

Koen.

From: Roni Even (A) [mailto:[email-masked]]
Sent: Monday, January 8, 2018 1:54 PM
To: De Schepper, Koen (Nokia - BE/Antwerp) <[email-masked]<mailto:[email-masked]>>; Ingemar Johansson S <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: ECN in QUIC update and questions

Hi Koen,

Roni

Hi Roni,

Koen.

Hi,

Roni

Hi

/Ingemar

Hi,

Roni Even

Hi

There are some questions

/Ingemar

Ericsson Research

---

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 11 Jan 2018 16:51:11 +0000

Hi
I wrote up a section that describes the suggested addition to section 8.16++ in the transport draft. I was in a bit of a hurry so there are a few potential grammatical/spelling errors.
https://github.com/quicwg/base-drafts/wiki/ECN-in-QUIC#suggested-additions-to-to-become-rfcs

/Ingemar

From: Ingemar Johansson S
Sent: den 10 januari 2018 10:18
To: De Schepper, Koen (Nokia - BE/Antwerp) <[email-masked]>; Roni Even (A) <[email-masked]>; [email-masked]
Cc: Ingemar Johansson S <[email-masked]>
Subject: RE: ECN in QUIC update and questions

Hi

My thoughts...
Frame format:

  0                   1                   2                   3

Response to ECN-CE:

/Ingemar

From: De Schepper, Koen (Nokia - BE/Antwerp) [mailto:[email-masked]]
Sent: den 8 januari 2018 14:41
To: Roni Even (A) <[email-masked]<mailto:[email-masked]>>; Ingemar Johansson S <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: ECN in QUIC update and questions

Koen.

Hi Koen,

Roni

Hi Roni,

Koen.

Hi,

Roni

Hi

/Ingemar

Hi,

Roni Even

Hi

There are some questions

/Ingemar

Ericsson Research

---

From: Ingemar Johansson S <[email-masked]>
Date: Mon, 15 Jan 2018 14:11:39 +0000

Gentlepeople!

I have now written up the suggested draft text in
https://github.com/quicwg/base-drafts/wiki/ECN-in-QUIC#suggested-additions-to-to-become-rfcs

Currently it covers:

  *   ACK_ECN frame format (transport draft)
  *   Capability exchange (transport draft)
  *   Connection migration (transport draft)
  *   ECN reaction (recovery draft)

In addition I have asked for a presentation slot at the interim.

/Ingemar

From: Ecn-in-quic [mailto:[email-masked]] On Behalf Of Ingemar Johansson S
Sent: den 11 januari 2018 17:51
To: De Schepper, Koen (Nokia - BE/Antwerp) <[email-masked]>; Roni Even (A) <[email-masked]>; [email-masked]
Subject: Re: [Ecn-in-quic] ECN in QUIC update and questions

Hi

/Ingemar

From: Ingemar Johansson S
Sent: den 10 januari 2018 10:18
To: De Schepper, Koen (Nokia - BE/Antwerp) <[email-masked]<mailto:[email-masked]>>; Roni Even (A) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Ingemar Johansson S <[email-masked]<mailto:[email-masked]>>
Subject: RE: ECN in QUIC update and questions

Hi

My thoughts...
Frame format:

  0                   1                   2                   3

Response to ECN-CE:

/Ingemar

Koen.

Hi Koen,

Roni

Hi Roni,

Koen.

Hi,

Roni

Hi

/Ingemar

Hi,

Roni Even

Hi

There are some questions

/Ingemar

Ericsson Research