Subject: RE: [Ecrit] Emergency Context Routing of Internet Technologies-Architecture Considerations

From: "Stastny Richard" <[email-masked]>
Date: Wed, 7 Sep 2005 14:17:42 +0200

Andy writes:
> I agree with Richard on this.  But I sense a recurring meta-issue
> here.  Just how much information is to be considered publicly
> visible?  Such as the PSAP URIs or the polygons of the PSAP coverage
> area...

What is the problem with making the polygons publicly visible?
Regarding the URIs:
If you want the terminal to reach emergency services,
you have to give them a URI. Providing them an indirect
URI just shifts the problem, but does not solve it.

There is a similar situation in ENUM: I want to peer on IP
but do not want to give out the address, not to the public,
but also not to the competitors - this is called a Catch 22

Providing security with information hiding is a bad idea:
best example: cryptography

Anybody trying to hide the algorithm failed - see
Bruce Schneier - the only result is that the algorithm
is not tested properly and therefore badly designed

The secret is the key, not the algorithm

-richard

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Andrew Newton <[email-masked]>
Date: Wed, 7 Sep 2005 09:49:02 -0400

> What is the problem with making the polygons publicly visible?

It may be considered a security problem.  Yes, trying to keep  
polygons out of sight is not a perfect or total security solution.   
But that doesn't mean you should make things easy for the bad  
actors.  And if there is any one take away we should have learned  
from protocol design, it is that the perfect security solutions tend  
to be the ones that never get implemented.

> URI just shifts the problem, but does not solve it.

I agree.

-andy