Subject: RE: [Ecrit] Comment on ecrit-requirements-00 item L10

From: "Roger Marshall" <[email-masked]>
Date: Wed, 28 Sep 2005 16:09:45 -0700

I agree that stronger language (MUST) makes the requirement clearer.  I
think the suggested text is good, but should still be separated. I'll
also argue that the context of how a supported CRS is to be used (i.e.
for MAPPING) should also be mentioned as is now worded.

Proposed revision to requirement:

"L10a.  Reference Datum: Implementations MUST support the WGS-84
coordinate reference system for use in mapping emergency calls."

"L10b.  Reference Datum Translation: Any implementation which supports a
different coordinate reference system, MUST support the ability to
perform coordinate transformation to the WGS-84 coordinate reference
system where necessary."

Are we getting closer?

Roger Marshall.

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] 
>On Behalf Of James M. Polk
>Sent: Tuesday, September 27, 2005 4:50 PM
>To: Thomson, Martin; Tim Dunn; Clive D.W. Feather; ECRIT
>Subject: RE: [Ecrit] Comment on ecrit-requirements-00 item L10
>
>I've changed my mind on this matter, and like Martin's wording better.
>
>Remember, this is a requirements ID. Requirements docs say 
>"MUST" a lot.
>
>ECRIT is based on work done in Geopriv, which has a single 
>datum for interoperability - WGS84 - even though endpoints of 
>a communication can choose to use another datum, all MUST 
>support WGS84 (EPSG's CRS 4326, I think).
>
>As Henning pointed out correctly, this isn't about national 
>variants, yet anyone's device has to work in the US, just as 
>US devices have to work elsewhere. If we give in to national 
>variants - we'll lose interoperability on day one to all those 
>not native within their home nation.
>
>We need to specify one datum, and let others be used between 
>devices that negotiate the other datum(s).
>
>At 05:38 PM 9/27/2005 -0500, Thomson, Martin wrote:
>>This sounds remarkably like similar statements I have read on UTF-8 
>>support in XML and many protocol specs.  What you want is a common 
>>baseline that everyone understands, otherwise interoperation becomes 
>>challenging.  I'd suggest a MUST is better.
>>
>>Also the wording that you have chosen could be interpreted as 
>requiring 
>>implementations to convert from arbitrary CRS's.  Instead suggest 
>>something like:
>>
>>"Implementations MUST support the WGS-84 coordinate reference system 
>>for emergency calls.  Implementations MAY support other coordinate 
>>reference systems, but they MUST be able to perform a coordinate 
>>transformation to
>>WGS-84 where necessary."
>>
>>There is a precedent for this sort of statement, see Section 7.8 of:
>>http://www.ietf.org/internet-drafts/draft-ietf-geopriv-pdif-lo
>-profile-
>>01.txt
>>
>>Cheers,
>>Martin
>>
>>-----Original Message-----
>>From: [email-masked] [mailto:[email-masked]] 
>On Behalf 
>>Of James M. Polk
>>Sent: Wednesday, 28 September 2005 2:51 AM
>>To: Tim Dunn; 'Clive D.W. Feather'; 'ECRIT'
>>Subject: RE: [Ecrit] Comment on ecrit-requirements-00 item L10
>>
>>At 09:11 AM 9/27/2005 -0600, Tim Dunn wrote:
>> >I think, yes, we prefer WGS-84 (I read that as the crux of that 
>> >original requirement). But if you're using a coordinate 
>system other 
>> >than WGS-84, you should have a facility that allows you to convert 
>> >from that system to WGS-84.
>> >
>> >By the way I said I preferred must in the second 
>requirement but was 
>> >OK with should (because I thought there would be consternation with 
>> >requiring coordinate transformation).
>> >
>> >So to re-reword to a much more generic set of requirements that:
>> >
>> >A:  The preferred coordinate reference system for emergency 
>calls is WGS-84.
>> >B:  Systems should have an ability to perform coordinate 
>> >transformation between differing coordinate reference systems....
>>
>>...to WGS84.
>>
>>then I agree with this wording
>>
>>
>>
>> >Tim
>> >
>> >
>> >-----Original Message-----
>> >From: James M. Polk [mailto:[email-masked]]
>> >Sent: Tuesday, September 27, 2005 8:46 AM
>> >To: Tim Dunn; 'Clive D.W. Feather'; 'ECRIT'
>> >Subject: RE: [Ecrit] Comment on ecrit-requirements-00 item L10
>> >
>> >At 08:21 AM 9/27/2005 -0600, Tim Dunn wrote:
>> > >Clive-
>> > >
>> > >How about an alternate presentation of the requirement, 
>specifically:
>> > >
>> > >A:  The preferred coordinate reference system for emergency calls 
>> > >is
>> >WGS-84.
>> > >B:  Systems using coordinate reference systems other than WGS-84
>> > >(should/must) have the ability to perform coordinate 
>transformation 
>> > >from
>> >the
>> > >alternate system to WGS-84 and vice-versa.
>> >
>> >Tim
>> >
>> >so what you're saying is:
>> >
>> >          "we prefer you use WGS84, and if you don't, you 
>(should/must)
>> >            convert to/from it"
>> >
>> >..this seems like a MUST to me dressed up to sound more 
>palatable by 
>> >those that don't use it.
>> >
>> >I agree with Clive - we cannot have the words "preferred" 
>and "MUST" 
>> >in the same sentence anywhere.
>> >
>> >
>> > >I feel the best classifier is MUST but I'm OK with SHOULD.
>> > >
>> > >Tim Dunn
>> > >Timothy N. Dunn Consulting
>> > >
>> > >
>> > >-----Original Message-----
>> > >From: [email-masked] [mailto:[email-masked]] On 
>> > >Behalf Of Clive D.W. Feather
>> > >Sent: Tuesday, September 27, 2005 2:07 AM
>> > >To: ECRIT
>> > >Subject: [Ecrit] Comment on ecrit-requirements-00 item L10
>> > >
>> > >Item L10 says that "The preferred coordinate reference system for
>> emergency
>> > >calls MUST be WGS-84".
>> > >
>> > >Firstly, I'm not sure how "MUST" interacts with "preferred".
>> > >
>> > >Secondly, in the UK the preferred coordinate system for emergency 
>> > >services is OSGB National Grid. Emergency services won't easily 
>> > >know what to do
>> with
>> > >a lat-long pair. Even if there is software at each end of 
>the call 
>> > >to do the conversion, it feels the wrong thing to do; 
>furthermore, 
>> > >as I understand it the conversion isn't exact and I'd hate a 
>> > >rounding error to creep in.
>> > >
>> > >--
>> > >Clive D.W. Feather  | Work:  <[email-masked]>   | Tel:   
> +44 20 8495 
>> 6138
>> > >Internet Expert     | Home:  <[email-masked]>  | Fax:   
> +44 870 051 
>> 9937
>> > >Demon Internet      | WWW: http://www.davros.org | 
>Mobile: +44 7973 377646
>> > >Thus plc            |                            |
>> > >
>> > >_______________________________________________
>> > >Ecrit mailing list
>> > >[email-masked]
>> > >https://www1.ietf.org/mailman/listinfo/ecrit
>> > >
>> > >_______________________________________________
>> > >Ecrit mailing list
>> > >[email-masked]
>> > >https://www1.ietf.org/mailman/listinfo/ecrit
>> >
>> >
>> >cheers,
>> >James
>> >
>> >                                  *******************
>> >                  Truth is not to be argued... it is to be 
>presented.
>>
>>
>>cheers,
>>James
>>
>>                                  *******************
>>                  Truth is not to be argued... it is to be presented.
>>
>>_______________________________________________
>>Ecrit mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/ecrit
>>
>>--------------------------------------------------------------
>---------
>>------------------------- This message is for the designated 
>recipient 
>>only and may contain privileged, proprietary, or otherwise private 
>>information.
>>If you have received it in error, please notify the sender 
>immediately 
>>and delete the original.  Any unauthorized use of this email is 
>>prohibited.
>>--------------------------------------------------------------
>---------
>>-------------------------
>>[mf2]
>
>
>cheers,
>James
>
>                                 *******************
>                 Truth is not to be argued... it is to be presented.
>
>_______________________________________________
>Ecrit mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/ecrit
>

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 28 Sep 2005 22:49:23 -0400

I think this is still somewhat confusing, as it is not quite clear who 
is supposed to be doing what. For the mapping protocol server, I think 
we want

"The server MUST understand WGS-84 coordinate reference system and MAY 
understand other reference systems."

I don't see where transformation comes into play, unless we might be 
talking about some hybrid systems mixing coordinate systems within a 
hierarchy of servers. This would seem a bit odd and unnecessarily 
complicated.