Subject: RE: [Ecrit] draft-polk-dhc-uri-00 (big picture)

From: [email-masked]
Date: Mon, 19 Sep 2005 14:12:37 -0400

Henning,

Your (1) may need to be broken down further:

User maps to network,
network maps to location (network itself may be mobile: planes, trains,
automobile, ship),
location then maps to PSAP.

Of course, if the user has GPS, then the above may be short-circuited.

Mike

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Henning Schulzrinne
> Sent: Saturday, September 17, 2005 12:00 PM
> To: 'ECRIT'
> Subject: Re: [Ecrit] draft-polk-dhc-uri-00 (big picture)
> 
> I'm not sure a DNS-vs.-DHCP discussion is all that helpful. 
> Since a lot of messages have gone back and forth, it would 
> help me at least to summarize some of the points and see if 
> we can at least agree on the facts.
> 
> # The system we're building has a number of translations 
> between the "dial emergency number" and the final IP address 
> of the phone of the PSAP call taker, including at least:
> 
> (1) Caller maps location and service desired to PSAP URL, 
> possibly using the mapping URL conveyed in DHCP
> 
> (2) The PSAP URL needs to be resolved via a sequence of DNS 
> translations (NAPTR, SRV, A), each of which has a TTL value, 
> based on standard SIP procedures documented in RFC 3263.
> 
> (3) The DNS resolution points to one or more SIP proxies, 
> which in turn route calls to the next step, either another 
> SIP proxy closer to the call taker or the call taker. Repeat 
> step (2) and (3) until the phone rings.
> 
> 
> # If the PSAP URL(s) are included in the DHCP information, 
> presumably the DHCP server performs step (1) above, for each 
> attached device based on its location. The draft does not 
> really say so, but I'm certainly hoping that this is not 
> manually configured. Presumably, this would take place at the 
> time the client asks for an address or does a DHCPINFORM.
> 
> Let's see if I got the picture right.
> 
> Henning
> 
> 
> 
> _______________________________________________
> Ecrit mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ecrit
> 

_______________________________________________
Ecrit mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ecrit

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 19 Sep 2005 14:25:04 -0400

This is probably true in general, but I'm assuming the availability of 
location information, as that is more of a GEOPRIV rather than ECRIT 
concern. I'm hoping that we agree that the details of how a caller got 
their location information should not matter when determining the PSAP 
URL. As you allude to, the number of possibilities there are rather 
large and may not directly involve any mapping, even without GPS. For 
example, LLDP-MED simply says "hi, your wire is in room 1234" every so 
often.

Also, by mapping I mean the more computer science definition of a 
functional mapping, i.e., an operation that takes one identifier and 
returns one or more other identifiers.

Henning